WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
WordPress HTTPS not compatible with Jigoshop Stripe plugin (7 posts)

  1. vizou
    Member
    Posted 1 year ago #

    This wonderful plugin is unfortunately not compatible with the Jigoshop Stripe plugin... but perhaps it's the Stripe plugin that is incompatible as it requires "force SSL" to be selected in Jigoshop settings. It seems that there is a conflict around this. I tried unchecking the Secure setting from the Pay page to see if that would do the trick but no go... can you help so I don't have to hard code this into htaccess? Thanks!!

    http://wordpress.org/extend/plugins/wordpress-https/

  2. vizou
    Member
    Posted 1 year ago #

    Jigoshop Stripe plugin requires "force SSL on checkout" to be checked. This forces it on ALL pages in my installation. So I believe the problem lies with that requirement... haven't heard anythiny back yet from WP HTTPS author...

  3. nohler
    Member
    Posted 1 year ago #

    I'm having the same issue. I'm trying to use Hostgator's shared ssl but it's not working.

    i was considering just getting a dedicated ssl certificate for the site.

    Is there any new information?

  4. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    You didn't actually say what's happening, just that it's 'not compatible.' That doesn't help me. I'm assuming you're getting redirect loops because WordPress HTTPS has Force SSL Exclusively enabled and Jigoshop's settings are forcing everything to be secure. This causes WordPress HTTPS to always redirect to HTTP and Jigoshop to always redirect to HTTPS. Disable Force SSL Exclusively or add '/' as a URL Filter to secure all of your pages.

  5. vizou
    Member
    Posted 1 year ago #

    It is not possible to leave "Force SSL" unchecked when using the Stripe gateway, even if the HTTPS plugin lets me individually select which pages to use https on, thus the plugin is "incompatible" with Stripe Jigoshop plugin.

  6. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    Again, you still didn't explain what the problem is. Take the time to actually explain what's happening. As for what you did tell me, I don't know if you're talking about the SSL settings in Jigoshop or WordPress HTTPS, so that doesn't help much.

    The fact of the matter is you shouldn't have conflicting settings. If a page is seucred in one plugin, you should secure it in the other. There is code to attempt to fix conflicting settings, but it only works if WordPress HTTPS is activated before (I think) Jigoshop. Either way, there's not a great solution to having mismatched settings and there's nothing I can do to fix it. You just need to make the settings match.

  7. rcabove
    Member
    Posted 6 months ago #

    I am having a similar problem with my wp website that I run for a client.

    Basically, through WooCommerce, I have the Stripe plugin to allow Credit Card purchases through checkout. The problem is, in order for it to work, YOU MUST HAVE 'FORCE SSL FOR CHECKOUT' through the WooCommerce settings. Once this is done, regardless of how you try and access the checkout/cart/pay pages, they now end up in a redirect loop. I was reading elsewhere that this is cause due to the SSL being done by proxy, so the php is_ssl() command cant identify if the page is SSL or not, so it ends up in a redirect loop. Unfortunately, you can't just use a different SSL solution because the "FORCE SSL FOR CHECKOUT' MUST BE TICKED in the WooCommerce settings.

    Any ideas? Getting this running is an absolute MUST for my client.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic