WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
WordPress HTTPS breaks Theme My Login plugin (4 posts)

  1. kaptkaos
    Member
    Posted 1 year ago #

    I am using Theme My Login widget on the home page. When anyone enters their login info the site just sits there for awhile. Then redirects to the login page. When I disable wordpress https, everything works fine. This just started when I upgrade the wordpress HTTPS plug-in.

    http://wordpress.org/extend/plugins/wordpress-https/

  2. gmarsh
    Member
    Posted 1 year ago #

    Try pulling up your login page, and checking the box for "Secure post". It just fixed the problem for me.

  3. gmarsh
    Member
    Posted 1 year ago #

    To clarify, I mean in the Page editor pull up the page named "login" which has your theme-my-login shortcode, and then check that box.

  4. ReactorShop
    Member
    Posted 2 months ago #

    Please insert this code snippet into a plugin or your theme's function.php file:

    /*Fixes the infinite loop when trying to log into the admin page (from a HTTPS page
    */into a HTTP page) by setting the WordPress cookie as not secure.
    function rsssl_secure_cookie( $secure_cookie, $credentials ) {
    	return FALSE;
    }
    add_filter( 'secure_signon_cookie', 'rsssl_secure_cookie', 10, 2 );

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic