WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
WordPress HTTPS 3.3.6 broken in WP 3.8 Parker? (3 posts)

  1. nugai
    Member
    Posted 7 months ago #

    We just updated to 3.8 and now it appears HTTPS is no longer working (Apache web server on CentOS). The WordPress HTTPS plugin dialog does not allow (or does not remember) the setting of a port number for an SSL Host port.

    Individual pages can be forced to SSL via page edit (Enable SSL check box) but the homepage always reverts to HTTP even when accessed via HTTPS. A side effect of this problem is that embedded page links (to HTTPS pages) are also broken.

    All of this (all WP pages being delivered as HTTPS even when accessed as HTTP) has been working properly under WP 3.7. I disabled all plugins we are using to isolate the problem and the problem remains using plain WP 3.8 with WordPress HTTPS 3.3.6.

    Anybody else having similar problems?

    http://wordpress.org/plugins/wordpress-https/

  2. battymonster
    Member
    Posted 4 months ago #

    Yes for me it started about a month ago and was intermittent until yesterday and appears to no longer an intermittent problem. I had to ftp in and delete it's folder from plugins to have access to the admin area. it seems to have left setting somewhere else though, because even though I changed the url in settings general to https: from http: the admin login using https instead off http doesn't work. Or am I assuming something that wrong? My assumption is that now that I changed the site's url to https: that the admin login would now include https: instead of http:? Although I'm currently still able to login and access the admin area using http:

  3. nugai
    Member
    Posted 4 months ago #

    I went through several re-installs and don't remember exactly how I fixed this problem. I vaguely recall issues with VirtualHost settings, location of certificates (SSH config pointing to a different location than SSL/TLS), and/or BulletProof Security. I may have fixed the problem by using a redirect in the httpd config file (forcing all URLs containing wp-admin to use https).

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.