WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WordPress has been installed for over a month. It's asking me to install it agai (31 posts)

  1. ossendryver
    Member
    Posted 2 years ago #

    Hi
    My site is http://www.krugersightings.com/ and It has had wordpress for over a month and a half. for the past week or so i have had on and off problems with my site i had a error 500 but now when i go to the home page it redirects me to the install.php and then about 10 minute later it works and then it happens again.
    I am now getting a decent amount of traffic and i can have my site not working every 5 minutes.
    Please help me!
    Thanks so much.

  2. ravimallya
    Member
    Posted 2 years ago #

    Hey, your website is up and running now. However, have you cross checked your connection strings in wp-config.php file and tried to connect to your database using a PHP connection string. Also, are you having a updated version of WP and the plugins that you're using? If not, update it and check the site. It looks like your host have limited number of mysql queries.
    let me know if you've any further doubts.

  3. ossendryver
    Member
    Posted 2 years ago #

    Hi
    this is what the host said.
    ""
    Hello Sean,

    Thank you for getting back to us.

    The issue which you're experiencing is due to the 'max_questions' for the MySQL database which is being used by the blog. If the MySQL user exceeds the database query limit, which is 75,000 per hour per user, then the WordPress website will be redirected to the installation page or the script is unable to connect to the database and it will be resulted in the error message 'Error Establishing database connection'. This setting is in place to ensure that the MySQL database cannot be overloaded with to many query requests. The queries will reset every hour and is kept by user; however every time the pages on your website are accessed you are still attempting to make queries to the database server. As a temporary fix for this issue you can delete and recreate your user.

    There are many possible causes for the 'max_questions' limit get exceeded. Some of them are:
    * A script is not closing the MySQL connection after accessing the database. In WordPress, such chances are less, however if there is an error in the scripting of a plugin or theme which you're using, then the MySQL connection won't close after querying the database. Hence, please make sure that you close the connection immediately after accessing the database using mysql_close() command from your scripts.
    * Your scripts or pages are hitting too frequently from a specific IP address through brute force tools or manually or from other websites. You can check raw logs available in the /stats directory or check the Visitor Statistics for such possibilities. Using the .htaccess Hotlink Protection and the .htaccess Block IP Addresses would resolve this issue.
    * Using a single database for multiple applications or having too many users for a single database. Also, having same user login for multiple databases which used by multiple instances of WordPress. A solution for this is creating separate databases for separate applications as well as having separate users.

    Being updated with Open Source applications such as WordPress, its themes/plugins/components etc. when an upgrade/patch is available will also help you to prevent such issues.

    Additionally, if you get a lot of traffic for your WordPress blog, then I suggest that you use a caching plugin, such as WP-Super Cache, WP-Total cache etc. Caching plugins will make a file copy of a page and serve that up instead of the original page (refreshing it every so often). This not only speeds up your website a lot, but hits to the cached pages make no SQL queries or database hits whatsoever.

    If you have any further questions, please update the Support Console.

    Sincerely,

    Rodolfo Keller
    Technical Specialist
    ""

    Please help i don't know how to do half of this stuff or what it even means
    Thanks

  4. Tim S
    Member
    Posted 2 years ago #

    WordPress opens Database connections during many of it's tasks. If you have a poorly written plugin that does not close the connection, it can result in having too many open connections. I would suggest installing WP- Super Cache and it should help by storing a copy of the pages and serving those to your visitors.

  5. ossendryver
    Member
    Posted 2 years ago #

    Thanks but im not sure what settings to put the super cache on.
    can you please help me.
    Thanks

  6. ravimallya
    Member
    Posted 2 years ago #

    Have you upgraded your wordpress application and its plugins? just go to Dashboard and from left panel, select Upgrades... check for available upgrades, and if you're not up-to-date, please click on upgrade now button. before doing so, please backup your database through phpmyadmin and files via FTP.
    If you're already up-to-date with the latest version, check this post to get activated with WP Super Cache. it will work on most of the hosting companies.

  7. ossendryver
    Member
    Posted 2 years ago #

    Yeh, everything is up to date.
    The super cache helped get the install page to disappeare but no it takes for ever to load a page and it goes faster only after you reload it like 5 times.

    What is causing this do you think?

    Thanks for all the help so far!

  8. ravimallya
    Member
    Posted 2 years ago #

    How many plugins that you've activated? please deactivate the ones that you actually don't want for your site. Also, install WP Optimize plugin from WordPress Plugins directory and optimize db tables periodically through it. couldn't find any load issues while checking your blog here http://ismyblogworking.com/www.krugersightings.com . if you have intermittent slowness, please contact your host mentioning that.

  9. ossendryver
    Member
    Posted 2 years ago #

    Hi
    I just tried that http://ismyblogworking.com/www.krugersightings.com site and my site now is again suddenly not working. it just loads

    I then tried about 10 minutes later and it then worked.
    It said that i needed to optimize my database which I did.

    I am still worried that it is something else.

    But for now it works thanks!

  10. ossendryver
    Member
    Posted 2 years ago #

    Hi
    I tried again when it wasn't working and this is what http://ismyblogworking.com/www.krugersightings.com Said:

    Your web server [] failed to respond within 15 seconds. The server might have crashed or is suffering a network outage.

    What do I do?
    Please Help!

  11. cubecolour
    ɹoʇɐɹǝpoɯ
    Posted 2 years ago #

    Look at how many queries are used on each page load.

    you can temporarily add <?php echo get_num_queries();?> to your footer to find out

    if you're getting a very high number try deactivating plugins one-by-one to see whether there is one in particular causing it. I once tried a plugin which increased queries from about 20 to over 200 - and the plugin didn't even do anything on the page I was looking at.

  12. ossendryver
    Member
    Posted 2 years ago #

    Hi
    Thanks how do I put it in the footer?

    I can't even get the the footer as i can't get to the dashboard

  13. ossendryver
    Member
    Posted 2 years ago #

    Ok
    I can temporarily get to the dash board.
    So how do i add it to the footer?

  14. ossendryver
    Member
    Posted 2 years ago #

    Ok i think i added it but it doesn't show anyhting.

  15. ossendryver
    Member
    Posted 2 years ago #

    Ok
    It has 204 queries.
    Is that good or bad?

  16. ossendryver
    Member
    Posted 2 years ago #

    I disabled a lot of plugins and it still says 204 queries.
    What else should i do?

  17. cubecolour
    ɹoʇɐɹǝpoɯ
    Posted 2 years ago #

    204 is heavy.

    Did you deactivate ALL plugins - if not? try that to narrow it down. If you already have, temporarily switch to the twenty eleven theme to see how the number of queries changes.

  18. ossendryver
    Member
    Posted 2 years ago #

    But now two things
    1. if i change to the twenty eleven theme would I lose all the settings in this theme?
    2. the menu now in my theme is full of bullet points.

    I'm going crazy with all these problems.

  19. cubecolour
    ɹoʇɐɹǝpoɯ
    Posted 2 years ago #

    1. It *should* keep all your settings when you switch back
    2. Not sure why, but your stylesheet path doesn't look too good: <link rel=”stylesheet” href=”Kruger National Park Sightings” type=”text/css” media=”screen” />

  20. ossendryver
    Member
    Posted 2 years ago #

    Thanks
    Is :<link rel=”stylesheet” href=”Kruger National Park Sightings” type=”text/css” media=”screen” />
    What i should change it to or what?
    and where in the header?

    is that what is causing the bullet points all over the place?

  21. cubecolour
    ɹoʇɐɹǝpoɯ
    Posted 2 years ago #

    I would normally expect to see it in the header.php and pointing to: http://www.krugersightings.com/wp-content/themes/custom-community/style.css - usually something like

    <link rel="stylesheet" href="<?php bloginfo('stylesheet_url'); ?>" type="text/css" media="screen" />

    I've just noticed the ton of css your theme puts in the doc - I guess it has a load of theme options in a theme control panel in admin to customise the css. That could be what's bloating up the number of queries.

  22. ossendryver
    Member
    Posted 2 years ago #

    So then should i chose a different theme even though ive had it for a long time?

  23. ravimallya
    Member
    Posted 2 years ago #

    yes, as said by cubecolour, try to check the number of queries by changing the theme once. You can choose twentyten or twentyeleven theme once and add <?php echo get_num_queries();?> into the footer.php and check the queires.

  24. cubecolour
    ɹoʇɐɹǝpoɯ
    Posted 2 years ago #

    So then should i chose a different theme even though ive had it for a long time?

    Only for testing to find out whether it is your theme or a plugin causing the excessive number of db queries on every page load.

    When checking the plugins did you deactivate all of them? The correct testing procedure is to deactivate all plugins, check how many queries and if it is a lot fewer, reactivate the plugins one-by-one checking how many queries after activating each. Then you will not if it is caused by a plugin and if so, which one.

    Similarly taking the theme out of the equation by activating the default theme will indicate whether that was generating an excessive number of queries. Once you have that data you can switch everything back to how it was.

  25. ossendryver
    Member
    Posted 2 years ago #

    Yeh i did that and i got it down to 100 queries.
    then i went to the support of my host iPage and they submitted it to the technical people.
    hopefully they will solve it!

  26. Tim S
    Member
    Posted 2 years ago #

    http://wordpress.org/extend/plugins/memory-viewer/

    check out this plugin. It may help you figure out where the queries are being generated.

  27. ossendryver
    Member
    Posted 2 years ago #

    Thanks everyone the host has fixed everything!

  28. zemljan
    Member
    Posted 2 years ago #

  29. ravimallya
    Member
    Posted 2 years ago #

    What did they do to fix the issue? Can you please let us know?

  30. cubecolour
    ɹoʇɐɹǝpoɯ
    Posted 2 years ago #

    Perhaps they relaxed the restriction they had imposed.

Topic Closed

This topic has been closed to new replies.

About this Topic