WordPress.org

Ready to get started?Download WordPress

Forums

WordPress hanging while logged in (3 posts)

  1. IndigoJo
    Member
    Posted 1 year ago #

    For several years, my WordPress has had intermittent problems with hanging while I am logged in - this affects loading admin screens and published parts of the blog. The request will take minutes to be acted upon, then retrieve no content - for example, an admin screen will display that says there are no posts or pages, and similarly a post or index screen will show with the themes, heading etc but no content, including the title. This does not affect when I am not logged in (for example, using a Chrome incognito window), does not affect XML-RPC requests (e.g. WordPress for Android or my custom blog posting app QTM), and it does not affect other sites I am running on the same host using Drupal. The problem strikes suddenly - after working fine - lasts about fifteen to thirty minutes and can occur at least once daily.

    I am using the Weaver II theme and the following plugins are active (latest version unless otherwise stated):

    - Akismet
    - Breadcrumb NavXT
    - Brian's Latest Comments (just deactivated this as I am using Disqus)
    - Broken Link Checker
    - Clever Tweet (just deactivated)
    - Custom Post Type UI
    - Disqus Comment System
    - Do Follow (Version 4.0)
    - Fast Secure Comment Form
    - Fidgetr (just deactivated)
    - Jetpack
    - Link Within
    - My Link Order
    - No Frames (version 0.2)
    - Possibly Related Recent Posts (version 1.2)
    - Search Everything
    - Share Buttons by Lockerz / AddToAny
    - Simple Twitter Connect - Base
    - STC - Follow Button Widget
    - STC - Publish
    - Subscribe To Comments
    - Tabbed Widgets (not using, will deactivate)
    - Text Control (version 2.2.3)
    - URL Shortener
    - WP-PageNavi

    In the past, this problem has been solved by eliminating contact with Automattic, such as by disabling stats and Gravatar. I am using Total Choice Hosting. My blog is http://www.blogistan.co.uk/blog/ which is a single site (if you load, you won't have this problem as you are not an admin).

    I have noticed that others have reported slowness when logged in, but it's not that it takes seconds rather than milliseconds to display the data, as others have reported - it's that it doesn't, at all.

  2. You're running a very database-intensive and plugin heavy site and the host database server is probably dropping out. Talk to your host and have them look at the error and mysql logs.

    If they won't, find a new host who can provide better hosting.

  3. IndigoJo
    Member
    Posted 1 year ago #

    I disabled most of the plugins I was using and for several weeks this problem didn't occur. However, in the last week or so I have installed routine updates for Fast Secure Contact Form and Jetpack, and the problem has started again.

    Last time this was happening, I fixed it by disabling WP Stats and Gravatar.

Topic Closed

This topic has been closed to new replies.

About this Topic