WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Gone Wild! (5 posts)

  1. vermontjohn
    Member
    Posted 4 years ago #

    yesterday I did an automatic upgrade to 2.9. When it was done, I got this error. In fact the error is showing all over the place.

    Anyone know how to fix this?

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/n/a/k/nakedinvt/html/barackobama/wp-admin/includes/dashboard.php:719) in /home/content/n/a/k/swordman/html/sensual/wp-includes/class-json.php on line 238

  2. vermontjohn
    Member
    Posted 4 years ago #

    I did just disable some plugins and found the problem to be the INTENSE DEBATE plugin!

    It is disabled and the blog is working fine now and the errors are gone.

    Now....any idea as to what to do about getting Intense Debate to work again???? It seems to be very popular and my site visitors use it constantly.

  3. alism
    Member
    Posted 4 years ago #

    There's a good chance this will be fixed in 2.9.1.

    So you can either install the release candidate for that:
    http://wordpress.org/wordpress-2.9.1-RC1.zip

    Just try the patch if you don't want to install the whole RC:
    http://core.trac.wordpress.org/ticket/11537

    Or if you can hold on 48 hours or so, it'll probably be available through the automatic upgrade when it's officially released.

    If it's still not fixed after that, it might be worth contacting the intense debate author.

  4. pivic
    Member
    Posted 4 years ago #

    I've had the problem with "class-json.php on line 238" and have actually tried switching class-json.php for the one in the RC1 package, but that didn't help.

    I like Intense Debate! Will contact them to see what's up.

    Thanks a lot for the solution!

  5. Beau Lebens
    Member
    Posted 4 years ago #

    Hi All (and thanks for the email pivic),

    It seems that there are a few things going on here:

    1. Some people don't have the core PHP JSON extension installed/enabled, so they require an additional library to be loaded for certain things (e.g. IntenseDebate) to work.
    2. WP 2.9 introduced a new core JSON library, which will override the one included in IntenseDebate. That should theoretically be fine but
    3. 2.9's JSON library also had a bug in it, where it was sending unnecessary headers to the browser.

    This problem only seems to manifest itself on a server where the JSON extensions are not enabled, and where you're running WP 2.9.

    The ideal solution is to enable JSON on your server, but unless you have full control over your server, that's probably not possible. @pivic you said that you tried getting the class-json.php from RC1 -- was that specifically for wp-includes/class-json.php?

    Can other folks please try replacing their WP file at wp-includes/class-json.php with this one: http://core.trac.wordpress.org/browser/trunk/wp-includes/class-json.php (use the links down the very bottom to download).

    If that doesn't work, please let me know what version of PHP you're using on your server so that I can look into this a bit more, as I'm not actually seeing this error on any of my installs so it's tricky to debug.

    Thanks for your help and patience!

    Beau (from IntenseDebate)

Topic Closed

This topic has been closed to new replies.

About this Topic