WordPress.org

Ready to get started?Download WordPress

Forums

WordPress generating a lot of 404 pages, after changing permalinks (18 posts)

  1. Fernicz
    Member
    Posted 1 year ago #

    Hi,

    I installed wordpress in July, before writing content I decide to change the permalink to /%category%/%postname%.html after writing about 20 content in mid-August, I registered my website to Google Webmaster.

    A few days ago when logged into google, I get notification if all posts on my website linking to 404 Not found pages. For examples:

    mysite.com/1st-category/my1stpost.html linking to --> mysite.com/1st-category/134564748480000
    mysite.com/2nd-category/my2ndpost.html linking to --> mysite.com/2nd-category/134560846340000
    mysite.com/3rd-category/my3rdpost.html linking to --> mysite.com/3rd-category/134526384920000

    and so on, and now I found 89 not found (404) pages ...

    I dont know where "/1345.....0000" pages come from, is this wordpress permalink issue ?

    Regards,
    Feronica

  2. mbrsolution
    Member
    Posted 1 year ago #

    Hello have a read on this links about permalinks

    http://codex.wordpress.org/Using_Permalinks

    Kind regards

  3. Fernicz
    Member
    Posted 1 year ago #

    Yes i have read about it,
    I think only Googlebot can find the 404 pages,
    I can't find the 404 linking from all my post, although I search our through source page nor fetch it via webmaster...

  4. mbrsolution
    Member
    Posted 1 year ago #

    Install this plugin http://wordpress.org/extend/plugins/redirection/

    It helps you find any 404 error links on your website plus it has a log file to help you.

    Kind regards

  5. Tiggerito
    Member
    Posted 1 year ago #

    I've got the same problem on a non WordPress website. Some of us affected are trying to track down the source of it in a Google thread:

    https://productforums.google.com/d/topic/webmasters/zvez-eib0Ao/discussion

    I'm currently suspecting Disqus. Are you using it?

  6. Fernicz
    Member
    Posted 1 year ago #

    @tiggerito,
    yes I'm using disqus, have you resolve your problem ?
    maybe I should remove disqus and see the result.

  7. Tiggerito
    Member
    Posted 1 year ago #

    No confirmation on the answer yet.

    Removing Disqus may help confirm the issue. But it may not. Google has probably found all the fake pages already and will take it's own sweet time removing them. It should stop more pages being found though.

  8. Tiggerito
    Member
    Posted 1 year ago #

    A Googler has joined in the forum post I referenced above and said they are looking into it.

  9. Fernicz
    Member
    Posted 1 year ago #

    @Tiggerito, That's Good News...
    Hope it resolve soon...

  10. mbrsolution
    Member
    Posted 1 year ago #

    That's good news, I am also interested in the answer...

    Kind regards

  11. Fernicz
    Member
    Posted 1 year ago #

    1345 not found page still crawled by Google bot, although disqus plugin has been removed.

    @Tiggerito, what about your site, increasing 404 alert on Webmaster Tools ?

  12. mbrsolution
    Member
    Posted 1 year ago #

    Log into your Google account if you have one. Open your Webmaster Tool and remove that url path from your list make sure that it is also removed your sitemap.xml file.

    If the page is totally deleted, sooner or later Google will remove it from the search and also from cache. If that page is meant to be redirected to another page then do that as well.

    Kind regards

  13. Tiggerito
    Member
    Posted 1 year ago #

    @mbrsolution could you provide evidence for this being a good action to take. I don't see any benefit or evidence that what you say will happen.

  14. Tiggerito
    Member
    Posted 1 year ago #

  15. Tiggerito
    Member
    Posted 1 year ago #

    @Fernicz Mine have head steady since the 7th

    Just spotted two other websites of mine (WordPress+Disqus) are also doing it.

    That's all of mine with Disqus installed are causing the 404s.

    It looks like Google is crawling new ones every several days and causing jumps in the error counts.

    No more news from Google. Disqus said they are also "looking into it":

    http://www.seroundtable.com/disqus-google-errors-15663.html

  16. Tiggerito
    Member
    Posted 1 year ago #

    Googler John Mueller just reiterated his stance regarding this issue...

    "I wouldn't worry about these 404 errors -- when we discover URLs in various places, we just want to double-check them to make sure that we're not missing anything. These crawl errors won't affect the rest of your site's crawling, indexing, or ranking. If you are seeing changes in your site's performance in search, they would not be due to these crawl errors & I'd recommend starting a separate thread for those issues."

    https://productforums.google.com/forum/#!msg/webmasters/zvez-eib0Ao/tfRKzkXqMEsJ

  17. ocnycmac
    Member
    Posted 1 year ago #

    I was getting the 404 error on everypage after making like 20 pages and deciding to change my permalinks from the default to the name of the page setting, but only the main frame I guess you call it was missing from everypage. I was still getting the logo and the menu on top and the links in the status bar of my browser when I hover the mouse over them were updated with the names like I wanted but they all gave me the 404 error. I even thought I had messed up my site after installing some plug-ins and started it all over again! lol. The second time around was that I noticed that it was after changing permalinks because if I put it back to the default everything worked. So I started searching online and found many other articles but no answer worked for me. Good news is I found the fix easily, I didn't think it could be the problem. My site is stored in a secondary folder not in the root of my hosting account. When I first created the site I went to settings>general and modified the "site address URL" to the root of my hosting account not the secondary folder and left the "WordPress Address URL" as it was which had the secondary folder where my files were. I thought it went like that because I was going to give my address to people without the "/secondaryfoldername" in it. When I changed it back to the way it was with the secondary folder included like it was on top in the "wordpress address URL" field the problem was fixed and I kept my name permalinks the way I wanted them! Hopefully this help anyone who may be getting the 404 and ends up on this page from searching like I did. I am sure many get the 404 error because they got confused there like I did and then changed permalinks and got the error. I figured it out alone as there are not that many answers on that issue online. I am back to normal as of now, just building the site.
    Check it out at: http://www.makedollarsdaily.net

  18. mbrsolution
    Member
    Posted 1 year ago #

    If you install the latest version of WordPress 3.5.1 and later on decide to change the permalink to something like /%category%/%postname%/ or simply /%postname%/, you have to make sure that you have also made changes to your sitemap.xml file.

    You also have to upload it to Google webmaster tools, bing would also be an advantage. That way the aforementioned search engine will update the links to your site quicker. You could also set up a rule in your .htaccess file to implement the changes made to your permalink.

    You might also have to install a redirect plugin at the beginning to help users find your new URL's. After a while you can remove or delete the redirect plugin.

    I hope this helps anyone deciding to make changes to your permalinks.

    Kind regards

Topic Closed

This topic has been closed to new replies.

About this Topic