WordPress.org

Ready to get started?Download WordPress

Forums

[closed] WordPress Failure Notice on logout (14 posts)

  1. keithvb
    Member
    Posted 1 year ago #

    When I logout by clicking the "Sign Out" tab in the navbar, I get:

    "You are attempting to log out of Eating Honestly
    Do you really want to log out?" "log out" is a link and
    "WordPress Failure Notice" appears in the FF page tab.

    When I click the "log out" link it takes me to the standard WP login.

    When I click "Sign Out" I'd like to go to the original login page

    The Sign Out menu item is a custom menu item with the link:
    http://eatinghonestly.com/wp-login.php?action=logout&_wpnonce=57a8b92a70
    The value"57a8b92a70" doesn't seem to matter. It can be anything.

    Something is wrong with the logout link I supect...

    Using WP 3.4.2 and a child theme based on TwentyEleven in WinXP
    Site is eatinghonestly.com, temporary login is test, pwd test

    What should I try?

  2. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    Deactivate all plugins and revert to Twenty Eleven and see if the problem persists.

  3. keithvb
    Member
    Posted 1 year ago #

    Krishna,

    Thanks for responding...

    When I revert to Twenty Eleven the navbar items disappear and I can't logout, so I just deactivated all the plugins on my child theme and there was no change.

    Any other suggestions?

    Keith

  4. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    Can you deactivate plugins and revert to Twenty Eleven theme so that I can check the results and find out what is wrong. Please do and report back.

  5. keithvb
    Member
    Posted 1 year ago #

    Reverted to Twenty Eleven
    All plugins deactivated

    thanks,

    K

  6. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    It seems it is a case of incomplete WordPress installation. Backup everything and reinstall WordPress.

  7. jitenoswal1
    Member
    Posted 1 year ago #

    Even I'm facing this problem :(
    can someone please help me out ..

  8. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    @jitenoswal1,

    Please start your own topic so that you will get better attention and help.

  9. jitenoswal1
    Member
    Posted 1 year ago #

    I will .. but I guess the problem which @keith happened to gone through is same as mine .. :( I hope the solution might be same as well ..

  10. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    No. Are you using the same server, plugins, themes, etc?

  11. jitenoswal1
    Member
    Posted 1 year ago #

    nope .. :/ but the same plugin woocommerce .. :/

  12. Bradley A.
    Member
    Posted 1 year ago #

    The same thing started with my blogs today, and it's obviously been a problem for a few years now from what I've found by searching here and on Google.

    From what I've experienced and read so far, it's definitely related to an incorrect nonce check somewhere, but I haven't found a solution yet that doesn't involve hard-coding in a core file, which I would prefer not to do.

    You can switch to any theme, deactivate and reset all your plugins, and it will keep doing it intermittently. SOMETIMES if you clear your cache and restart your browser it will help, but even then you can't tell. :D

    Just to throw this out there: Is anyone else using a social login/commenting plugin, as well, such as LoginRadius? I've never had a problem with it before, but I've noticed that when I log out now, it screws up my comment box considerably. If I deactivate LoginRadius, it fixes the comment box, although I still get the weird non-logout thing. Not sure if that means anything or not, but thought I would ask and hopefully get someone with more coding experience thinking in a different direction, maybe.

    It would definitely be helpful to find a fix for this. It's extremely irritating, and it's been happening to others for quite a while. I am subscribing to this post, and anxiously awaiting a quick resolution, as well.

  13. Bradley A.
    Member
    Posted 1 year ago #

    @Krishna - Re-installing WP does not correct the issue.

    @Jiten - Your email address is not listed. My site url is http://www.bradleyanderson.me

  14. Don't email anyone.

    Folks, if you're not going to offer help on the forums, you're in the wrong place.

    Bradley, please make your own topic since you don't have the exact problem (you have different plugins and themes etc). I know you think it's the same, but from a support perspective you guys make it much harder for us to help you when multiple people muddy the issue.

Topic Closed

This topic has been closed to new replies.

About this Topic