WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Email Notification Plugin v2.3.1 (73 posts)

  1. briangroce
    Member
    Posted 8 years ago #

    The Word Press Email Notification Plugin has been updated to version 2.3.1.

    Updates to this version:

    * Blog names with commas now display correctly in the from field
    * Changed the default location to look in the WP directory for the wpemn_config.php file
    * Updates the sent flag before sending future dated posts in order to cut down on duplicate e-mails being sent

    If you see anything that looks like a bug or the documentation needs corrected, please comment on the Watershed Studio blog.

  2. fuzzie
    Member
    Posted 8 years ago #

    Well, I have looked through the docs, and I can't seem to figure out why the admin part isn't working.

    http://mydomain.com/wp-admin/wp-email-notification/index.php
    gives me a 404 error.

    Did I miss a step?

    Also, I populate the form with "Enter Email Here", which disappears when someone tries to register...however, I get a couple of yahoos trying to just click the "Subscribe" button without adding their email...is there a way to restrict a submission to block "Enter Email Here"?

    Thanks for a great plugin!

  3. tonyzeoli
    Member
    Posted 8 years ago #

    I'm having the same problem with the plugin, a 404 error. I commented out line 19, but I don't understand what the instructions mean by "tweaking" the file? You should explain what you mean by "tweak". Do I change


    include ("$_SERVER['DOCUMENT_ROOT']/maillist/wpemn_config.php");

    to something else? It should just be calling into wpemn_config.php to get the server information, no?

  4. plusspecialguests
    Member
    Posted 8 years ago #

    Everything installed fine, and I've used an older version of this plugin successfully at http://www.rattleheadhq.com/wordpress

    But on http://plusspecialguests.wyger.nl/index.php it seems to be another story.

    As I say, everything installed fine, but there seems to be an error at sign up.

    I get the following:
    Warning: mail() has been disabled for security reasons in /vhost/usr/plusspecialguests/maillist/index.php on line 217
    Thanks for subscribing.
    You will receive an email shortly to confirm your subscription.
    Once you confirm your subscription you will begin to receive
    notifications when there is +SG news!.

    Close this window to go back

    I realise the program thinks everything is OK, but something has blocked the email from sending.

    Any suggestions?

  5. gbox
    Member
    Posted 8 years ago #

    Hello,

    I just installed the plugin, works fine so far! But, I think the most important function (for me) is not implemented yet: I would like to see the plugin send mails when there is a "external" message posted in the blog, in my case a automatic post from flickr.com. When this messages are posted there is not send any mail to my users.
    What can I do?

  6. herold
    Member
    Posted 8 years ago #

    Is it possible to replace the blank text messages with wordpress pages?

  7. electrolund
    Member
    Posted 8 years ago #

    Any idea why this plugin would be interfering with the Gallery2 plugin WPG2? See this page for some odd errors.

  8. RustedWire
    Member
    Posted 8 years ago #

    I just upgraded to WP2.0.1 and now this plugin isn't working for me, although it was when i have WP1.5. Anyone help?

  9. electrolund
    Member
    Posted 8 years ago #

    Never mind on the above post. I figured out. WPG2 has an option to use a custom header file instead of the theme's header.php. I just modified that one to remove the Email Notify code. All works well now!

  10. dkabal
    Member
    Posted 8 years ago #

    Where's that option to set which header.php gets used?

    I've tested, and no e-mails are currently emerging from the subscription (using WP2.01, e-mail notif. 2.3.1). I've only editted the header.php in my template's folder.

    I tried putting the line:

    <?php email_notification_future_send(); ?>

    in the "header" div, and also within the <head> section of the header.php file, still no notifications.

    Does anyone know what I'm doing wrong?

  11. electrolund
    Member
    Posted 8 years ago #

    Here's what I did to get it working. I copied the header.php in my theme directory and changed the name to wpg2header.php. Then in the Gallery2 options page, under the Style Options tab, click the "Use WP Custom Header". By default, it will look for a wpg2header.php file. Then in that new header file, remove the notify code.

    Pretty simple.

  12. jcjdoss
    Member
    Posted 8 years ago #

    Warning: mysql_connect(): Access denied for user: 'www-data@localhost' (Using password: NO) in /home/thetrailermart/public_html/wordpress/wp-content/plugins/wp-email-notification/index.php on line 45

    Warning: mysql_select_db(): supplied argument is not a valid MySQL-Link resource in /home/thetrailermart/public_html/wordpress/wp-content/plugins/wp-email-notification/index.php on line 46

    What does this mean!!! I'm going nuts

  13. sadish
    Member
    Posted 8 years ago #

    I got the same error as jcjdoss.

    any help ?

  14. acanay
    Member
    Posted 8 years ago #

    guys .. do you have this message in header ?

    if so ... you have to past:
    <!-- newsletter ........... -->
    <?php email_notification_future_send(); ?>
    <!-- /newsletter -->

    pasting the <?php email_notification_future_send(); ?>
    it's not enough :-)

    anyway .. if anybody knows why the plugin doesn't send emails with posting new post ?? don't be shy and write about it :-)

  15. acanay
    Member
    Posted 8 years ago #

    finnaly everything is working fine. only the email is send about 3 hours later and don't ask me why :-)
    but IT DOES WORK :-)

  16. nmallory
    Member
    Posted 8 years ago #

    There is an issue in email_notification_2.3.1.php with the way the date is handled which is why there is a delay in when the email notification is sent out. Here is how I fixed it.

    I replaced:
    $curr_date = date("YmdHi");
    $date_diff = $curr_date - $post_date;

    With:
    $post_dat2 = $postdata['Date'];

    And replaced:
    if ($date_diff < 0){

    with:
    if ($post_dat2 > current_time('mysql')) {

    This appears to have resolved my issue.

  17. herold
    Member
    Posted 8 years ago #

    @nmallory

    Does this resolve the delay after posting as well or only when you do a mailing to all subscribers from the admin panel?

  18. kcgbjc
    Member
    Posted 8 years ago #

    I have installed this per instructions, but when I go to subscribe an email from the main page, all I get is a white page with, "} } ?>"

    What's happening?

  19. nmallory
    Member
    Posted 8 years ago #

    herold - I haven't ever emailed everyone from the page, but it does resolve the delay which is what I was trying to fix. I know someone else asked me for the fix and used it to his satisfaction. If it fixes your issue too, will you come back and let me know?

    I honestly don't think there isn't a plugin I haven't gone digging in at some point for tweaking or curiousity. Unforturnately, I'm not not clear on my PHP yet. ;)

  20. herold
    Member
    Posted 8 years ago #

    @nmallory

    I edit my php file today and applied the fix. I will test over the next few days and post back here my results.

  21. BrittMalka
    Member
    Posted 8 years ago #

    Hi

    I've tried both nmallory and acanays tips, but still no mails are send when I post on my blog.

    WordPress is version 2.0.2, Email Notification Plugin is version 2.3.1.

    Any other ideas?

  22. MichaelChan
    Member
    Posted 8 years ago #

    My problem is even more serious than jcjdoss'. This was the message that came out:

    WordPress Email Notification Plugin v2.3.1 Admin Area

    Warning: main(/home/tental2/public_html//maillist/wpemn_config.php): failed to open stream: No such file or directory in /home/tental2/public_html/wp-content/plugins/wp-email-notification/index.php on line 19

    Warning: main(/home/tental2/public_html//maillist/wpemn_config.php): failed to open stream: No such file or directory in /home/tental2/public_html/wp-content/plugins/wp-email-notification/index.php on line 19

    Warning: main(): Failed opening '/home/tental2/public_html//maillist/wpemn_config.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/tental2/public_html/wp-content/plugins/wp-email-notification/index.php on line 19

    Import Addresses :: Export Addresses :: Remove Addresses :: Email List Subscribers :: Update Settings

    Warning: mysql_connect(): Access denied for user: 'tental2@localhost' (Using password: NO) in /home/tental2/public_html/wp-content/plugins/wp-email-notification/index.php on line 45

    Warning: mysql_select_db(): supplied argument is not a valid MySQL-Link resource in /home/tental2/public_html/wp-content/plugins/wp-email-notification/index.php on line 46

    I'm quite a newbie when it comes to coding. After fiddling around with WordPress, I kinda get the feeling why people still don't use Linux or any open source software...

  23. acanay
    Member
    Posted 8 years ago #

    MichaelChan: ha ha ... why you have an empty directory ?
    "public_html//maillist/" .. double // or it's only a "shortcut" ??

    guys .. anytime I post something I do not use email notif. :-)
    just go to your manage-email notif-Email List Subscribers and email them :-)
    don't forget to past a link to your new post ... I know it's not what you want but it does work :-)

  24. rohit4all
    Member
    Posted 8 years ago #

    Dear Friend,
    I downloaded I install this pluggin and followed above 5 step correctly. But I do not know how to activate and from where" As mention below

    6. Activate the plugin.

    7. Put form code in template...

    <form method="post" action="maillist/index.php">
    Enter your e-mail address to receive notifications when there are new posts

    <input type="text" name="email" size="12" maxlength="36" />
    <input type="submit" name="submit" value="sign up" />
    </form>

    8. In your template header file, add this line...

    <?php email_notification_future_send(); ?>

    9. The admin options can be found under Manage > Email Notification

    10. Post...

    You'll see a notify drop down in the Write area

    ""

    Pls reply how I can activate plugin.

  25. Michael Bishop

    Posted 8 years ago #

    You activate plugins via your dashboard admin panel.

    There should be a tab for plugins, then a button to activtate/deactivate the plugin.

  26. rohit4all
    Member
    Posted 8 years ago #

    Yeah but in dashboard admin panel there is not any plugin on the name of email notification.

  27. Michael Bishop

    Posted 8 years ago #

    Are you sure the file is uploaded to your plugins directory?

  28. rohit4all
    Member
    Posted 8 years ago #

    Thanks miklb,

    I got it actually I have not uploaded plugin file. now its working nicely. at http://www.gmatindia.com

    Thanks a lot.

  29. rohit4all
    Member
    Posted 8 years ago #

    Now my question is

    ""Can I place this email subcription form(code/page) on my index.htm homepage of my website and forums/index.php an phpbb forum.which running on same domain. when a person subcribe this he can receive latest updates of forum.

  30. rohit4all
    Member
    Posted 8 years ago #

    any answer ?? still waiting ..

Topic Closed

This topic has been closed to new replies.

About this Topic