WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Email Notification Plugin v2.2 (45 posts)

  1. briangroce
    Member
    Posted 9 years ago #

    The Word Press Email Notification Plugin has been updated to version 2.2.

    Download

    Updates to this version:
    * Added a template option for HTML emails (a HUGE hat tip goes out to Jeff Mikels for this functionality)
    * Added option for admin to remove people from the list

  2. argentine
    Member
    Posted 9 years ago #

    Nice and easy o install. Thanks

  3. Dgold
    Member
    Posted 9 years ago #

    Brian, plugin looks great, I want to try it. Before trying it, I was looking for a feature on your page -- to limit notifications to 1 (or 2) categories. I don't want to email All categories because I am going to stay busy back-logging back-dated posts for quite some time (until I finish some non-importable archives), and I don't want people getting dozens of out-dated emails.

    I saw this in your To Do List:
    "Add notification only on specific categories (readers choice at signup)"

    and wondered if it already has the feature for the admin to choose the categories sent?

    I'll post a comment on your blog if I don't hear a response here.

  4. briangroce
    Member
    Posted 9 years ago #

    Currently you can choose on a per-post basis (there's a drop down to select).

    If by default you only wanted to send for specific categories you'd need to change the query in the code.

  5. Servant
    Member
    Posted 8 years ago #

    I’ve been experimenting with this plugin and have several accounts (e.g. gmail, msn, my own, etc.) that I’ve sent the html formatted message to see how it appears. I am sending the full content of the post and for some reason in MS Outlook there are no scroll bars. It just seems to cut the message off. This is not the case for web-based email readers, which work fine. Has anyone else seen this problem or can offer a solution? Thanks.

  6. sense4design
    Member
    Posted 8 years ago #

    This plugin gives erros under wordpress 1.5.2
    I get this error in wp-admin

    Warning: main(/maillist/wpemn_config.php): failed to open stream: No such file or directory in /home/sense4de/public_html/rossifiles/wp-content/plugins/wp-email-notification/index.php on line 19

    Warning: main(/maillist/wpemn_config.php): failed to open stream: No such file or directory in /home/sense4de/public_html/rossifiles/wp-content/plugins/wp-email-notification/index.php on line 19

    Warning: main(): Failed opening '/maillist/wpemn_config.php' for inclusion (include_path='.:/usr/local/lib/php:/usr/lib/php') in /home/sense4de/public_html/rossifiles/wp-content/plugins/wp-email-notification/index.php on line 19

    After upgrading to 1.5.2 from 1.5 this plugin stopped working.

    Can anybody pleas ehelp me?

    Thank you
    Vidal

  7. erikankrom
    Member
    Posted 8 years ago #

    1. If your installation of WordPress isn't located at:

    yoursite.com/your-wordpress-directory/

    And the maillist directory isn't located at:

    yoursite.com/maillist/

    You *WILL* need modify the code to match your server settings

    In: yoursite.com/your-wordpress-directory/wp-content/plugins/wp-email-notification/index.php

    a. Line 19 *WILL* need to be updated...

    line 19: include ("$DOCUMENT_ROOT/maillist/wpemn_config.php");

    b. If your maillist directory is located in your wordpress directory,
    you can use this instead of line 19

    line 22: include (ABSPATH."/maillist/wpemn_config.php");

  8. kahnoya
    Member
    Posted 8 years ago #

    Great plug-in! Quick question...

    I was modifying the 'email_notification_2.2.php' file to change the plain text format. Now I get this error:

    Parse error: parse error, unexpected '?' in /home/iloveco/public_html/read/wp-content/plugins/wp-email-notification/email_notification_2.2.php on line 104

    I never touched line 104, but I'm thinking it messed up after decompressing the .zip file. Should there be special characters where the ?'s are?

    Line 104
    $post_content = str_replace(array("??,"??","??,"??,"??,"??," "), array('"','"','?,'?,'?,'...',' '), $post_content);

  9. kahnoya
    Member
    Posted 8 years ago #

    Fixed... just decompress the .zip file on an EN system.

  10. cpjolicoeur
    Member
    Posted 8 years ago #

    I seem to be having a problem with this plugin not sending an email for posts created using xmlrpc.php. I use w.bloggar on windows and ecto on the mac, and making blog posts with either of these programs do not seem to be sending out the email. Only emails made through the wordpress web interface actually send out the email message.

    I thought is was related to this bug fix http://trac.wordpress.org/ticket/967 which supposedly should have fixed it with version 1.5.2 which I am running. However, I still seem to be having the same problem. Any ideas?

  11. cpjolicoeur
    Member
    Posted 8 years ago #

    any help with the publish_post() issue i mentioned when using ecto and w.bloggar??

  12. SergioHernando
    Member
    Posted 8 years ago #

    Hi,
    Just implemented the plugin. Everything works fine, but my blog operates with charset=ISO-8859-15″, and once HTML mails are sent by the plugin, they seem to be formatted with other charset, such as UTF8, as special characters are not properly displayed.

    Where can I specify HTML mail charset? Any hint?

    Regards,

  13. SergioHernando
    Member
    Posted 8 years ago #

    Hi folks,

    just to confirm that i suffer the same situation explained in my previous post when sending plain text notification emails. My blog operates with european 8859-15 charset, and mails received are not compatible with that charset. They seem to be formatted with UTF-8, as ampersand characters are not respected.

    Do you have any hint on what´s happening?

    Thanks in advance

    My WP is available at http://www.sahw.com/wp

  14. cpjolicoeur
    Member
    Posted 8 years ago #

    do you happen to post directly through the WP interface or do you use a third-party tool like ecto or w.bloggar?? just wondering because I still can't seem to get the email notification to work unless I post directly through the WP interface.

  15. SergioHernando
    Member
    Posted 8 years ago #

    I use WP interface to send notifications. I don't use any kind of third party applications to send mails.

    Do you have any hint about the charset encoding question I've mentioned?

  16. cpjolicoeur
    Member
    Posted 8 years ago #

    not yet. I have been looking into the code a little for you, but mostly I've been trying to work out the publish_post() logic not firing off. I'll see what I can find out for you.

  17. sunnah82
    Member
    Posted 8 years ago #

    Please help me I have error in my admin section when use this plugin.

    Warning: main(/maillist/wpemn_config.php): failed to open stream: No such file or directory in /home/globbor/public_html/sunnah/wp-content/plugins/wp-email-notification/index.php on line 19

    Warning: main(/maillist/wpemn_config.php): failed to open stream: No such file or directory in /home/globbor/public_html/sunnah/wp-content/plugins/wp-email-notification/index.php on line 19

    Warning: main(): Failed opening '/maillist/wpemn_config.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/globbor/public_html/sunnah/wp-content/plugins/wp-email-notification/index.php on line 19

  18. cpjolicoeur
    Member
    Posted 8 years ago #

    looks like you are missing the files or they are in the wrong place. try uploading w/ FTP again according to the instructions.

  19. jmarcw
    Member
    Posted 8 years ago #

    I've been trying to get this but just fall short. I get many errors no matter how much I edit. This whole /home/totallyo/public_html/blog/maillist/index.php...I ftp to totallyout.com/public_html/blog/maillist/index.php I don't get this at all---my website is totallyout.com/blog/ ...not home/totallyo/

    Warning: mysql_connect(): Access denied for user: 'root@localhost' (Using password: NO) in /home/totallyo/public_html/blog/maillist/index.php on line 25

    Warning: mysql_select_db(): supplied argument is not a valid MySQL-Link resource in /home/totallyo/public_html/blog/maillist/index.php on line 26

    Warning: mysql_query(): Access denied for user: 'root@localhost' (Using password: NO) in /home/totallyo/public_html/blog/maillist/index.php on line 37

    Warning: mysql_query(): A link to the server could not be established in /home/totallyo/public_html/blog/maillist/index.php on line 37
    Access denied for user: 'root@localhost' (Using password: NO)
    Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in /home/totallyo/public_html/blog/maillist/index.php on line 38

    Warning: mysql_query(): Access denied for user: 'root@localhost' (Using password: NO) in /home/totallyo/public_html/blog/maillist/index.php on line 58

    Warning: mysql_query(): A link to the server could not be established in /home/totallyo/public_html/blog/maillist/index.php on line 58
    Access denied for user: 'root@localhost' (Using password: NO)
    Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in /home/totallyo/public_html/blog/maillist/index.php on line 60

    Warning: mysql_query(): Access denied for user: 'root@localhost' (Using password: NO) in /home/totallyo/public_html/blog/maillist/index.php on line 69

    Warning: mysql_query(): A link to the server could not be established in /home/totallyo/public_html/blog/maillist/index.php on line 69
    Access denied for user: 'root@localhost' (Using password: NO)
    Warning: mysql_insert_id(): A link to the server could not be established in /home/totallyo/public_html/blog/maillist/index.php on line 70
    Thanks for subscribing.
    You will receive an email shortly to confirm your subscription.
    Once you confirm your subscription you will begin to receive
    notifications whenever is updated.

    Go Back

  20. cpjolicoeur
    Member
    Posted 8 years ago #

    as far as the directory being /home/totallyo/ instead of /home/totallyout/ is a common hosting practice. they are just limiting your username to 8 characters when creating your actual home directory on the webserver. that is nothing to worry about.

    the error messages you are getting seem to be because you do not have your MySQL DB connection information setup correctly. try to check your setup.

  21. jmarcw
    Member
    Posted 8 years ago #

    Ok getting closer but I still have this for an error :
    Warning: mysql_connect(): Access denied for user: 'root@localhost' (Using password: NO) in /home/totallyo/public_html/Maine/wp-content/plugins/wp-email-notification/index.php on line 44

    Warning: mysql_select_db(): supplied argument is not a valid MySQL-Link resource in /home/totallyo/public_html/Maine/wp-content/plugins/wp-email-notification/index.php on line 45

    Also when I run the install.php file it goes to step 2 page but it's always get The page cannot be displayed in I Eplorer

    Thanks for any help

  22. fotohead
    Member
    Posted 8 years ago #

    Ok, I have the dumbest question by far.... The install notes tell me to do the following:

    " 7. Put form code in template...<form method="post" action="maillist/index.php">Enter your e-mail address to receive notifications when there are new posts

    <input type="text" name="email" size="12" /><input type="submit" name="submit" value="sign up" /></form>"

    Ok looks good, I understand the form code thing I think - but which template am I supposed to put it into??

    Please excuse my newbieness

    Thanks for any help

  23. dushan
    Member
    Posted 8 years ago #

    Hi there,

    the plugin is surely great. Yet for now I have the following problem:

    I installed the newest version on WP 1.5.1 and I set the plugin to notify by HTML.

    Now the emails are text, containing loads of HTML.

    Am I doing something wrong?

    Thanks for any help! :)
    dushan

  24. med
    Member
    Posted 8 years ago #

    So far, this is the best of all email notification plugins I have tested on my blog.

    However, I am frequently delaying messages to be published, so I am actually having the problem that people get notified of posts that are not yet published.

    I had a look at the db posts table, and as far as I can see this plugin relies on the post status (published or not). I was thinking of changing this to respect the publishing date, but wanted to check before starting to fiddle around with this myself.

    I am not exactly a PHP genius, and if someone has a nice, clear and easy approach, let me know. Thanks.

  25. cpjolicoeur
    Member
    Posted 8 years ago #

    fotohead:

    you don't actually have to put it in any of your templates. Just create a new page and put the form code in the new page. Have a standalone page just for email subscriptions. at least thats what I did.

  26. sooeydoo
    Member
    Posted 8 years ago #

    Is there an option to send all new posts for one day as one email instead of sending an email for each post? I would not like to flood my users' inboxes with 3 emails everyday (on average) - I would like to limit it to just one.

  27. fotohead
    Member
    Posted 8 years ago #

    cpjolicoeur:

    Thanks for the reply! Good advice too - I seem to have got things worked out and its working for me....

    Thanks again for taking the time to let me know your ideas.

  28. bjcameron
    Member
    Posted 8 years ago #

    Does anyone know if this has been resolved:

    "plugin not sending an email for posts created using xmlrpc.php." I am using wp 1.5.2 and the postie pluggin.

    Thanks

  29. cpjolicoeur
    Member
    Posted 8 years ago #

    Its still not working for me. I'm trying to debug now but I think the problem may be in the 3rd party posting apps themselves.

    With w.bloggar on Windows XP it seems that w.bloggar is sending the post up as a draft even though the "Post & Publish" button was pressed and the post truly does get published. At the time it reached the check in xmlrpc.php the $post_status="draft" not "publish" therefore the publish_post() function doesn't get called.

    With ecto on OS X, it seems that ecto does send the $post_status="publish" so publish_post() should be getting called. But I'm still not getting the email notifications.

    I'm just not sure where the problem is. It my be with some other installed plugins that act on publish_post() and are affecting this email notification plugin, or it may be with the 3rd party apps, or with xmlrpc.php itself.

  30. jmjawors
    Member
    Posted 8 years ago #

    I'm getting this error in the Dashboard's options for this plugin:

    Could not successfully run query (SELECT * FROM wp_email_list_config WHERE id = ‘1′) from DB: No database selected

    The notification seems to be working just fine, but I can't access it through the dashboard. Any help?

Topic Closed

This topic has been closed to new replies.

About this Topic