WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WordPress Editor Driving Me Insane (42 posts)

  1. 21stproject
    Member
    Posted 8 years ago #

    Before anyone jumps down my throat and tells me that I shouldn't be using the WYSIWYG editor for HTML posts, I'm not, at least, I really, really don't think so.

    I searched the forms and saw instructions for switching the rich text off and having the text editor on, I did this by logging on as admin, going under users and checking off the box that said "Use the visual rich editor when writing"

    My WordPress blog is all valid HTML until I start posting. The posts themselves are written in an editor (outside WP) and validated as XHTML 1.0 Transitional -same as my WP blog.

    But every time I post the page is no longer valid! I get all these tags from the post still. It's driving me crazy.

    Admittedly though, the shorter the post, the less chance I have of this happening.

    But there’s no reason at all for this to happen, what should I do?

    If there is no solution, how do I directly upload the post to the SQL database without using WordPress’s posting ap?

    Oh and I downloaded and installed WordPress this week, not sure what version that would be, but its the latest I'm sure.

  2. tomatoma
    Member
    Posted 8 years ago #

    If you downloaded this week it must be 2.03. It is driving me insane also. WP editor is changing My code. Everytime I save a post it changes my coding as it likes. Inserting html tags I dont want or deleting the ones I write. For example I cannot insert youtube videos because it deletes half the code.

    ¿Is there a way to modify this? I saw a plugin that let you use the html editor instead of the wysiwg but I can't find it anylonger, and ¿would it solve this problem?

  3. klifix2
    Member
    Posted 8 years ago #

    This problem is familiar to me as well! The You Tube code is mixed up as well within my posts.
    I used the HTML button to correct the code and updated this and then saved the posts, but sometimes with few codes it seems it still 'corrects' it into plain text and therefore it doesn't show what it needs to show: a you tube player.

    As I have seen in this forum, there is a special plugin for this. I didn't had the time to test, so therefore I like to ask in this topic if there is someone familiar with this problem and this plugin?

  4. yosemite
    Member
    Posted 8 years ago #

    Disable "WordPress should correct invalidly nested XHTML automatically" in Options:Writing.

  5. 21stproject
    Member
    Posted 8 years ago #

    oh wow, I completely missed the replies to this topic, huh.

    "WordPress should correct invalidly nested XHTML automatically" is unchecked with mine, so..that's not solving anything unfortunately.

    Glad to see I'm not the only one suffering with this..I hope it ends is all.

  6. yosemite
    Member
    Posted 8 years ago #

    What external editor are you using?

  7. 21stproject
    Member
    Posted 8 years ago #

    Why does that matter?

    I'm using dreamweaver's WYSIWYG editor and I'm not relying on the software to validate anything for me, the w3.org valuator does that for me.

    After I'm sure its valid I copy and paste the code as is.

    I usually tab my code but I untabbed everything and pasted that way, I still get problems, the line breaks seem to be doing it but its very random, usually around p tags I think.

    I don't know what the problem is, seriously. I could be editing through notepad and pasting from there and it'd still give me the same problems.

  8. tomatoma
    Member
    Posted 8 years ago #

    I'm with 21stproject, the editor does not matter. A CMS should not change users coding without permission. Even if our html is horrible we have the 'right' to use it ;-)

  9. 21stproject
    Member
    Posted 8 years ago #

    Tomatoma, absolutely, it kills me, seriously, I absolutely love wordpress, it's only been a few days since I've started using it and I've even looked under the hood and tore the default theme apart and what not, but the editor?

    It’s embarrassing, it makes me want to go back to trying to use Blogger.

    It cant be a big ask right? I just want an editor that lets ME do the editing. That’s all.

    --
    And yes, I am running version 2.03, I just checked the download folder.

  10. Chris_K
    Member
    Posted 8 years ago #

    I did this by logging on as admin, going under users and checking off the box that said "Use the visual rich editor when writing"

    Just to confirm: You unchecked it, right?

  11. 21stproject
    Member
    Posted 8 years ago #

    Yes HandySolo, here's the settings I have;

    Unchecked- Use the visual rich editor when writing

    Unchecked- Users should use the visual rich editor by default

    Unchecked- Convert emoticons like :-) and :-P to graphics on display

    Unchecked- WordPress should correct invalidly nested XHTML automatically

  12. 21stproject
    Member
    Posted 8 years ago #

    Any ideas, anyone? I'm starting to despair

  13. Chris_K
    Member
    Posted 8 years ago #

    Operating without a clue as to what you're actually doing in that outside editor... seems like maybe it would be good to know!

    So, what's an example of what you're putting in your posts?

  14. 21stproject
    Member
    Posted 8 years ago #

    My blog is found here;

    http://21stproject.com/blog/

    I copied the html from here;

    http://21stproject.com/test1.html

    I switched the blog back to the un-tampered default theme just so there's less variables to look at. I tried to find my first post, one that had no tables with less confusing code but I can't seem to find it.

  15. Chris_K
    Member
    Posted 8 years ago #

    oooooh. goodness, now I see it. So WP is adding a </p> for some <td> elements when another element comes up first.

    Hmm, there was a recent discussion here about modifying or disabling "autop". I think searching for that one might be relevant.

  16. 21stproject
    Member
    Posted 8 years ago #

    I'm looking...still can't find it!

    Also, would older posts help at all if I have a newer version of wordpress?

    What kind of keywords am I looking for? Just autop?

    I can't believe this, all the posts I come across have someone telling the poster that they should search for posts that resolve the issue since it's been brought up so many times. I still can't find it!

  17. Chris_K
    Member
    Posted 8 years ago #

    *ouch*

    Ok, well I'd search for "autop" or "auto format" or such things. If I get time to sit and focus tonight I'll search as well.

    [edit added: but dangit, I know I saw something here within the last few months that was useful!]

  18. 21stproject
    Member
    Posted 8 years ago #

    Thanks for your help!

    I'll post again if I find it, still hunting for it.

  19. prof611
    Member
    Posted 8 years ago #

    Hello -

    I just found this thread, and it starts out with the same problem I've been having for a couple of days now.

    I HATE "WYSIWYG" editors. I just spent over an hour trying to put up a post that contains sections of coding, and trying to enclose that section with a 'pre' tag. Finally, I went into the database itself, and was able to do it in spite of the built-in editor, but it's STILL not the way I want it exactly.

    I want to be able to design a post using a simple text editor like Notepad, and be able to post it WITHOUT having the coding changed. I've already checked on available plugins, and none of them allow an experienced HTML programmer to do what they want to do.

    Please, somebody, point me to a plugin that allows COMPLETE coding to be entered, without modification, into a post.

  20. Chris_K
    Member
    Posted 8 years ago #

    I love thread-drift.

    @prof611: I'll assume you've figured out how to turn off the wysiwyg editor(noted several posts up in this same thread).

    I tend to use this plugin for code samples in blog posts. http://blog.igeek.info/wp-plugins/igsyntax-hiliter/

    Your searching on the topic might have uncovered this older thread that has a handful of other options mentioned: http://wordpress.org/support/topic/55087?replies=22

  21. prof611
    Member
    Posted 8 years ago #

    Hi. Fast reply.

    Yes, I read the whole thread, and I did uncheck everything in Writing Options before posting here. It doesn't eliminate the WYSIWYG editor, however. My coding is still changed before it gets submitted.

    I also just read all of the stuff in the older thread that you mentioned above.

    None of this helps with my major problem: I don't want WordPress messing with my coding at all! I just want to be able to design a post the way I want it to appear, using a simple text editor like Notepad.

    Styling "sample code" in the post is not the only problem I've experienced. Every HTML tag I put in gets changed by the editor to something I didn't want! Then I have to figure out a work-around to get the post to look like I wanted it to look.

    I have spent far less time designing a whole XHTML page for one of my websites than it took me to write one post for my blog! Either I'm going to give up this blogging idea, or I'll have to spend a lot of time writing my own plugin in order to do what I want to do. I just hope that there's a way to avoid both alternatives.

  22. Chris_K
    Member
    Posted 8 years ago #


    [...]I did uncheck everything in Writing Options before posting here. It doesn't eliminate the WYSIWYG editor, however

    Right. That won't.

    Users -> Your Profile. Scroll down to the bottom of the page. Uncheck the option to use the visual rich editor.

  23. 21stproject
    Member
    Posted 8 years ago #

    @prof611:
    I'm looking to do exactly what you're trying to do, no luck so far!

    @HandySolo:
    Thanks for those links, the igsyntax-hiliter plugin is going to come in useful if I can figure out how to style it, can't seem to find proper documentation on the kind of code it generates around my code, need to style the width: http://21stproject.com/blog/

    I still can't find that autop thing, meh. And if I did find a plugin that corrects the stuff, is it going to be compatible with igsyntax-hiliter?

    Don't you get any of these problems?

  24. Chris_K
    Member
    Posted 8 years ago #

    Re the igsyntax-hiliter width: In the ig_syntax_hilite plugin directory, it has its own CSS sheets. Width can be found in syntax_hilite_css.css. I modified mine to suit.

    The autop thing may become a personal quest... I know there's an answer out there if we can just hit the right search terms.

    I don't really get problems like this, no. But I don't have much call for tabular data either. :-/ And the validation bug you're hitting is, you have to admit, a bit obscure!

    Which reminds me: It wouldn't hurt to put this issue in trac so that the devs know about it (or even search there). A bit of code pre and post in the trac article would be pretty helpful I bet (or even a link back to this thread).

  25. vavroom
    Member
    Posted 8 years ago #

    FWIW, I'm also aggreived by what appears to be an "autop problem". i've turned off rich editor in my user profile, etc, and I generally don't have a problem, except when I add the
    <!--more-->
    Tag in a post, it then automatically wraps it in a , which is behaviour I really do NOT want to see, as it throws an extra empty paragraph in my post. If I include the more link within the tag immediately before where I want to break, then, it really messes up validation as my paragraphs are unfinished when viewing pages that are NOT single.php.

    Any solution to this would be greatly appreciated.

  26. Samuel Wood (Otto)
    Tech Ninja
    Posted 8 years ago #

    If you want to disable the wpautop functionality, add this to your theme's functions.php file (create a new functions.php in your theme directory if you haven't got one):
    <?php remove_filter('the_content','wpautop'); ?>

    Note that wpautop is applied when the content is *displayed*, not when you're saving the content.

  27. 21stproject
    Member
    Posted 8 years ago #

    The bug is very vague, I do admit, I'm going to give it another few tries till I report it in trac, I want to have enough examples so people can see what I'm talking about, maybe recreate it even. I still don't know exactly what triggers it because shorter posts do validate.

    As far as tabular data goes, like I said, that's not the first time I've encountered bougus additions, it does it when tags have attributes. But thats seemingly random as well, meh.

    And thanks for showing me where the css file is!

    Edit: didn't see your post Otto42, I'll give your solution a shot right now

  28. Samuel Wood (Otto)
    Tech Ninja
    Posted 8 years ago #

    There are two filters that are applied to posts after you submit them but before they are saved to the database.

    The first is "balanceTags", and this is disabled by turning off "WordPress should correct invalidly nested XHTML automatically".

    The second is "wp_filter_kses", and this is disabled if the user in question has the "unfiltered_html" capability (using the Role Manager plugin). Users should have this capability by default, I believe, unless you change it.

    So the real key to this is to work out where the actual change to the post is happening. Is it happening before the post goes into the database or afterwards, when the post is displayed on the page?

  29. 21stproject
    Member
    Posted 8 years ago #

    @Otto42

    It works, when I post something the post is validated (even the post that was refusing to at the beginning), but for some reason it screws with wordpress, the post gets saved and what not, but I'm not redirected and I get this error;

    Warning: Cannot modify header information - headers already sent by (output started at /homepages/5/d97685745/htdocs/21stproject/blog/wp-content/themes/default/functions.php:3) in /homepages/5/d97685745/htdocs/21stproject/blog/wp-admin/inline-uploading.php on line 5

    Warning: Cannot modify header information - headers already sent by (output started at /homepages/5/d97685745/htdocs/21stproject/blog/wp-content/themes/default/functions.php:3) in /homepages/5/d97685745/htdocs/21stproject/blog/wp-admin/inline-uploading.php on line 144

Topic Closed

This topic has been closed to new replies.

About this Topic