WordPress.org

Ready to get started?Download WordPress

Forums

Download Monitor
WordPress Download Monitor errors when downloading (14 posts)

  1. Snerf
    Member
    Posted 3 years ago #

    When you click on a download link, it errors on functions.inc.php on a number of functions saying they already exist. The way to fix it is to add 'if (!function_exists('function_name')) { ' to all the functions inside the file. Would be nice if it was fixed for the next version, this has been going on for 6 months at least, and its annoying having to fix it every time I Update.

  2. wendymerritt
    Member
    Posted 3 years ago #

    Snerf,
    How can you tell where your error came from? "I am having a Error 404 - Page not found!" with every download. I have uninstalled and reinstalled the plugin with no success. I don't want to add your information unless I"m sure I'm having the same error. Did you add your code to the functions.inc.php file?

    Blessings,
    Wendy Merritt

  3. Snerf
    Member
    Posted 3 years ago #

    I can tell where the error comes from, because the browser tells me there is an error in that file.

    Everytime I update the plugin, I need to fix the functions.inc.php file as stated. It is a little annoying.

  4. wendymerritt
    Member
    Posted 3 years ago #

    I do not see anything in my browser that tells me where the error is. I just see a 404 error statement. Am I missing something or not looking in the right place? I don't want to make these changes and then find out that wasn't my issue.

    If this is my problem where exactly in the functions.inc.php file am I adding this line? Do I included the single quotes you surrounded the code with?

    Thanks for your help.

    Blessings,
    Wendy Merritt

  5. Snerf
    Member
    Posted 3 years ago #

    I am sorry, I am not here to fix other people's problems, I am here to say that to fix "my" problems I needed to add in the if (!function_exists..) to all the commands inside that file.

  6. wendymerritt
    Member
    Posted 3 years ago #

    Way to promote the Open Source spirit!

    All I asked was what YOU did and where. I'm sorry I asked you to step outside your comfort zone.

    ~Wendy Merritt

    P.S. Takers annoy me!

  7. Snerf
    Member
    Posted 3 years ago #

    I explained what I did, in my 1st post.

    Sheesh, maybe if you READ the post you wouldn't get all crazy.

  8. Karine
    Member
    Posted 3 years ago #

    I have the same problem and Snerf DID explain what he did to repair it in the first post...

  9. wendymerritt
    Member
    Posted 3 years ago #

    Ka-ri-ne, Snerf merely what he did not exactly how he went about doing it. Such as it is, I fixed the problem myself. It was not this issue at all but rather an error in the .htaccess file.

  10. DjSk-MoOn.com
    Member
    Posted 3 years ago #

    Greetings. I also I have the same problem wendymerritt hope you can help me and tell me that part of htaccess fixed it again worked for the download - monitor ..!

    I hope I'm desperate greeting prompt response!!

  11. wendymerritt
    Member
    Posted 3 years ago #

    DjSk-MoOn.com I thought I had it fixed but today I'm getting the dreaded 440 error again. This is what my added files to the .htaccess look like(public_html/YourUrlFileName/.htaccess)

    #BEGIN Download Monitor
    Options +FollowSymLinks
    RewriteEngine on
    RewriteRule ^downloads/([^/]+)$ /wp-content/plugins/download-monitor/download.php?id=$1 [L]
    #END Download Monitor

    Since mine isn't working at the present moment you may not want to used what I have here...but if all else fails you could try it.

    I'll let you know what fixes it...when I get it fixed.

  12. wendymerritt
    Member
    Posted 3 years ago #

    Ummm, that would be a dreaded 404 error...lol

  13. wendymerritt
    Member
    Posted 3 years ago #

    This is what my current error looks like

    http://ow.ly/i/cFJV

    I also noticed that the link in the address bar is not the link set in the Download Monitor:

    http://myurl.com/wp-content/uploads/downloads/2011/06/filename.pdf?doing_wp_cron

    Any ideas?

  14. wendymerritt
    Member
    Posted 3 years ago #

    Okay, @DjSk-MoOn.com, I got everything fixed, finally. Something with my hosting (according to Mike Jolley) at Hostgator is requiring that I make all the downloads a force download. Here's what my .htaccess looks like:

    public_html/***Yourdomain***/.htaccess

    # BEGIN Download-Monitor
    Options +FollowSymLinks
    RewriteEngine on
    RewriteRule ^downloads/([^/]+)$ /home/**yourhostingusername**/public_html/**yourdomain**/wp-content/plugins/download-monitor/download.php?id=$1 [L]
    # END Download-Monitor
    
    RewriteEngine off
    <IfModule mod_suphp.c>
    	suPHP_ConfigPath /home/**yourhostingusername**/public_html/**yourdomain**/php.ini
    	<Files php.ini>
    		order allow,deny
    		deny from all
    	</Files>
    </IfModule>
    
    # BEGIN WordPress
    
    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteBase /
    RewriteRule ^downloads/([^/]+)$ http://**yoururl**/wp-content/plugins/download-monitor/download.php?id=$1 [L]
    </IfModule>
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    I hope this helps. :-)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic