WordPress.org

Ready to get started?Download WordPress

Forums

WordPress didn't return a vaild path (22 posts)

  1. huffnpuff
    Member
    Posted 3 years ago #

    Hi

    Just installed Yoast WordPress SEO and got the following settings advice:

    WordPress didn't return a valid path to your upload directory, please make sure your upload path is set correctly

    Where would I find this and how do I fix it.

    Many thanks

  2. Jonas Grumby
    Member
    Posted 3 years ago #

    Settings > Media

  3. huffnpuff
    Member
    Posted 3 years ago #

    Thanks Jonas,

    Not sure anything is wrong here.

    Uploading files: Store uploads in this folder is blank Default is wp-content/uploads

    Full URL path o files is also blank Configuring this is optional. By default it should be blank.

    Had a peek at my files and directories, the plugin folder does contain the Yoast plugin.

    Any ideas on why I am getting the warning message ?

    Many thanks

  4. huffnpuff
    Member
    Posted 3 years ago #

    sorry to bump but really stuck here

  5. Jonas Grumby
    Member
    Posted 3 years ago #

    I'm not familiar with that plugin, but if you installed it, you should see it in the /wp-content/plugins folder and also on the Plugins page in admin.

    Store uploads in this folder should not be blank. It should have something like wp-content/uploads in it.

    The other one should be blank as the screen says.

  6. huffnpuff
    Member
    Posted 3 years ago #

    Hi Jonas,

    I can see the plugin in the plugin folder, its activated. Its on the dashboard of the plugin where I am seeing the warning in a big red shiny box, which normally means do not ignore, but I am at a loss to understand what the problem is, if it did not have a valid path surely the plugin would not be able to be seen or activated... doesn't make much sense to me, or should it ?? : )

  7. Jonas Grumby
    Member
    Posted 3 years ago #

    You wrote:

    Store uploads in this folder is blank

    I wrote:

    Store uploads in this folder should not be blank.

  8. huffnpuff
    Member
    Posted 3 years ago #

    I'm sorry I forgot to mention I have changed that to wp-content/uploads as per the comment next to the box but there is no change the warning remains.

  9. Jonas Grumby
    Member
    Posted 3 years ago #

    If you FTP to the server, is the folder there? If not, you can create it. Otherwise I believe WordPress will create it the first time you upload an image.

  10. huffnpuff
    Member
    Posted 3 years ago #

    checked out if uploads directory was in wp-content, it was not so created one. re downloaded plugin from dashboard > plugins.

    Checked site through ftp again and it installed the plugin directly into the plugins folder on my blog files in wp-content/plugins. Would the path to be entered in that box be wp-content/plugins or should I do a manual download and install into the uploads folder....or am I completely off track

  11. Jonas Grumby
    Member
    Posted 3 years ago #

    I don't know what plugin you are talking about. You don't need any plugin. Like I said, I think the first time you upload an image WordPress will create the folder. Otherwise you can create it with an FTP program or your hosting control panel.

  12. huffnpuff
    Member
    Posted 3 years ago #

    Hi Jonas,

    I have tried uploading an image but it failed and got this message:

    Unable to create directory /var/www/vhosts/hpcastles.co.uk/httpdocs/blog/wp-content/uploads/2011/02. Is its parent directory writable by the server?

    I have created a directory manually in wp-contents but when I upload the plugin (Yoast SEO) it uploads into the wp-content/plugins folder.

    I have deleted all that started again and tried manually uploading the plugin directly into the wp-content/uploads folder but it cannot be seen in the plugins window on the dashboard.

    Looking for a rope and a tree lol.

  13. Jonas Grumby
    Member
    Posted 3 years ago #

    Plugins are supposed to go in the wp-content/plugins folder.

    The path in Settings > Media is for media files. If that folder is not writable, you can fix that with an FTP program (CHMOD command), your hosting control panel (permissions), or your hosting support people could change it for you.

  14. huffnpuff
    Member
    Posted 3 years ago #

    Hi Jonas

    I do have full access to the root. The file permission at present is Owner only can write, if I change to group or public permission am I at risk from unwelcome visitors.

    Thank you for your patience.

  15. Jonas Grumby
    Member
    Posted 3 years ago #

    Should all be 755 except the .htaccess file in the wordpress directory, and wp-admin/index.php which both need to be set to 644.

    http://codex.wordpress.org/Changing_File_Permissions

  16. huffnpuff
    Member
    Posted 3 years ago #

    both .htaccess file and admin/index on 644 (still owner only can write no group or public write permission) All others on 755

  17. huffnpuff
    Member
    Posted 3 years ago #

    Had a problem when installed .htaccess file, it caused an internal server error 500 and could not access wp-admin, deleted file and got the admin panel back

  18. Jonas Grumby
    Member
    Posted 3 years ago #

    Where did you put the .htaccess file and what was in it? For the one in the main WordPress directory, it can be blank and WordPress will rewrite it when you update your Permalinks structure.

  19. huffnpuff
    Member
    Posted 3 years ago #

    Hi Jonas

    I put the .htaccess file in mydomain/blog its where all the wp directories and files are.

    I have tried updating the permalink options it produced some code to copy & paste onto the .htaccess file, I suppose because it could not write to it itself. Obviously I cannot paste it because there is no .htaccess file.

    The permalinks option to default/%postname%/ did not work because of this and I had to revert back to default.

  20. Jonas Grumby
    Member
    Posted 3 years ago #

    I think it's ok to leave it without one as long as you are not using custom permalinks, and when you change the permalink structure, WordPress will write it as long as your /blog folder is set to 755. At least that's how it's supposed to work.

  21. huffnpuff
    Member
    Posted 3 years ago #

    Resolved with your marvellous help Jonas. Needed to go to 777 in the end. .htaccess is still unresolved but my server is working on it so hopefully its a problem at their end and will get fixed.

  22. Daniel Craig Jallits
    Member
    Posted 3 years ago #

    Please see my comments under Plugins & Hack support for the plugin: WordPress SEO by Yoast

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.