WordPress.org

Ready to get started?Download WordPress

Forums

WordPress deleting random things! (5 posts)

  1. MykMallett
    Member
    Posted 3 years ago #

    I have a custom plugin that saves meta data using a bind the the save function, which puts event times and dates into a seperate table. This works absolutely fine, except if the user leaves the edit page open and (i assume) an auto-save occurs.
    This then (even tho the details are still in the correct fields) saves some incorrect and unusable string into the table. It still saves the correct post_id and blog_id, but the custom meta boxes values are not saved properly and are essentially deleted.

    Secondly, at seemingly random occasions, the header image (the custom one that a user can add) just disappears. I can't give anymore information than that because it happens so infrequently and I cant seem to reproduce it!

  2. MykMallett
    Member
    Posted 3 years ago #

    I've narrowed the header image deletion to when a plug-in gets activated. Anyone know why this might be?

    I've disabled auto-save and that seems to have stopped the deleting of meta data...but thats not a viable solution, why is it saving incorrect data when auto-saving?

    Although I know I might as well be writing this on a piece of paper, folding it up into a plane and throwing out the window.

  3. MykMallett
    Member
    Posted 3 years ago #

    Does anyone even bother looking at these forums anymore? This is almost as bad as the Facebook developer forums for help. Fix up WordPress for f*cks sake

  4. MykMallett
    Member
    Posted 3 years ago #

    Blah blah blah blah blah, fucking wordpress forums. Massive pile of total bollocks

  5. carmelosantana
    Member
    Posted 3 years ago #

    I promise, its highly unlikely you'll see positive results with the attitude above. With that being said ... I can say I am also suffering from awkward save issues. There seems to be an issue with metaboxes not saving due to the autosave feature. Theres simple snippet of code to disable, but didn't work for me. Chill out, and good luck.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags