WordPress.org

Ready to get started?Download WordPress

Forums

WordPress db error : While commenting on posts (4 posts)

  1. kgvinayak
    Member
    Posted 6 years ago #

    I upgraded wordpress to 2.3.1 from 2.3 a while ago. Now when anyone comments on my blog post, I get the following error. I am pretty sure I've upgraded the way it should be, using automatic upgrade. Any help appreciated.

    WordPress database error: [MySQL server has gone away]
    SELECT * FROM wp_comments WHERE comment_ID = '11598' LIMIT 1
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/myaccount/public_html/domain.com/wp-includes/wp-db.php:160) in /home/myaccount/public_html/domain.com/wp-comments-post.php on line 67
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/myaccount/public_html/domain.com/wp-includes/wp-db.php:160) in /home/myaccount/public_html/domain.com/wp-comments-post.php on line 68
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/myaccount/public_html/domain.com/wp-includes/wp-db.php:160) in /home/myaccount/public_html/domain.com/wp-comments-post.php on line 69
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/myaccount/public_html/domain.com/wp-includes/wp-db.php:160) in /home/myaccount/public_html/domain.com/wp-includes/pluggable.php on line 391
  2. kgvinayak
    Member
    Posted 6 years ago #

    Anyone took a look at this?
    Tried hard but couldn't find a solution at all?

    Any pointers are going to be of great help...

  3. kgvinayak
    Member
    Posted 6 years ago #

    Okay, after going through a lot in the forum threads (which by the way is hard to detect if someone is having exactly the same problem or not), the solution is totally unexpected for me.
    Solution: Disable FastCGI acceleration on the server
    Bluehost has this disabled, but sometime ago I had enabled it to serve pages faster. Apparently I can't use it for good.

    Thanks to this thread
    http://wordpress.org/support/topic/124416?replies=5

    Hope this helps someone.

  4. Mike1
    Member
    Posted 6 years ago #

    I am showing the same error. I checked and I do not have FASTCGI enabled on my server. I dont get the db error, just what shows up below. No errors are showing up in the apache error log.

    [08-Nov-2007 07:20:09] PHP Warning: Cannot modify header information - headers already sent by (output started at /home/flyersfa/public_html/wp-includes/wp-db.php:160) in /home/flyersfa/public_html/wp-comments-post.php on line 67
    [08-Nov-2007 07:20:09] PHP Warning: Cannot modify header information - headers already sent by (output started at /home/flyersfa/public_html/wp-includes/wp-db.php:160) in /home/flyersfa/public_html/wp-comments-post.php on line 68
    [08-Nov-2007 07:20:09] PHP Warning: Cannot modify header information - headers already sent by (output started at /home/flyersfa/public_html/wp-includes/wp-db.php:160) in /home/flyersfa/public_html/wp-comments-post.php on line 69
    [08-Nov-2007 07:20:09] PHP Warning: Cannot modify header information - headers already sent by (output started at /home/flyersfa/public_html/wp-includes/wp-db.php:160) in /home/flyersfa/public_html/wp-includes/pluggable.php on line 391

    It is not happening with every comment post. I can post fine logged in and not logged in so I really don't know what is causing it or how to replicate it
    Using a modified kubrick theme
    http://www.flyersfancentral.com/

Topic Closed

This topic has been closed to new replies.

About this Topic