WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WordPress Database error (16 posts)

  1. rwbra
    Member
    Posted 1 year ago #

    WordPress database error: [Unknown column 'day_no_time' in 'field list']
    INSERT INTO wp_popularpostsdatacache (id, day, day_no_time) VALUES (10, '2012-09-01 10:34:05', '2012-09-01') ON DUPLICATE KEY UPDATE pageviews = pageviews + 1, day = '2012-09-01 10:34:05', day_no_time = '2012-09-01';

    This is the error message I am receiving when accessing any of my posts on my site http://www.reliefteaching.com

    However, the site runs fine when I am enter through http://www.reliefteaching.com/wp-admin.

    Any ideas?

  2. rwbra
    Member
    Posted 1 year ago #

    It seems the problems was the wp popular post plug in.

    When deactivated the problem disappeared.

  3. wolfkettler
    Member
    Posted 1 year ago #

    Had the same problem and your solution corrected it. Thanks for sharing!

    Interestingly, the error only occurred for non-logged in users, which is what you also experienced.

    Wolf
    WOLF KETTLER PHOTOGRAPHER
    http://www.wolfkettler.co.uk

  4. joshhwash
    Member
    Posted 1 year ago #

    Had the same problem. Thanks for sharing!

  5. mflen
    Member
    Posted 1 year ago #

    Perfect info! Thanks.

  6. abetopten
    Member
    Posted 1 year ago #

    Wow thanks a lot wolfkettler!

  7. onsecrethunt
    Member
    Posted 1 year ago #

    I simply Deactivate this plugin the problem solved.But I love this plugin and don't want to deactivate it.. :(

  8. rwbra
    Member
    Posted 1 year ago #

    True. I deactivated and reactivated the plug in. I lost the post data but the plug in works fine now and I don't get the error message. Go figure!

  9. RichardWPG
    Member
    Posted 1 year ago #

    - First, try contacting the hosting provider if the database server is online / if they have any other problem at their end, or they made any changes to your account, or if there are any limitations/restrictions, if the hosting package is set to Windows and not Linux, etc .

    - double check your wp-config.php file settings for the database name, database username and database password. This is where most errors occur.

    -Then check that you don't need to change the database host from "localhost" to something else. You can get that info from your hosting provider.

    -Check you have actually created a database with the same database name as is in your wp-config.php file.
    -Last, but not least, if all that information is correct your database probably has a problem with it, and you may need to contact your hosting provider.

  10. onsecrethunt
    Member
    Posted 1 year ago #

    @Rwbra Sir, Thanks for the support, finally Plugin working great when I activated this.

  11. BioptronPL
    Member
    Posted 1 year ago #

    Thanks it fixed my problem too :)

  12. Jennifer
    Member
    Posted 1 year ago #

    ive had no trouble with this plugin until i upgraded 2 days ago. now, the same thing happened to me with the following error:

    WordPress database error: [Unknown column 'day_no_time' in 'field list']
    INSERT INTO wp_popularpostsdatacache

    i had to deactivate and reactivate. all looks well now, but hopefully this won't happen again. also, i didn't seem to lose any tracking data. i still have the same popular posts in my top 4 widget.

    interestingly, there is a new plugin upgrade available today. im about to upgrade again and im hoping it fixes this issue because i do love this plugin.

  13. rwbra
    Member
    Posted 1 year ago #

    Interesting Jennifer. I maintained my post data but lost my all time data. Annoying but not disastrous.

  14. Jennifer
    Member
    Posted 1 year ago #

    rwbra, that's too bad. i just double checked my view counts, and sure enough, it did maintain that data. sorry you lost yours.

  15. Hubobo
    Member
    Posted 1 year ago #

    I can't get to the dashboard of my wordpress site (http://www.hubobo.nl), the login shows the above error and i can't get in by going to http://www.hubobo.nl/wp-admin (same error).

    Any ideas?

  16. esmi
    Forum Moderator
    Posted 1 year ago #

    Please post your own topic.

Topic Closed

This topic has been closed to new replies.

About this Topic