WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WordPress database error (6 posts)

  1. boldt
    Member
    Posted 4 years ago #

    I'm trying to write my own little plugin and I have tested it on several of my WP, but when I installed it on my last WP (the one I really want to use it) I got this message:

    WordPress database error: [Too many keys specified; max 64 keys allowed]
    ALTER TABLE wp_Counterize ADD INDEX ( timestamp );

    I don't think it has any thing to do with my specific plugin.

    Anyone know what to do?

  2. s_ha_dum
    Member
    Posted 4 years ago #

    You've hit a limit on the number of keys allowed by the MySQL server you are trying to use. That is, you are using too many indexes. You can change the value but only recompiling MySQL. Unless you have the ability to do that, or can talk your host into it, you are going to have to rework your indexes probably.

  3. boldt
    Member
    Posted 4 years ago #

    I have no Idea I'm only a user.
    My plugin is not establishing any new tables in the database only looking into 2 tables.

    Is it the plugin mentioned in the error (Counterizeii) that is establishing the error?
    or is it a coincident? (order of plugins installed)?

  4. s_ha_dum
    Member
    Posted 4 years ago #

    I had assumed that the plugin named was your plugin. Disable Counterize and see what happens.

  5. boldt
    Member
    Posted 4 years ago #

    if I deactivate Counterizeii or any other plugin and then activate my plugin nothing happens - meaning no warning occurs.

    It is only a warning all the plugins seems to be working

  6. boldt
    Member
    Posted 4 years ago #

    I have addressed this problem on Counterizeii webpage
    ( http://www.navision-blog.de/counterize-ii-english/ )
    and they have now found a programme error.
    "The problem is a small typo in the file “counterize_install.php”. If you open the file and you go to the end you will find twice something like:
    if($minorVersion < …

    you have to change them to:
    if($MinorVersion < …

    please note the "M" of "minor" now capital.
    "

Topic Closed

This topic has been closed to new replies.

About this Topic