WordPress.org

Ready to get started?Download WordPress

Forums

WordPress database error (9 posts)

  1. tfmurphhk
    Member
    Posted 7 years ago #

    Can anyone shed some light on this error that I am suddenly getting? I don't know that I have done anything to cause it... it just suddenly appeared.

    Also (obviously) do you have a solution...

    Thanks

    ================================

    WordPress database error: [You have an error in your SQL syntax near '.* FROM wp_posts WHERE 1=1 AND (post_type = 'post' AND (post_status = 'publish' at line 1]
    SELECT SQL_CALC_FOUND_ROWS wp_posts.* FROM wp_posts WHERE 1=1 AND (post_type = 'post' AND (post_status = 'publish' OR post_author = 1 AND post_status = 'private')) ORDER BY post_date DESC LIMIT 0, 10

    ==================================

  2. moshu
    Member
    Posted 7 years ago #

    Somebody might have a solution if you help them...
    Link, where exactly, what did you do right before, etc.?
    Did your host upgrade any software/hardware?

  3. tfmurphhk
    Member
    Posted 7 years ago #

    Hmmm, to the best of my knowledge I did nothing. I had not updated my blog in several days, when I went to do so, I got this message. I tried to fix it (blindly) and it only got worse.

    The message comes up right from the get-go at http://www.pga-auctions.com/wordpress

    I have no idea what my host may have done. Do you suspect the problem is at the host?

    Tom

  4. whooami
    Member
    Posted 7 years ago #

    Your current default theme needs to be upgraded.

    upload the default theme inside the 2.2.1 zip -- making sure to either overwrite the existing files, or deleting the old files first.

  5. moshu
    Member
    Posted 7 years ago #

    Did you try deactivate all the plugins?
    Also, I can see you are using WP 2.2.1 - but was your theme ever updated during the upgrades?

  6. tfmurphhk
    Member
    Posted 7 years ago #

    Well, a new problem has arisen.

    I wanted to try deleting the plugins as suggested but when I logged in I got this message:

    ERROR: WordPress 2.2.1 requires MySQL 4.0.0 or higher

    so now I can not get in to admin rights. I am assuming taht MySQL is on the server, over which I have no control??

    The problem seems to have worsened!

    Tom

  7. tfmurphhk
    Member
    Posted 7 years ago #

    OK, here is what I have done... and still no resolution.

    I deleted the entire wordpress folder on my server and then uploaded a full new clean version of WP 2.2.1 fresh from download.

    I then tried to run http://www.pga-auctions.com/wordpress and of course got a message that there was no wp-config.php file, only a wp-config-sample.php

    So I then uploaded only one file... the OLD wp-config.php file that had been in use prior to all these problems.

    And now when I run http://www.pga-auctions.com/wordpress I get the message referred to earlier... "WordPress 2.2.1 requires MySQL 4.0.0 or higher".

    So I am guessing that the problem is NOT on my side, but rather on the Server Side. I will try to get some resolution from my server... but that is never easy.

    Anyone have any ideas for me??

    Tom

  8. moshu
    Member
    Posted 7 years ago #

    It is quite a clear message. Your host has an older version of MySQL. And if you click About on the top of this page and from there Requirements on the left:
    http://wordpress.org/about/requirements/
    You can read this:

    To run WordPress your host just needs a couple of things:

    * PHP version 4.2 or greater
    * MySQL version 4.0 or greater

    You will have to use the 2.0.x branch (2.0.10 being the latest stable) - or find a new host.

  9. tfmurphhk
    Member
    Posted 7 years ago #

    Thanks Moshu... you came up with the solution just a bit before my server did.

    I spoke to them and they advised that the server I was on was not capable of handling 2.2.1 Their solution is to switch me to a different server in their "farm".

    Before I do that I will look at downloading 2.0 and seeing if I can get the blog to run with that. If so, then it will surely confirm the 2.2.1 issue and I can make a decision as to whether to have them switch me to another server.

    Can you advise (in general terms) what I get or lose... by being on 2.0 versus 2.2? Remember, I am not all that tech savy so just some simple layman's explanation please.

    Thanks (everyone here) for all the support and help.

    Tom

Topic Closed

This topic has been closed to new replies.

About this Topic