WordPress.org

Ready to get started?Download WordPress

Forums

WordPress database error (30 posts)

  1. Rea
    Member
    Posted 9 years ago #

    the landing page on my blog is giving me a wierd error at the top and i have no idea what it is. this is what it's saying:

    WordPress database error: [You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near '1o' at line 1]
    SELECT DISTINCT * FROM wp_posts WHERE 1=1 AND post_date_gmt <= '2005-06-16 03:39:59' AND (post_status = "publish") GROUP BY wp_posts.ID ORDER BY post_date DESC LIMIT 0, 1o

    my blog is here: http://blog.letmefall.com/

    thanks in advance for any help. :)

  2. Mark (podz)
    Support Maven
    Posted 9 years ago #

    What happened just before the error happened ?
    Did you install a plugin ?

  3. polyhex
    Member
    Posted 9 years ago #

    Hi - looking at the error, the limit should perhaps be 10, (ie the number ten), and not a number 1 followed by the letter o ?

  4. Myword
    Member
    Posted 9 years ago #

    Not sure where to post this data base error I am getting, I'm new to wordpress.
    The URL http://www.disyasite.com/weblog/wp-admin/install.php shows
    the error msg.
    My Host says that the database is et to go on a windows platform.
    Going round in circles and need resolution ..Can anyone help?
    reply floyd_campbell@hotmail.com

  5. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Your host is talking rubbish - WP loves the Linux platform.

    Do you have a mySQL database ?

  6. stchatterbox
    Member
    Posted 9 years ago #

    yes, this is also what i think, and remember to grant permissions for your MySQL

  7. Myword
    Member
    Posted 9 years ago #

    Thanks for replying..My host says that he has setup the mysql and there is no issue their end.

  8. iand
    Member
    Posted 9 years ago #

    Rea - check your templates for tags that should be inside the loop that are outside it.
    Myword - have you double-checked wp-config?
    http://codex.wordpress.org/Editing_wp-config.php

  9. Mark (podz)
    Support Maven
    Posted 9 years ago #

  10. Myword
    Member
    Posted 9 years ago #

    I'm new to wordpress and installing it to my host..I need advice to move on from here from anyone who can please..

  11. Myword
    Member
    Posted 9 years ago #

    Wp config is set up OK the MSQL credentials OK. The database is ready, it is on windows...all serverside minimum requirments OK, then I run install.php and get this
    http://www.disyasite.com/weblog/wp-admin/install.php

    I am stuck in da mud here..wordpress version 1.5 12 (Zip)

  12. Mark (podz)
    Support Maven
    Posted 9 years ago #

    "MSQL" - you meant mySQL ?

    Who are you hosted with ?

  13. Myword
    Member
    Posted 9 years ago #

    Easyspace.com

  14. Myword
    Member
    Posted 9 years ago #

    Am I posted in the right place..given my thread?

  15. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Yep :)

    Looking at the specs, I assume you have the Platinum or Diamond package as the necessary database is not included in the other package. It looks too as if you need to ask them to activate the db and pass you the details.
    If you do have a mySQL database - no other - and you really are stuck I'll have a go for you if you email me enough information to access your hosting account.
    t2 @ tamba2 . org . uk

  16. Myword
    Member
    Posted 9 years ago #

    The package is platinum and they are adamant there is nothing for them to do..no activation required...windows platform..database is mySQL..Thanks for the offer..I'll try the installation again from scratch and see what happens.

  17. Myword
    Member
    Posted 9 years ago #

    I've done as I said..reinstalled wordpress..I hadn't made any mistakes I can identfy, I get the same results
    http://www.disyasite.com/weblog/wp-admin/install.php

    I would imagine the issue is serverside.

    Anyone got another angle?

  18. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Paste your wp-config.php here ?
    (but REMOVE your password)

  19. Myword
    Member
    Posted 9 years ago #

    // ** MySQL settings ** //
    define('DB_NAME', 'campfad'); // The name of the database
    define('DB_USER', 'campfad'); // Your MySQL username
    define('DB_PASSWORD', 'password'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value

  20. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Okay ..... the DB_NAME looks wrong.
    It usually has something before that - with a site of mine, it is the domain name before the db_name, with another it's the user name.
    That is where I would check your site first.

  21. Myword
    Member
    Posted 9 years ago #

    Could you say that anotherway please? Im not understanding you.

  22. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Did you follow the first link I gave up the top of this thread ?

  23. Myword
    Member
    Posted 9 years ago #

    I think I'm leaving this till I can talk to my host again.
    There is no indication in the folders that mySQL is installed..Thanks for your suggestions so far.

  24. moshu
    Member
    Posted 9 years ago #

    Uusally there "no indication" in the folders about the presence of the MySQL. It might even be on a different server (as happens with many hosts).

  25. Rea
    Member
    Posted 9 years ago #

    the last thing i remember changing is how many posts to show i once. then it went all wacky on me. i have no idea how to look for code that's not in place or anything. i've looked at everything...but i'm still not sure of what exactly i should be looking for.

  26. Rea
    Member
    Posted 9 years ago #

    well after a bit of playing around, i went back to options, made a quick change and it's restored. heh, i hate when stupid things like that happen. thanks for the help! :)

  27. Myword
    Member
    Posted 9 years ago #

    I contacted my host today who once again is insistent that the MYSQL is set up and ready.

    Does wordpress demand the existence of an apache module to run???

    My hosting is on an NT server that is not runing apache mods...

    I'm wondering if this is really my problem. I was told that wordpress would run properly on an NT server.

  28. Myword
    Member
    Posted 9 years ago #

    My host kept on insisting I upload the wordpress database to the folder myself...I wonder where the database is supposed to come from? I gather the install routine of wordpress creates the database itself...Is that correct?

  29. Myword
    Member
    Posted 9 years ago #

    To distill the question "Can I run wordpress on an NT server without the apache module?"

  30. skippy
    Member
    Posted 9 years ago #

    Yes, you can run WordPress on IIS instead of Apache:
    http://cornwall.backtalk.com/archives/2004/07/07/15/16/31/

Topic Closed

This topic has been closed to new replies.

About this Topic