WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Database Backup Plugin (75 posts)

  1. skippy
    Member
    Posted 9 years ago #

    Announcing the WordPress Database Backup Plugin:
    http://www.skippy.net/blog/2005/07/12/wordpress-database-backup/

    This is an easy-to-use plugin to quickly backup your WordPress database. You may download the backup file, or have it emailed to the address of your choice.

  2. eveums
    Member
    Posted 9 years ago #

    Wow, that looks like an awesome plugin, I can't wait to try it! Thanks!

  3. Lorelle
    Member
    Posted 9 years ago #

    I've used it and it is indeed AWESOME.

  4. Lorelle
    Member
    Posted 9 years ago #

    Skippy, will this work on any server?

  5. skippy
    Member
    Posted 9 years ago #

    It ought to work on any server, but the variety of possible server configurations makes it hard for me to offer any definitive answer.

    Lots of people have reported that it works for them. Two people have reported PHP errors. I am waiting on additional information from both of them to determine what caused those errors.

  6. korereactor
    Member
    Posted 9 years ago #

    I'm getting this error:
    Invalid argument supplied for foreach() in /wp-content/plugins/wp-db-backup.php on line 177

    Warning: Cannot modify header information - headers already sent by (output started at /wp-content/plugins/wp-db-backup.php:177) in /wp-admin/admin.php on line 10

    Warning: Cannot modify header information - headers already sent by (output started at /wp-content/plugins/wp-db-backup.php:177) in /wp-admin/admin.php on line 11

    Warning: Cannot modify header information - headers already sent by (output started at /wp-content/plugins/wp-db-backup.php:177) in /wp-admin/admin.php on line 12

    Warning: Cannot modify header information - headers already sent by (output started at /wp-content/plugins/wp-db-backup.php:177) in /wp-admin/admin.php on line 13

    NOTE: I removed the first part of the paths for security reasons in this post.

  7. korereactor: Looking at the code to skippy's plugin I suspect you problem is that you have a table in you database with no rows.

    Looking at your comments feed you have not had any comments on your site yet :(.

    I suspect that if you add a comment to one of your posts the backup will work fine. :)

    westi

  8. korereactor
    Member
    Posted 9 years ago #

    Yea, since I don't use links, that's probably an issue as well. I'll try some things out...

  9. korereactor
    Member
    Posted 9 years ago #

    Yep, that's it. Added a comment and a link and blamo! Works like a champ! Thanks!

  10. Glad that fixed it for you korereactor.

    Props to skippy for one awesome plugin!

  11. korereactor
    Member
    Posted 9 years ago #

    Well, now I have a problem with the wp-cron and email. It's all setup, however, I'm not getting any emails and nothing is happening at the scheduled times. Has anyone got the cron plugin to work with this?

  12. Lorelle
    Member
    Posted 9 years ago #

    This will work great for the WordPress Backup Week coming soon!

  13. oncidium
    Member
    Posted 8 years ago #

    Just want to check on this before I do anything stupid...i get the message: WARNING: Your backup directory is NOT writable!
    /home/content/c/h/e/cherylkemp/html/blog/wp-content/backup/

    If I email or download the database this shouldn't be a problem???

  14. Mark (podz)
    Support Maven
    Posted 8 years ago #

    CHMOD the directory to 777 (change it's permissions)

    And it's not a problem to download / email.

  15. skippy
    Member
    Posted 8 years ago #

    oncidium: as long as your database is comparatively small (under, say, 2 megs) you should be okay. The currently available version of wp-db-backup keeps the whole backup in memory.

    A new version (due very very soon) will spool the backup table by table to a file in the /wp-content/backup directory. This file will be deleted after it is mailed to you.

    It's probably best to grant write permission to your backup directory now, so that you're ready for the new version.

  16. oncidium
    Member
    Posted 8 years ago #

    Thanks for the response, Skippy. Can you tell me how to grant write permission? I thought of that before I wrote my original post, but I don't know how to do it.

  17. skippy
    Member
    Posted 8 years ago #

    See Podz's response, immediately above mine. If you're using FTP, tell us which FTP client you use and we'll try to help.

  18. oncidium
    Member
    Posted 8 years ago #

    Well I thought I had a revelation...but then more problems. Part of the issue is that there was no backup folder in the wp-content directory. I created a new folder named "backup" then right clicked on it and enabled read/write and execute for owner only. That did get rid of the "not writable" error. Then when I tried to back it up I got a TON of errors:

    A bunch of these:
    Warning: fwrite(): supplied argument is not a valid stream resource in:
    a database error and
    a few of these

    Warning: fwrite(): supplied argument is not a valid stream resource in /home/content/c/h/e/cherylkemp/html/blog/wp-content/plugins/wp-db-backup.php on line 155

    It is such a long list I wasn't sure whether I should post it here or not. I usually just use the "my network places" in windows for ftp and I also have Frontpage 2003, although I haven't really been suing it much since I got WordPress going...easier just to do the simple ftp.

    Thanks.

  19. oncidium
    Member
    Posted 8 years ago #

    It also give this statement: Backup Successful!
    Your backup file: cherylkemp_wp_20050802_797.sql should begin downloading shortly.

    then this after I click the link cherylkemp...etc: Forbidden
    You don't have permission to access /blog/wp-content/backup/cherylkemp_wp_20050802_797.sql on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

  20. pineapplemike
    Member
    Posted 8 years ago #

    installed it. when i look at the downloaded file, should it look all messy?

  21. oncidium
    Member
    Posted 8 years ago #

    Oh...sorry I didn't try this sooner. I had checked all of the following boxes for additional components:
    You may choose to include any of the following tables:
    sk2_blacklist
    snipe_gallery_cat
    snipe_gallery_data
    snipe_gallery_frames
    wp_bad_behavior_log
    wp_sk2_logs
    wp_sk2_spams

    If I don't check any of them, it works. It would be great though if there is a way to do it all at once.

    Sorry for the multiple posts

  22. skippy
    Member
    Posted 8 years ago #

    pineapplemike: did you select gzip compression? If you did, then yes it should look messy. Unzip it first.

    oncidium: did you read the included wp-db-backup.txt ? I explain the documentation why I will not support automatic selection of all the additional tables.

  23. oncidium
    Member
    Posted 8 years ago #

    no I didn't read it but I will.

    Guess that means there is no easy way...with that many errors there is no way I can figure it out (nor would it be worth the timek). I think I finally did get myPHP to save it like I wanted. I just want to make sure when I switch servers, I don't mess anything up.

  24. skippy
    Member
    Posted 8 years ago #

    There's no reason to backup the following tables if you're moving servers:
    sk2_blacklist
    wp_bad_behavior_log
    wp_sk2_logs
    wp_sk2_spams

    All of the information in those tables is likely to change with some regularity.

  25. TH
    Member
    Posted 8 years ago #

    In wp-db-backup 1.5 I get the error message:

    "The script to backup your database is too large for PHP to load entirely into memory, and so cannot be compressed within PHP.
    Your database was too large to compress.
    Your backup has been saved uncompressed."

    I read on Skippy dot net about PHP memory limit, but that can't be it because I have don't have more than a few posts. Besides... It worked before. I think it stopped working when I upgraded to the latest version. Any ideas why? I guess I don't need to have it zipped, but it's a bit annoying that the gzip feature is always selected. I just know that I'll try it once each time before I remember to uncheck it.

  26. tqn69
    Member
    Posted 8 years ago #

    TH, I have exactly the same problem: very small number of total posts; initially the plugin compressed my .sql backups; now (starting a week later) it returns the "too large for PHP to load entirely into memory" message. What gives?

    The changed behavior very likely coincided with my upgrading to version 1.5.

    I'd love to know if this can be fixed.

  27. HooverDST
    Member
    Posted 8 years ago #

    TH and tqn69, yeah I've had the same problem (I'm running WP 1.5) but if I uncheck the gzip feature, I don't get the error.

  28. tqn69
    Member
    Posted 8 years ago #

    Hoover, agreed. However, I prefer getting a compressed backup since I'm having them sent daily to my Gmail account. It'd save bandwidth.

  29. HooverDST
    Member
    Posted 8 years ago #

    tqn69, yeah I know what you mean. I'm sure Skippy will fix the issue in the next release.

  30. TH
    Member
    Posted 8 years ago #

    Well... HooverDST, I'm sure you're right about that. This all indicates that there are more of us with this problem. For once I think I have actually been the victim of a bug and not my own stupidity (that tends to screw up even the most simple directions).

Topic Closed

This topic has been closed to new replies.

About this Topic