WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Creating Heavy System Loads (21 posts)

  1. webservant
    Member
    Posted 8 years ago #

    Hi all,

    I received several emails form my hosting company, hostgator, that wordpress is creating too much load on their servers. I disabled all the plugins and it is still the same.

    They sent me this error file below. mysql queries that never complete or die off:

    Can you please advice what to do. I need to sort this out in the next 48 hours or they will ban my domain onlinehealthadvice.com from their hosting. I tried different themes but they tld me it didn't change anything.

    Thank you for your help.

    root@banned [~]# mysqladmin pr | grep onlinehe
    | 480 | onlinehe_wrdp1 | localhost | onlinehe_wrdp1 | Sleep | 2279
    | |
    |
    | 1497 | onlinehe_wrdp1 | localhost | onlinehe_wrdp1 | Sleep | 1982
    | |
    |
    | 1563 | onlinehe_wrdp1 | localhost | onlinehe_wrdp1 | Sleep | 1977
    | |
    |
    | 2422 | onlinehe_wrdp1 | localhost | onlinehe_wrdp1 | Sleep | 1732
    | |
    |
    | 2667 | onlinehe_wrdp1 | localhost | onlinehe_wrdp1 | Sleep | 1670
    | |
    |
    | 2922 | onlinehe_wrdp1 | localhost | onlinehe_wrdp1 | Sleep | 1604
    | |
    |
    | 3065 | onlinehe_wrdp1 | localhost | onlinehe_wrdp1 | Sleep | 1577
    | |
    |
    | 3834 | onlinehe_wrdp1 | localhost | onlinehe_wrdp1 | Sleep | 1413
    | |
    |
    | 4718 | onlinehe_wrdp1 | localhost | onlinehe_wrdp1 | Sleep | 1188
    | |
    |
    | 4846 | onlinehe_wrdp1 | localhost | onlinehe_wrdp1 | Sleep | 1132
    | |
    |
    | 4973 | onlinehe_wrdp1 | localhost | onlinehe_wrdp1 | Sleep | 1123
    | |
    |
    | 4974 | onlinehe_wrdp1 | localhost | onlinehe_wrdp1 | Sleep | 1123
    | |
    |
    | 5199 | onlinehe_wrdp1 | localhost | onlinehe_wrdp1 | Sleep | 1068
    | |
    |
    | 5204 | onlinehe_wrdp1 | localhost | onlinehe_wrdp1 | Sleep | 1071
    | |
    |
    | 5206 | onlinehe_wrdp1 | localhost | onlinehe_wrdp1 | Sleep | 1071
    | |
    |
    | 5610 | onlinehe_wrdp1 | localhost | onlinehe_wrdp1 | Sleep | 979
    | |
    |
    | 5805 | onlinehe_wrdp1 | localhost | onlinehe_wrdp1 | Sleep | 932
    | |
    |
    | 5956 | onlinehe_wrdp1 | localhost | onlinehe_wrdp1 | Sleep | 895
    | |
    |
    | 6495 | onlinehe_wrdp1 | localhost | onlinehe_wrdp1 | Sleep | 768
    | |
    |
    | 6911 | onlinehe_wrdp1 | localhost | onlinehe_wrdp1 | Sleep | 674
    | |
    |
    | 7299 | onlinehe_wrdp1 | localhost | onlinehe_wrdp1 | Sleep | 588
    | |
    |
    | 7786 | onlinehe_wrdp1 | localhost | onlinehe_wrdp1 | Sleep | 465
    | |
    |
    | 8044 | onlinehe_wrdp1 | localhost | onlinehe_wrdp1 | Sleep | 417
    | |
    |
    | 8637 | onlinehe_wrdp1 | localhost | onlinehe_wrdp1 | Sleep | 289
    | |
    |
    | 8669 | onlinehe_wrdp1 | localhost | onlinehe_wrdp1 | Sleep | 282
    | |
    |
    | 8700 | onlinehe_wrdp1 | localhost | onlinehe_wrdp1 | Sleep | 275
    | |
    |
    | 8866 | onlinehe_wrdp1 | localhost | onlinehe_wrdp1 | Sleep | 232
    | |
    |
    | 9119 | onlinehe_wrdp1 | localhost | onlinehe_wrdp1 | Sleep | 172
    | |
    |
    | 9123 | onlinehe_wrdp1 | localhost | onlinehe_wrdp1 | Sleep | 171
    | |
    |
    | 9438 | onlinehe_wrdp1 | localhost | onlinehe_wrdp1 | Sleep | 98
    | |
    |
    | 9878 | onlinehe_wrdp1 | localhost | onlinehe_wrdp1 | Sleep | 1
    | |
    |
    | 9880 | onlinehe_wrdp1 | localhost | onlinehe_wrdp1 | Sleep | 0
    | |

  2. Mark (podz)
    Support Maven
    Posted 8 years ago #

    I've posted to the hackers list for advice.
    What plugins did you have activated ?
    Did the host give you any other details at all apart from the above ?

  3. schestowitz
    Member
    Posted 8 years ago #

    Podz, the host can probably say very little apart from which queries still 'hang'. As for the reason, it's hard to tell as you can't decipher what is actually running. It doesn't seem like the processes devour any resources (they fall under the 'sleep' category). Nontheless, I wonder what spawns this. It might need some experimentation on the OP's side -- seeing what actions trigger an instantiation of such a process (this might require root access).

    A clean install might be worthwhile although I doubt the OP has changed anything in terms of code. Could it be something in the database that mySQL or WordPress cannot handle gracefully? I doubt it.

  4. Ment0r
    Member
    Posted 8 years ago #

    I have/had same problems with wordpress creating heavy loads. Not sure if this matches the above, but maybe it helps if i share my expirience with this..

    Every time i posted an entry it took long to load... the post was saved, but shortly after the server went down or my page gone incredible slow. One time it was so heavy that the whole server crashed. My hoster told me that the file which is eating all system-RAM is "post.php" in the wp-admin folder.

    I think it has something to do with the trackback attempts. Maybe it trys to ping every http:// link and gets no response or something.. then loops till it is dead. I doubt it, because it is known that pingin slows down posting.. in my case it crashes the server (maybe).

    After i had disabled everything regarding pingin and trackback i could use my blog again. i have no plugins modifying something in my adminarea, hacks editing admin files or anything like it. it must be something in the post.php

    Btw.. this issue is out of the box. i tried clean installs, disabled plugins one by one etc.. no luck.

  5. schestowitz
    Member
    Posted 8 years ago #

    Will an unstable version provide a solution until a stable one is released?

    http://wordpress.org/download/nightly-builds/

    There was/is a big pinging mechanisms overhail these days...

  6. Matt Mullenweg
    Troublemaker
    Posted 8 years ago #

    Sleeping connections have nothing to do with load, at all.

    If you don't like them, turn your mysql client timeout lower in your my.cnf.

  7. Ryan Duff
    Member
    Posted 8 years ago #

    Matt pretty much nailed what I was going to say. Does your host really know what is going on? Are they concerned at the ammount of dead process it generates or is there something else they claim to be loading down their servers. I suggest they figure out what they're talking about or send you the correct error logs. If this is the best they can do, maybe its time for a more knowledgable host.

  8. Stefano Aglietti
    Member
    Posted 8 years ago #

    In these days my hosting was expiriencing a large load on the mySQL server by few users that saturated it, in his forum wordpress-it.it (Support and info in italian about WP) was signed as a site that do a lot of trafic and a lot of queries (WP e bbpress) in a so clean way that they aimed to us as an example of a tracciated site but a polite one. We still use 1.5.2 and few plugins on the production site. So I suppose that the problems is the hosting service that doesn't know what they are doing, maybe havng trouble with theyr server and pointing the finger to ther first stupid thing they got in they logs.

    If WP have had hat problem this forum should have been flooded with request for same problem.

  9. davidchait
    Member
    Posted 8 years ago #

    Dreamhost has recently been sending a few notes to folks using too much CPU time (>30 cpu-minutes per day, I think) based on WP sites. So this isn't quite so isolated. But we haven't a clue what the real overhead is, what scripts are taking up time, etc.

    -d

  10. wangxiaohu
    Member
    Posted 8 years ago #

    My wangxiaohu.org got the same problem. I was told by my host provider that index.php was consuming about 50% of CPU for more than 4 hours before it was manually shut down.

    It is WP 2.0.1 running on a Windows server. The plugins it was using are:

    1. Archivist (Bring some old posts back to the front.)
    2. Get Recent Comments
    3. Photopress Plugin
    4. Subscribe me (Allow others to subscribe this blog)
    5. wpLicense (Add Common License notice to this blog)
    6. Lightbox Plugin (JS powered overlay popup)
    7. Jalenack’s Wordspew (AJAX based shout box)
    8. Counterize (hits and other statistics)
    9. LiveJournal Crossposter

    Please help! THANKS!

    Yu

  11. wangxiaohu
    Member
    Posted 8 years ago #

    I found that it is cache.php cause the heave load for my problem mentioned above. See the error below:
    -----------------------------------------
    Fatal error: Maximum execution time of 90 seconds exceeded in c:\websites\wangxiaohu364\wangxiaohu.com\wp-includes\cache.php on line 344
    -----------------------------------------

  12. wangxiaohu
    Member
    Posted 8 years ago #

    Disabling the cache system solved the problem. In wp-config.php:

    define('DISABLE_CACHE', true);

  13. nevermore
    Member
    Posted 8 years ago #

    Ha, I have been noticing that while working in WP my system is hanging and slower than usual..(slow anyway). So If I disable cache that should work?

  14. CrustyGeek
    Member
    Posted 8 years ago #

    Thanks for that - it's really speeded up my site.

  15. Can
    Member
    Posted 8 years ago #

    Mine too. Thank you!

  16. davidchait
    Member
    Posted 8 years ago #

    The cache should only be a problem on 'broken' systems, where the cache directory isn't writeable. Hopefully it'll default off for the next release...

    If POSTING seems to be hanging, that's a different issue -- remove Pingomatic from your pings list...

    -d

  17. newthis
    Member
    Posted 8 years ago #

    This solved my problem with installing to a subdirectory not working too. Thank you.

  18. nevermore
    Member
    Posted 8 years ago #

    """Disabling the cache system solved the problem. In wp-config.php:

    define('DISABLE_CACHE', true); """

    I find after a day on here using WP, the wait time for pages and programs is beyond belief. when i close something, it starts from the top and slowly folds downwards..at other times, everything hangs for an incredibla amount of time and i have gotten notice of low memory even when all is closed down..should i do the above as suggested in another post? what causes the ram overload?
    cheers, Laurie

  19. WPChina
    Member
    Posted 8 years ago #

    My wp-config.php does not have define('DISABLE_CACHE', true);

    Should I add it?

    tks!

  20. davidchait
    Member
    Posted 8 years ago #

    if running 2.0.4, I believe it is disabled by default. if running earlier, yes, you should probably manually add it.

  21. svillemain
    Member
    Posted 8 years ago #

    Disabling cache worked for me.

    Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic