WordPress.org

Ready to get started?Download WordPress

Forums

WordPress changing my post HTML...not wanted (11 posts)

  1. jasong955
    Member
    Posted 6 years ago #

    When I load and edit a post in wp-admin, WP changes the HTML formatting automatically and I cannot find how to disable that. It adds TONS of unnecessary HTML tags - <FONT...> and others. I use my own HTML formatting and don't want WP to mess with it. Is there a way to disable WP's ability or desire to change/add formatting HTML to my posts? Thanks.

  2. moshu
    Member
    Posted 6 years ago #

    Stop copy/pasting from MS Word and/or other bad word processors into the wysiwyg editor.

  3. muppetfreak
    Member
    Posted 6 years ago #

    I am having a similar problem but I am NOT copy and pasting. I am using a blog editor (Qumana) and WordPress is changing the HTML when I upload. This is really frustrating. How do I get it to leave my HTML alone?

  4. EDFMedia
    Member
    Posted 6 years ago #

    I am having the same issues and since I hand code all of my HTML copying/pasting from bad word processors really does not help me much.

  5. moshu
    Member
    Posted 6 years ago #

    Handcode into the wysiwyg? That's not a good idea. I also hand code my html in the simple editor (NOT switching between Code and Visual but completely turning wysiwyg off!) - and I never have any problems.

  6. lkrubner
    Member
    Posted 6 years ago #

    I hand code into the simple editor (not the WYSIWYG editor) and WordPress is rewriting all my HTML. I need for it to stop. How do I make it stop?

  7. moshu
    Member
    Posted 6 years ago #

    Is the wysiwyg completely turned off (admin > Users > Your profile)? If you just switch between Visual and Code (as I said above) the wysiwyg is still ON when saving the post, so it will screw up your html...

  8. lkrubner
    Member
    Posted 6 years ago #

    If I log in as "admin" and click on Users, then click on "Your Profile", I see a box on the left that says "Use the visual editor when writing". When I turn that off, I continue to have problems with WordPress re-writing my HTML.

  9. moshu
    Member
    Posted 6 years ago #

    I don't and I never had.
    No, it might also depend on what are you trying to insert into the content...

  10. lkrubner
    Member
    Posted 6 years ago #

    My email address is lawrence@krubner.com. Write to me if you like and I'll send you a username and password. You can login and see the problem.

  11. moshu
    Member
    Posted 6 years ago #

    Better read my reply in the other thread you posted :)
    It's your theme, not WP!

Topic Closed

This topic has been closed to new replies.

About this Topic