WordPress.org

Ready to get started?Download WordPress

Forums

huge serverload through old urls after move - how to have direct 404 page? (2 posts)

  1. inspirationally
    Member
    Posted 3 years ago #

    Hello, I hope you can help. 1 1/2 years we worked on switching our site to WordPress. Now Christmas, we opened it to the public, just to see the serverload runs to 20 and more. Sometimes over 100 server crashing.

    I tried around and came now to deactivating ALL plugins, going back to the default style coming with wp 3.0.3 but still: serverload sometimes over 10.

    In the apachestatus in web host manager i can see, that many old Urls are requested - pictures at different places before and now - because of the new gallery structure - elsewhere on the server, the comments are now different, thousands of URLs I cannot simply redirect with one of those redirect plugins, cause it is too irregular.

    And I have the guess, this is what causes the high serverload - wordpress cannot work with those many requests to pages that does not exist. I have the usual permalink structure with category/year/month/day/topic, lots of static pages. If you put in some not existing url, wordpress searches for a site that could be it.

    If I disable permalinks to use ?p=123, people are sent directly to an ugly 404 error page. Which makes the serverload not go above 2, server running smootly at about 1.5 -

    so it is no plugin, no bad theme,
    just the fact that we moved the site.

    Do you have an idea how I can get around this? That the permalink use ALSO sends dead urls directly to 404 before searching in the database for something related?
    Otherwise, 1 1/2 years are for NOTHING.

    Thank you very much and Merry Christmas, Martina.

  2. inspirationally
    Member
    Posted 3 years ago #

    No solution on this? :-(
    I also found this which is "exactly" the problem we have:
    http://core.trac.wordpress.org/ticket/11843

Topic Closed

This topic has been closed to new replies.

About this Topic