WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WordPress causing coredumps (10 posts)

  1. Mr_Cynical
    Member
    Posted 8 years ago #

    I'm running WordPress on a (shared) Linux hosting account, and for some reason it is causing core dumps to appear in my server- at 13meg EACH. The reason I know that WordPress is causing these is that one of the few discernible bits of text (from the gibberish and squares in the file) is WordPress Error. I haven't changed anything on my WordPress install recently, so does anyone know what could be causing this?

  2. MichaelH
    Member
    Posted 8 years ago #

    Server reboot not likely an option? If nothing has changed in WordPress maybe it isn't WordPress. Can you get to your MySQL database and backup it up?

    Can you get phpinfo? See http://codex.wordpress.org/Finding_Server_Info

  3. Mark (podz)
    Support Maven
    Posted 8 years ago #

    How often are these dumps appearing ?
    Where EXACTLY on the server are they appearing ?
    What plugins do you have running ?

  4. Mr_Cynical
    Member
    Posted 8 years ago #

    After I deleted the first batch, two of them appeared inside nine minutes. So I'd guess about one every five minutes until my storage gets maxed (my domain host has since set up a cronjob to delete them that runs every five minutes).

    Plugins:
    Bad Behaviour
    Blacklist
    Comment Quicktags
    ESF 1.0 Feed
    Fancy Excerpt
    Fancy Tooltips
    Follow URL
    Force Word Wrapping
    Frame Buster
    Mod-Rewrite Trackback Spam Blocker
    Official Comments
    RSD 1.0
    Simple Search & Replace
    Tag Remix

    As for the phpinfo, heres what I got, I've just copypasted it if that's OK (file is at http://www.davidarussell.co.uk/info.php):

    System Linux server1.dnsblock.com 2.4.30-grsec #1 Wed Apr 20 07:39:42 BST 2005 i686
    Build Date Apr 21 2005 14:20:32
    Configure Command './configure' '--prefix=/usr' '--with-xml' '--enable-bcmath' '--enable-calendar' '--with-curl' '--with-dom' '--with-dom-xslt' '--with-dom-exslt' '--with-swf=/usr/local/flash' '--enable-ftp' '--with-gd' '--with-jpeg-dir=/usr/local' '--with-png-dir=/usr' '--with-xpm-dir=/usr/X11R6' '--with-gettext' '--with-imap' '--with-kerberos' '--with-mcrypt' '--with-mhash' '--with-ming=../ming-0.2a' '--enable-magic-quotes' '--with-mysql' '--enable-discard-path' '--with-pear' '--enable-safe-mode' '--enable-sockets' '--enable-track-vars' '--with-ttf' '--with-freetype-dir=/usr' '--enable-gd-native-ttf' '--enable-versioning' '--with-xmlrpc' '--with-zip' '--with-zlib'
    Server API CGI
    Virtual Directory Support disabled
    Configuration File (php.ini) Path /home/usrback/Zend/etc/php.ini
    PHP API 20020918
    PHP Extension 20020429
    Zend Extension 20021010
    Debug Build no
    Thread Safety disabled
    Registered PHP Streams php, http, ftp, compress.zlib

  5. Mark (podz)
    Support Maven
    Posted 8 years ago #

    Got phpmyadmin ?

    Go look at the database WP is in. Look at the sizes of each table.
    Optimise / repair the tables ( http://www.tamba2.org.uk/wordpress/repair/ )

    Which tables are the biggest ?
    You didn't mention where these dumps are being saved on the server.

  6. Mr_Cynical
    Member
    Posted 8 years ago #

    Sorry, they're being saved in the 'root 'of my web-accessible area (/public_html/)- the same directory that I have WordPress in.

    EDIT: I've done the repair process you linked to, some of those 'overhead' numbers were worryingly large. I'll keep an eye on it and see if any more coredumps occur.

  7. Mark (podz)
    Support Maven
    Posted 8 years ago #

    The overhead numbers do occur, it's normal - a bit like having to defrag your HD.
    Look at the overall size of each table - I'm wondering of your host has a setup which causes certain data to be dumped if the db size exceeds a set level. If so, then there may be a way to limit or remove tables.

  8. Mr_Cynical
    Member
    Posted 8 years ago #

    It's still doing it (after the PHP MyAdmin repair) and the database is only 1.38 megs. I'll backup my database and try a full, fresh install of WordPress, maybe one of the plugins I had before has screwed something up.

  9. Mr_Cynical
    Member
    Posted 8 years ago #

    Still don't have the faintest idea what was causing it, but reinstalling WordPress (although a bit of a pain) seems to have solved the problem

  10. nieuws
    Member
    Posted 8 years ago #

    Perhaps you should ask some friends to monkey-proof trial and error parts of the site while you check the serverload. part by part you can determine where the problem is located.

Topic Closed

This topic has been closed to new replies.

About this Topic