WordPress.org

Ready to get started?Download WordPress

Forums

WordPress blog not recognized as valid rss by reader (17 posts)

  1. mstrjack
    Member
    Posted 8 years ago #

    Hey everybody,
    I'm not new to blogging, just to using WordPress, and I have a slight problem with accessing my blog. I use the free RssReader software to link to and read the blogs and newsfeeds I check on a regular basis. When I try to add my new WordPress blogs to my favorites in this software, it claims an error is found in the code, and suggests validation. When I validate the rss feed, the validator finds a few "code errors", but still validates the feed. However, RssReader still refuses to add my blogs to my lists. Has anyone else run into this problem? And is there an easy fix? Or do i need to simply change the software i use to read feeds? Thanks for any info anyone out there might have. p.s.- my blog did validate and was picked up by technorati automatically, so again, I don't know if the problem is with the WordPress software or with RssReader. Thanks,
    Jack

  2. evilzenscientist
    Member
    Posted 8 years ago #

    Which RSS feed are you using? Give us a sample url.

  3. mef526
    Member
    Posted 7 years ago #

    I am having a similar problem. It looks like the WOrdPress is working OK but RssBandit anc't add it t the subscribed ist: Feed not found. Here's the link : http://CodeInsight.com/rss

  4. hjabb
    Member
    Posted 7 years ago #

    Hey I'm having the same prob. I got an rssReader working in Flash however, its not working correctly showing the images, links bold text.. and such.. and it says its not a valid rssfeed.. and does anyone know why WordPress add's [...] and cuts off the rest of the posts? It does it on all the feeds if they are over a certain length or something...?

    Please help :)

  5. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    and does anyone know why WordPress add's [...] and cuts off the rest of the posts

    Go to Options->Reading and turn on Full Text instead of Summary mode.

  6. hjabb
    Member
    Posted 7 years ago #

    its already set on Full Text... any more suggestions? I could sure use em :)

    I got rid of the [...] if I use the file wp-rdf.php..? any thoughts

  7. hjabb
    Member
    Posted 7 years ago #

    http://ezekieldesign.com/wordpress/wp-rss2.php - you see the [...] added in there? I'm using an rssReader and it shows that rather then the entire feed.. and it wont load the actually page like /wordpress/ because of the obvious reasons.

  8. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    The correct URL for your feed is this:
    http://ezekieldesign.com/wordpress/?feed=rss2

    And looking at your file, it looks perfectly correct to me. Yes, the <description> contains the excerpt, but the <content:encoded> contains the full text of your posts, and any feedreader worth its salt should recognize that and display the full text correctly.

    The description is the summary and Firefox only displays the summary. That's normal. But an actual feedreader will display the full text.

    Also, you're still running WordPress 2.0.4. Upgrade to 2.0.10, at least.

  9. hjabb
    Member
    Posted 7 years ago #

    i've still got 2.0.4

    how would I read only a certain category? I've got a news I want to display only as news, and dates only as dates.. through the rss reader in flash.

  10. rudolf45
    Member
    Posted 7 years ago #

    I don't know what is a reader in flash... but for categories:
    http://www.ezekieldesign.com/wordpress/?cat=2&feed=rss2

  11. hjabb
    Member
    Posted 7 years ago #

    awesome, thanks! How do I get rid of the [...] ?

    I opened the file http://ezekieldesign.com/wordpress/wp-rdf.php and there isn't a [...] but it still doesn't show the entire post. :(

  12. rudolf45
    Member
    Posted 7 years ago #

    Stop messing with that file. I don't think it has anything to do with the RSS feeds.

  13. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    You don't get rid of it, because it's not there. Not where you think it is anyway.

    The <description> shows the excerpt, as it is supposed to do. However, the actual content is contained in the <content:encoded> field, like it is supposed to be.

    Firefox shows only the description. Other feedreaders show the full content.

    And stop referencing those files directly! You should never, ever use a link to wp-rss2.php or wp-rdf.php or any of those. The correct links for your various feeds, in your case, are:
    http://ezekieldesign.com/wordpress/?feed=rss2
    http://ezekieldesign.com/wordpress/?feed=rdf
    http://ezekieldesign.com/wordpress/?feed=rss
    http://ezekieldesign.com/wordpress/?feed=atom

    Although you should probably only ever use the rss2 one. The rdf one is a special case which you probably don't need.

  14. hjabb
    Member
    Posted 7 years ago #

    awesome, thanks.. checked it in Safari and it showed the entire topic.. Now when I test the rssRead on my harddrive it works, but adds the [...] Maybe I should see if I can test it in Safari, does this mean that whenever ppl such as myself are using firefox the news topic will prob. always be cut off? If so sounds like you know and understand a lot about this topic, do you know if there is a why to make it so even in FireFox it will display only the content:encoded rather then the excerpt? I see it in the code and thats exactly what its doing.. Its not pulling in any of the content.. :( Just like FireFox. And that was using the flash player off my harddrive testing it...

    thanks for all and any more help!!!

  15. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    Well, you're not supposed to use feeds directly like that, you're supposed to subscribe to them with a feedreader.

    Firefox is not a feedreader, all it can do with feeds is display the summaries and use them in the Live Bookmarks. Subscribe to it in Google Reader instead, for example, and you'll see what it looks like to most users.

  16. hjabb
    Member
    Posted 7 years ago #

    ok cool, looks like all is working well now, thanks! :)

Topic Closed

This topic has been closed to new replies.

About this Topic