WordPress.org

Ready to get started?Download WordPress

Forums

WordPress blog causing 404 links of website. (21 posts)

  1. Irene Cros
    Member
    Posted 1 year ago #

    I have recently had a WordPress blog added to my website. Since the blog went live it has creted over 400 404 errors on my business website. (Information from Google webmaster tools).

    Any ideas why, and what I can do. P.S. I am not the person involved in the development of the site or blog. Just the business owner.

    Thank you.

  2. s_ha_dum
    Member
    Posted 1 year ago #

    Any ideas why, and what I can do.

    Nothing definitive without more information.

    Are you saying that the 404 errors are for URLs that do not belong to WordPress? WordPress is causing errors for pages that do exist and used to work?

    What is your URL?

    Can you post a screenshot somewhere of your Google Webmaster tools crawl error page showing the 404 URLs, or just copy and paste representative sample of them?

    Is it possible to get the person involved who is responsible for developing the website?

  3. Irene Cros
    Member
    Posted 1 year ago #

    Thank you.
    Yes, I will be able to work with my web person after the holidays. I just wondered whether it was something I could myself from WordPress.org.

    Is there some way I can send the URL or screen shot without making it public?

    Thank you.

  4. s_ha_dum
    Member
    Posted 1 year ago #

    Whether or not someone here can walk you through a fix depends on how much information you provide, which means answering questions as accurately as you can. My questions above are mostly unanswered.

    Is there some way I can send the URL or screen shot without making it public?

    No, but what would be sensitive in a screen shot of broken URLs? All I need is a representative sample. You can copy and paste ten or so if you want.

    What is your URL?

  5. Irene Cros
    Member
    Posted 1 year ago #

    Thank you.

    Hi, the url is :

  6. s_ha_dum
    Member
    Posted 1 year ago #

    Your anchor tag is malformed. Looks like only created the first part of it. You can paste raw URLs or you can use the 'link' button above the edit screen.

  7. Irene Cros
    Member
    Posted 1 year ago #

  8. s_ha_dum
    Member
    Posted 1 year ago #

    Ok. The URL is only part of the information I asked for, and it is insufficient. If you can't answer my questions you are wasting my time and you will need to wait until your web person gets from the holidays to solve this. Your choice.

  9. Irene Cros
    Member
    Posted 1 year ago #

    Hi there,

    Sorry about this. But I didn't want to put links on the web which can be picked up in Google searches. That may seem mad, but I have no idea how this works.
    Here's some examples from the list of errors.
    Is it any good?
    Thanks

    blog/tag/international-house-teacher-training/about.php
    404
    blog/2012/07/22/great-opportunity-to-win-a-free-teacher-training-course/about.php
    404
    blog/category/tefl-courses/about.php
    404
    blog/2012/08/about.php
    404
    blog/tag/learn-a-language/about.php
    404
    blog/category/tefl-lesson/about.php
    404
    blog/2012/08/01/the-2012-olympics-learning-and-teaching-olympic-language/about.php
    404
    blog/category/language-learning/about.php

  10. s_ha_dum
    Member
    Posted 1 year ago #

    But I didn't want to put links on the web which can be picked up in Google searches.

    Google won't read text inside an image. (That is why you should always use your "alt" attribute :) )

    Ok. That tells me what I wanted to know. Those are WordPress URLs, and all of them end with 'about.php'. ???

    Tell me what you have at wp-admin->Settings->Permalinks for "Common Settings"

  11. Irene Cros
    Member
    Posted 1 year ago #

    http://www.crossroadslanguages.com/blog/2012/08/05/sample-post

    The only setting selected is 'day and name' See link.

    Not all the errors end in 'about php'. there are now about 550 errors linked to the blog ...

    Hope that's what you needed.

    Thank you.

  12. s_ha_dum
    Member
    Posted 1 year ago #

    It is starting to seem like your server does not have mod_rewrite installed and enabled. Your web person may know, or you may need to check with your host.

    mod_rewrite is an Apache (your site is on an Apache2 server) module that allows urls like sitename.com/index.php?p=123 to be rewritten into a human friendly version like sitename.com/2012/01/01/howdy-ho. You must have mod_rewrite for those URLs to work.

  13. Irene Cros
    Member
    Posted 1 year ago #

    Many thanks for all your help. I will pass everything on to the site designer/developer when he's back. He looks after the hosting too.

    Can he get back to you if he has questions, as obviously he'll be better on all this than I am?

    Again, thank you for everything.

  14. s_ha_dum
    Member
    Posted 1 year ago #

    Can he get back to you if he has questions, as obviously he'll be better on all this than I am?

    Yes, of course, right here on the forums.

  15. Irene Cros
    Member
    Posted 1 year ago #

    OK. Thanks a lot.

  16. Irene Cros
    Member
    Posted 1 year ago #

    Hi, I have spent some time looking at 'permalinks' etc. and the URLs on the web site.
    The web site is bilingual and all the URLs, except the home, end in php?lang=en. The list of crawl errors all (most) end in php

    None have the language added. Is it possible that this is what is causing the problems ?

    Thanks.

  17. s_ha_dum
    Member
    Posted 1 year ago #

    It looks like you switched to the default permalinks, and it looks like everything works now. That makes me think it is more likely to be the mod_rewrite problem I mentioned.

  18. Irene Cros
    Member
    Posted 1 year ago #

    Hi,
    Thanks for the message. Yes I changed to default to see what happened, but then I didn't know how to check whether it had done anything.

    How can you see that it is working?

    Thanks.

  19. s_ha_dum
    Member
    Posted 1 year ago #

    How can you see that it is working?

    I clicked around on your blog and nothing broke. Your visitors, including me, would see the broken (404) errors just like Google does. I remember trying it before and a lot of things triggered that 404 error.

  20. Irene Cros
    Member
    Posted 1 year ago #

    Hi, that's strange because I was never able to cause an error from my blog... It was only the messages from Google that notified me that there were errors.

    I have now re-selected date and name, because when I was trying to check for errors just a few minutes ago, I saw that if I did a google search for the blog, google brought up the blog, but the links were broken ...

    Now I have changed it back to what it was (date and name) and at least the links from google searches work.

    I'm going to give up on this. I will pass your information on the the person in charge of the web when he gets back.
    Many thanks.

  21. s_ha_dum
    Member
    Posted 1 year ago #

    Hi, that's strange because I was never able to cause an error from my blog... It was only the messages from Google that notified me that there were errors.

    WordPress handles 404 errors more or less gracefully. If you aren't looking for them it may not be obvious.

    Yes, you should leave this alone. :) As it is, Google, and every other search engine, has a set of broken links. If you start altering the permalinks, they will have several sets of broken links. Put the permalinks back to 'default' and leave it alone until your web person gets back. Those 'default'-- p=123 -- links should pretty much always work.

Topic Closed

This topic has been closed to new replies.

About this Topic