WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WordPress and Google Apps (9 posts)

  1. Falcon1986
    Member
    Posted 5 years ago #

    I have a blog set up and running WordPress 2.5.1 just fine. Recently, I was able to migrate all of my mail handling to Google Apps. E-mail can be sent and received from one account to another.

    The problem that remains is that any time WordPress tries to send out mail (e.g. when a new user signs up or through a contact form), nothing ever arrives at the Google Apps-hosted accounts. Instead, it gets stuck in duplicate e-mail accounts still on the local server.

    What can I do to get my WordPress blog to start sending mail from the Google Apps accounts? Is there a special plugin I can use?

    Thank you for your time.

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    What about email from third parties? Where do those go?

    I use Google Apps and WordPress on a domain with no issues. Email goes mostly where I would expect it to go. I did nothing special to set this up.

    Note that if you just migrated your email, and made the DNS changes, then those changes take time to propagate. A couple days or more.

  3. Falcon1986
    Member
    Posted 5 years ago #

    Well, Google Apps has been set up and running for about a month now.

    E-mail accounts under Google Apps can receive and send e-mail to any recipient I have used so far. I have no problems with that part.

    Again, the only problem occurs when WordPress tries to send e-mails itself. Instead of sending mail to/through the remote Google Apps accounts, mail is sent to the local accounts.

  4. Falcon1986
    Member
    Posted 5 years ago #

    I tried registering with my blog using my private Hotmail e-mail address and surprisingly, username and password information is sent out.

    The problem seems to be with the WordPress sending e-mails to addresses within its own domain.

  5. Falcon1986
    Member
    Posted 5 years ago #

    I'm upgrading this thread to the 'Resolved' status.

    Everything is working just fine now. Turned out I did not need to edit any SMTP settings as I was starting to believe.

    The culprit of this whole problem was a little option that was activated in the MX Settings of cPanel. After setting the MX Entries I entered as instructed by Google Apps I should have disabled "Always accept mail locally even if the primary MX does not point to this server."

    Mail is now being sent by WordPress. Hooray!

  6. stickel
    Member
    Posted 5 years ago #

    I'm having the same problem, sort of. I have Google Apps set up and it works wonderfully with my emailing needs, but I'm not receiving any of my wordpress notification emails.

    The WP settings are set to send emails on comments and comments waiting approval but those emails don't ever show up in the Google Apps email. I'm using media temple's (dv) server and it's a pretty vanilla WP install.

    Anyone have any ideas?

  7. tyr
    Member
    Posted 5 years ago #

    Stickel, I was having the same problem on my MT site, and I JUST figured it out!

    When you move to Google Apps for your email, there's a place in the admin panel to let the servers know that you're not using MT for your email.

    Within your admin panel, click on the "enable/disable mail" button.

    There you get the option:

    Choose 'YES' if the MX record for the domain is pointed at your (mt) Grid-Service. Choose 'NO' if you are hosting your email on a different server.

    You'll need to select no.

  8. basketball
    Member
    Posted 5 years ago #

    Thanks for the tip tyr, exactly what I was looking for!

  9. parrfolio
    Member
    Posted 4 years ago #

    Anyone know how to resolve this with a Dreamhost account? I'm having the same problem of no worpdress email with google apps email for my domain.

Topic Closed

This topic has been closed to new replies.

About this Topic