WordPress.org

Ready to get started?Download WordPress

Forums

"WordPress Already Installed" ??? (8 posts)

  1. Douglas Bell
    Member
    Posted 8 years ago #

    I'm trying to install WordPress, and the install script gives me "Already Installed

    You appear to have already installed WordPress. To reinstall please clear your old database tables first."
    The problem is that this is not true! I haven't installed WordPress before, and the database table that I'm installing it to was created in CPanel 5 minutes ago! Why is it giving me this?

  2. Douglas Bell
    Member
    Posted 8 years ago #

    *bump*

  3. moshu
    Member
    Posted 8 years ago #

    and the database table that I'm installing it to was created in CPanel 5 minutes ago

    1. Don't bump, please. Helpers are allergic to that word :)
    2. You are not supposed to create "tables" - only an empty database. If you created tables that's the reason the install script "thinks" WP is already installed. Creating the tables is the task of that script.

  4. Douglas Bell
    Member
    Posted 8 years ago #

    What I meant was an empty database. I created an empty database, which is the one I specified. When it gave me the error, I deleted it and recreated it, and it still gave me that error. The database is empty, not a single table in it.

    I do have an installation of WordPress on a DIFFERENT DATABASE on the same server, would that cause an error?

  5. moshu
    Member
    Posted 8 years ago #

    Are you sure the 4 pieces of info in your wp-config.php file are pointing to the new database and not to the old one?

  6. Douglas Bell
    Member
    Posted 8 years ago #

    I am positive. I checked it over and over again.

  7. Douglas Bell
    Member
    Posted 8 years ago #

    Oops, I found my error! I went to the install script of the other WP installation I had already installed! Sorry! *embarrassed*

  8. moshu
    Member
    Posted 8 years ago #

    I have WP installations that are in the same database (just different prefix) and still no problems.

    Edit. Glad you sorted it out.

Topic Closed

This topic has been closed to new replies.

About this Topic