WordPress.org

Ready to get started?Download WordPress

Forums

[closed] WordPress admin running extremly slow! (28 posts)

  1. analuciadacruz
    Member
    Posted 2 years ago #

    I'm running the 3.3.2 wordpress version in two websites, and my admin panel has been incredibly slow!
    Any tips about what is making this slow down?

    I've already uninstalled and reinstalled all plugins, i'm only running a contact form plugin and the Wp-Supercache plugin.
    Also after posting a new post it takes forever to see it on my website, etc.
    I've already contacted my host service and they explained me that this is related with wordpress.

    Anyone having the same problem? Anyone figured out what to do?

    Thank you!

  2. Johnb81
    Member
    Posted 2 years ago #

    How is it when you try to browse the website (i.e. not the admin panel)?

  3. esmi
    Forum Moderator
    Posted 2 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress.

  4. analuciadacruz
    Member
    Posted 2 years ago #

    When I open the website on Safari, Google Chrome or Mozilla it opens really fast.
    Working on the website via FTP is also really fast, even uploading photos via FTP is fast.. the only issue is working on the wordpress admin panel, that's why I think this could only be a wordpress issue.
    I've done what you told be about the plugins, I only had 2 the contact form and the WPSuperCache.
    I've reinstalled my theme too!

    If i re-upload the wp-includes and wp-admin do i loose information on the website?
    thats the only thing of what you suggest that i didn't do!

  5. Matthew Horne
    Member
    Posted 2 years ago #

    Sometimes updating wordpress can cause some problems, so you could also try this.

    Deactivate all plugins
    Rename your wp-content file, by adding 1 on the end, Back up you database
    http://diywordpressblog.com/backing-up-wordpress-database/

    Download the database to your computer with just the basic export options ticked, no need to tick any others. Just ensure its SQL.

    then uninstall wordpress

    Reinstall wordpress and re-upload the database.

    If you need help with uploading the database let me know.

    Then after all that is complete, optimize your database.

    http://diywordpressblog.com/how-to-optimize-phpmyadmin/

    You will only loose info if you delete wp-content and the database, these are the key parts to your site.

  6. Matthew Horne
    Member
    Posted 2 years ago #

    If you still have problems after that link the site and ill take a look.

  7. esmi
    Forum Moderator
    Posted 2 years ago #

    Have you checked your server's error logs lately?

  8. analuciadacruz
    Member
    Posted 2 years ago #

    I've got a never ending list of errors for today, mostly related to MySql database.
    What should I do?
    Unistall wordpress and re-install it again, backing up my database an then uploading it?
    I'm truly disappointed with this, i only had so many errors on the beginning, when i was creating my website and having all these again is truly disappointing!
    Any suggestion?

  9. analuciadacruz
    Member
    Posted 2 years ago #

    Right now i'm having an "error establishing data base connection" everytime i'm working on the admin panel for a while... help!

  10. esmi
    Forum Moderator
    Posted 2 years ago #

    Contact your hosts.

  11. Johnb81
    Member
    Posted 2 years ago #

    If you are having error connecting to the database it means that or the database name, or username or password is not correct. I agree with @esmi, I guess the best option here is to contact your hosting provider.

    It is almost impossible to solve such a problem without having any access.

  12. marianograndioso
    Member
    Posted 1 year ago #

    I have the same issue with a WP multisite I'm working on.
    Everything was working fine until yesterday. Now the front-end works as before, but the backend takes like 10 secs to load every time.
    I've tried deactivating all plugins and adding define('WP_MEMORY_LIMIT', '512M'); (and other values as well) to wp-config, but neither seems to work.
    I don't remember exactly what I've done before it stopped working. I've had an update recently (to 3.4.2), added some plugins, changed the max upload file size value (which I tried changing back) and other stuff...
    Any ideas ?

  13. NiallDarwin
    Member
    Posted 1 year ago #

    I'm sure this should exist but after some searching I haven't found what I'm after so this seems the best place to put it:

    Is there a tutorial / step by step guide to optimising a WP install for speed?

    My site piwiwiwi.co.nz is drastically slow and various friends / techies give me all types of conflicting advice. These forums offer lots of little bits of useful advice but has anyone tried to summarise it into a 'Try these 10 things first' or similar?

    Thanks, N :)

  14. esmi
    Forum Moderator
    Posted 1 year ago #

    Please post your own topic.

  15. pwhstacy
    Member
    Posted 1 year ago #

    Hello,

    May be server issue, contact with your hosting provider

  16. conorrefresh
    Member
    Posted 1 year ago #

    Hi, Have you been able to find a solution? sounds like I have a similar problem so would be interested to know how you fixed it.

    Thanks

  17. franzbel
    Member
    Posted 1 year ago #

    Hi !

    Same problem over here...

    I've developed my own theme using a few custom types posts. The frontoffice works great but the admin is really slow : 20 sec to load the page !

    Admin page loading time :
    - Total query time: 170,1ms for 96 queries (0,170073032379150s)
    - Page generated in 21 000,0ms; (21,4154109954833984375000s); 99,19% PHP; 0,81% MySQL

    Solutions :
    - I've desactivated all the plugins, it doesn't change anythin.
    - If I change to wp defaut theme, the admin is fast ! => There is well a problem with my own theme...
    - I've desactivated my custom types post,it doesn't change anything.
    - I've updated wp, it doesn't change anything...

    Any idea how to fix this ?

  18. sjsteiner
    Member
    Posted 1 year ago #

    Same issue here.

    I can no longer even log in to my admin page. First it was really slow, now nothing.

  19. WPProHelp
    Member
    Posted 1 year ago #

    @franzbel

    Since you found out that it is definitely your theme, that is already a good start. To start troubleshooting this you can:

    1. Check if ALL pages in the admin panel are slow or not. If not, check what these pages are using related to your theme.

    2. If all pages are slow, might as well strip all of your theme and start building it slowly and test the admin panel each time.

  20. sjsteiner
    Member
    Posted 1 year ago #

    @ WPProHelp Member

    What could be the problem if I cannot even get into my admin page?

    It takes forever attempting to load and says "Connecting..." and finally just times out.

  21. WPProHelp
    Member
    Posted 1 year ago #

    @sjsteiner

    To start off with, did you try to disable all plugins and switch to the default theme? That should work. If that does not work, then we must start looking into something else.

  22. sjsteiner
    Member
    Posted 1 year ago #

    I cannot even log into my admin panel.

    This issue just started the last few days. First it was kinda slow but still worked. It progressively got slower until the point where I cannot even log in.

    I have not downloaded any new themes or plugins in weeks.

  23. WPProHelp
    Member
    Posted 1 year ago #

    It is not necessarily new plugins and themes. If you cannot login you can disable the plugins and switch to the default theme by:

    1. Logging to your WordPRess via FTP
    2. Make a backup copy of all the directories and files in /wp-content/plugins and wp-content/themes
    3. Delete all those files and directories except from the directory twentyeleven.

    Now you should be able to login. Once you logged in, start adding the plugins one by one and the new theme. Once you reproduce the problem, then you found out which is the plugin which is causing the issue.

  24. franzbel
    Member
    Posted 1 year ago #

    @WPProHelp

    Yes it's on all the pages :
    - mysite.com/wp-admin
    - mysite.com/wp-admin/edit.php (to edit page or article)
    - mysite.com/wp-admin/themes.php (theme)
    - etc...

    The strange thing is that I've only worked on some templates for the frontoffice (page or post and custom posts), I didn't change anything in the backoffice...

    What do you mean with "strip all of your theme and start building it slowly and test the admin panel each time." ? What should I do exactly ?

    Thank you for your help ! :-)

  25. TCR
    Member
    Posted 1 year ago #

    What do you mean with "strip all of your theme and start building it slowly and test the admin panel each time." ? What should I do exactly ?

    this would be in order to try and determine where the problem with your site is, once the problem has been identified we can help you fix it.

  26. franzbel
    Member
    Posted 1 year ago #

    @TCR

    Yes that's it but I wonder how to strip the pages. With which one should I start and what should I remove ?

    Last night, I've removed all the new templates that I had created but it didn't go faster. I can do it again but I really don't know what to start with (anymore) ;-)

  27. franzbel
    Member
    Posted 1 year ago #

    @TCR and @WPProHelp

    Thank you for your help. I've stripped my theme files again and I've finally found the origin of the problem.

    I've developed my theme from an existing theme and a new version of this original theme has come out. The admin was always calling a file which notificates that there was a new version of this theme. The call of this file was really really slow. Now it's better : from 20-25 sec to 3.9 sec !
    That's much better, thank you !! :-)

  28. Andrew
    Forum Moderator
    Posted 1 year ago #

    I'm closing this thread as it seems like Franzbel's issue is resolved.

    Remember to create your own thread if you need support.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.