WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Admin and Cloudflare (14 posts)

  1. tbaker2500
    Member
    Posted 2 years ago #

    I host a wordpress site, http://www.drabblecast.org, at Dreamhost. They recently started offering Cloudflare, and I've been trying it out. (For those who do not know, Cloudflare is a kinda-CDN which caches images and helps speed up the site. It acts as a reverse proxy server.)
    Since enabling that service, I've been unable to upload any media file to drabblecast.org larger than 50megs. (Yes, my PHP settings allow for 500meg, works fine without Cloudflare.) After talking with Cloudflare, they confirm that they limit any file through their servers to 50 megs. The recommended that I create a subdomain which is not served by them to handle these admin tasks. Great idea, let's do it.

    I did that (uploads.drabblecast.org), and every time I try to log into uploads.drabblecast.org/wp-admin and log in, it immediately redirects me to http://www.drabblecast.org/wp-admin, since that is the URL set in "Settings" in wordpress. Because it sends the browser there, the connection is now through Cloudflare, and I'm limited again.

    Does anybody know a way around this? I'm starting to bang my head on the desk. :-(

    Thanks for any help,
    Tom

  2. Carol_Ann
    Member
    Posted 2 years ago #

    I just tried cloudflare myself, but had to drop them because I couldn't log into my c-panel. Something on there end prevented any CSS from loading and anything I clicked took me back to the login page. Weird thing is I actually noticed in increase in my page load times.

  3. tbaker2500
    Member
    Posted 2 years ago #

    I turned off auto minify and rocket loader. Seems to work except for upload sizes.

  4. damoncloudflare
    Member
    Posted 2 years ago #

    "I turned off auto minify and rocket loader. Seems to work except for upload sizes. "

    Doesn't sound like a Rocket Loader or Auto Minify issue. Are you still having issues with this?

    "Seems to work except for upload sizes."
    Uploads are limited, unfortunately, if it is being proxied by us. It doesn't look like we're touching uploads.drabblecast.org?

  5. damoncloudflare
    Member
    Posted 2 years ago #

    "I just tried cloudflare myself, but had to drop them because I couldn't log into my c-panel. "

    Any of these should work for getting to cPanel (we wouldn't impact the user name and password for your cPanel login, however).

    Please try any of the following:

    cpanel.yourdomain.com

    direct.yourdomain.com/cpanel

    direct.yourdomain.com:2082

    "Something on there end prevented any CSS from loading and anything I clicked took me back to the login page. "
    This actually sounds like one one of two things:
    1. Auto Minify was causing an issue.
    2. You had multiple minify options turned on (such as a caching plugin and CloudFlare's Auto Minify option).

    "Weird thing is I actually noticed in increase in my page load times."
    Definitely unusual. What were you using to test?

  6. tbaker2500
    Member
    Posted 2 years ago #

    I set up uploads.drabblecast.org (not cloudflared) to mirror drabblecast.org(cloudflared). It all works fine, until I try to log into the admin panel (/wp-admin/). At which point, WordPress seems to purposely redirect me upon logging in to http://www.drabblecast.org/wp-admin/.

    Is there ANY way to allow me a non-cloudflared login to the admin panel? Otherwise, cloudlfare seems useless to me since I can't upload the needed files.

    Any help is greatly appreciated!

    Tom

  7. Carol_Ann
    Member
    Posted 2 years ago #

    @damoncloudflare - Yes, I think you were correct. I was using W3T Cache and Cloudflare. Problem was W3T was causing my "Edit Post" page to go blank and I had to drop that plugin too. I'll give cloudflare a try again without W3T.

  8. damoncloudflare
    Member
    Posted 2 years ago #

    Ok, great. Definitely let us know what happens.

  9. tbaker2500
    Member
    Posted 2 years ago #

    No ideas on my problem, Damon? I really want cloudflare to work, but I can't use it unless I can log wordpress admin with a subdomain.

  10. damoncloudflare
    Member
    Posted 2 years ago #

    Hi,

    I just took a look at your Page Rules and don't see anything that should be impacting the wp-admin section. I made a slight change to your wp-admin rule to see if it helps. Can you let me know if that helps with the login now?

  11. tbaker2500
    Member
    Posted 2 years ago #

    Hm, we're getting two things confused.

    The login issue is with me trying a non-cloudflare server subdomain, uploads.drabblecast.org. WordPress redirects uploads.drabblecast.org/wp-admin to http://www.drabblecast.org/wpadmin.

    With Page Rules, I just tried uploading a 60meg file and it still failed. Does Page Rules remove cloudflare services? Or will it still suffer the same 50meg limit?

    Thanks,
    Tom

  12. Hax
    Member
    Posted 2 years ago #

    to login to wordpress using your subdomain use

    uploads.drabblecast.org/wp-login.php not uploads.drabblecast.org/wp-admin

    At first it will redirect you to drabblecast.org/wp-admin, but once you are logged in to the subdomain you can change the url to uploads.drabblecast.org/wp-admin with no problem.

    I am using cloudflare too it's awesome http://xparkmedia.com/

  13. tbaker2500
    Member
    Posted 2 years ago #

    Thanks for the help, Hax.
    I must be dense, or something is configured differently.
    I do exactly as you say. It does, in fact, redirect me to http://www.drabblecast.org at that point. However, when I go directly to uploads.drabblecast.org/wp-admin, it directs me again to a login page with this URL:
    http://www.drabblecast.org/wp-login.php?redirect_to=http%3A%2F%2Fwww.uploads.drabblecast.org%2Fwp-admin%2F&reauth=1

    So I'm thinking that part of the problem here, is since I'm using Dreamhost's DNS, and with Cloudflare enabled it appends www to everything, that's mixing things up?

    Also, in WordPress's setup, I have both the URL's set as http://www.drabblecast.org, rather than drabblecast.org. Would that make a difference?

  14. tbaker2500
    Member
    Posted 2 years ago #

    No, I just fixed the DNS to not append www, and when I follow your instructions, after logging in, then going back to uploads.drabblecast.org/wp-admin, it going back to the login screen with the URL of:
    http://www.drabblecast.org/wp-login.php?redirect_to=http%3A%2F%2Fuploads.drabblecast.org%2Fwp-admin%2F&reauth=1

    (At least it didn't have www appended anymore to uploads.drabblecast.org)

    Thanks
    Tom

Topic Closed

This topic has been closed to new replies.

About this Topic