WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] "WordPress address must match your Site address" (4 posts)

  1. anthom
    Member
    Posted 4 years ago #

    I'm trying to activate multi-site on a new install of 3.0, modified the config to allow it, and all seems to work well. I have all my wp-files and directories at the root of my domain, and want to use subdomains for the additional blogs I'll be setting up.

    For some reason, my siteurl needs a "www." in it in order for me to log into admin. If I leave it without the "www.", I'm stuck in an infinite login loop. If I change the WordPress address to match my site address by adding the "www.", then the Network config page tells me the www. is going to be part of each subdomain (ie. blog123.www.astreetproductions.com), which is a little counter-productive. Am I doing something wrong?

  2. Douglas Bell
    Member
    Posted 4 years ago #

    Yes, if you are going to set up a multi-site install of 3.0 using subdomains, you're going to have to make sure that your Site Address and WordPress Address in Settings do not have a "www." in them BEFORE you start the conversion to multi-site. Yes, it's inconvenient, but I think it's done intentionally, and yes the documentation really needs to be updated to reflect this.

    You might have to reset your database and reinstall WordPress so you can ensure that Multi-Site gets set up properly.

  3. you're going to have to make sure that your Site Address and WordPress Address in Settings do not have a "www." in them BEFORE you start the conversion to multi-site. Yes, it's inconvenient, but I think it's done intentionally, and yes the documentation really needs to be updated to reflect this.

    Um, 3.0 with multisite now supports the www. You don't have to strip it out.

  4. anthom
    Member
    Posted 4 years ago #

    It looks like it's working now. I had cleared my cache and everything, but perhaps I wasn't patient enough.

    I set my install to use the "www"-free siteurl and WP address, and once I checked the site on another browser, was able to log in to wp-admin without a problem. Now it looks like it's working regardless of browser.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags