WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WordPress address changed now site is down (21 posts)

  1. shawngoesgreen
    Member
    Posted 1 year ago #

    I had a senior moment and inside of settings>general settings I changed the wordpress address(url) and site address(url) to what the url I want to use full time. I started with another address and both urls point to the site.

    When I change it I now get this error in the browser:
    Parse error: syntax error, unexpected T_VARIABLE in /homepages/39/d260099872/htdocs/shawngoesgreen/wp-includes/option.php on line 225Parse error: syntax error, unexpected T_VARIABLE in /homepages/39/d260099872/htdocs/shawngoesgreen/wp-includes/option.php on line 225

    I have done some of the things suggested on this site. I updated my database in phpMyAdmin with no luck. I tried editing my wp-config.php file with no luck.

    Any other ideas? The website is http://www.shawngoesgreen.com

  2. Gaurav Raghav
    Member
    Posted 1 year ago #

    login to your ftp and eplace the option.php file by downloading it for the wordpress version you are using .

  3. shawngoesgreen
    Member
    Posted 1 year ago #

    Didn't do anything unfortunately.

  4. esmi
    Forum Moderator
    Posted 1 year ago #

  5. shawngoesgreen
    Member
    Posted 1 year ago #

    Nothing. I even tried changing the functions.php and that didn't do anything. I did notice that none of the secret keys where filled in, like it changed somewhere along the way. I added those back and checked the database info above that. Still nothing.

  6. esmi
    Forum Moderator
    Posted 1 year ago #

    Try re-uploading all files & folders - except the wp-content folder - from a fresh download of WordPress.

  7. shawngoesgreen
    Member
    Posted 1 year ago #

    Unbelievable. Nothing. I know for sure that all I did was change those two lines and I can't get it back.

    Thanks for working with me esmi and gaurav.

  8. esmi
    Forum Moderator
    Posted 1 year ago #

    I know for sure that all I did was change those two lines

    what two lines where?

  9. shawngoesgreen
    Member
    Posted 1 year ago #

    settings>general settings > I changed the wordpress address (url) and site address (url). It was http://shawngoesgreen.com, I changed them to http://shawnwrightsportfolio.com

  10. esmi
    Forum Moderator
    Posted 1 year ago #

    That change in itself would not cause a problem in wp-includes/option.php. What have you done since then?

  11. shawngoesgreen
    Member
    Posted 1 year ago #

    When I did that and hit save I have been getting the error message you see when you visit the site.

    shawngoesgreen.com is the original site. I also have shawnwrightovernight.com and shawnwrightsportfolio.com pointing to the site.

    I have changed the mysql database wp-options file. Both siteurl and home. Did various version to see if anything would work.

    I edited wp-config.php and functions.php to change the site url manually. Neither worked and I removed the changes.

    I reloaded all the files except wp-content folder with new files.

  12. esmi
    Forum Moderator
    Posted 1 year ago #

    I have changed the mysql database wp-options file.

    Sorry? No one told you to change any files with the possible exception of the wp-config.php file (method 1 in Changing_The_Site_URL). Do you mean that you edited the wp_options table in the database? If so, did you make a database backup first? and what did you change the values in the wp_options table to?

  13. shawngoesgreen
    Member
    Posted 1 year ago #

    I forgot to mention that part. Before i got on here I tried this from the WordPress Codex. http://codex.wordpress.org/Changing_The_Site_URL#Changing_the_URL_directly_in_the_database

    The database is now the was it was originally. Changes where made to:

    Option_id 1
    Option_Name site url
    option_value http://shawngoesgreen.com

    and

    Option_id 39
    Option_Name home
    option_value http://shawngoesgreen.com

    I changed the values to http://shawnwrightsportfolio.com saved and reloaded the page, nothing. I then changed to http://shawnwrightovernight.com saved and reloaded the page, nothing. Then I changed it back the way it was originally.

  14. esmi
    Forum Moderator
    Posted 1 year ago #

    Change them back to http://shawngoesgreen.com

  15. shawngoesgreen
    Member
    Posted 1 year ago #

    They have been back to http://shawngoesgreen.com since I started this post.

  16. esmi
    Forum Moderator
    Posted 1 year ago #

    Do you have a pre-change database backup?

  17. shawngoesgreen
    Member
    Posted 1 year ago #

    I believe I do.

    So if I read you correctly, you believe it is a corrupt database? Would the change I made have corrupted it or is could it be a deeper issue?

  18. esmi
    Forum Moderator
    Posted 1 year ago #

    Right now, some form of database corruption is the only thing I can think of that would create this kind of problem in an unedited version of wp-includes/options.php on a site using Twenty Eleven with no active plugins. So it's an educated guess, at this point. :-)

  19. shawngoesgreen
    Member
    Posted 1 year ago #

    Thanks for the help esmi. I am off to pickup the kids. I'll start knocking away at this. I am not to worried right now since this is strictly a portfolio, i can rebuild if I can't dig up the database backup.

  20. shawngoesgreen
    Member
    Posted 1 year ago #

    Just to finish this story. I was not able to find a backup of my site so I had to rebuild it. For the first time I used MAMP to build offline and it went pretty quick.

    I purchased backup buddy for all my sites and started making full backups. I was able to use backup buddy to transfer my files from local development to the live site very easily. Really impressed with the program. Anyway it helped me develop a better backup routine.

    Thanks for the help esmi.

    Shawn

  21. esmi
    Forum Moderator
    Posted 1 year ago #

    Glad to hear that you're up & running again.

Topic Closed

This topic has been closed to new replies.

About this Topic