WordPress.org

Ready to get started?Download WordPress

Forums

WordPress 403 Forbidden Error (6 posts)

  1. Codemark
    Member
    Posted 2 years ago #

    I am having a CRAZY error with WordPress. When I create a new article or edit an old one, I cannot insert hotfile links that go after the first trailing slash.

    I'm explaining it better. If in a post I do:

    <a href="http://www.hotfile.com">TEST</a>
    I can correctly create the article. If I do:

    <a href="http://www.hotfile.com/">TEST</a>
    Or longer link, like:

    <a href="http://www.hotfile.com/dl/[...]">TEST</a>
    I get an instant 403 error when updating the post from administration. This is crazy, and happens only with Hotfile links. Everything else works like a charm.

    What could the error be? If it helps, i'm posting my .htaccess, that I never changed from my WP installation:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    Already done repairing and optimization of MySQL DB. Kind thanks in advance to everyone.

  2. MickeyRoush
    Member
    Posted 2 years ago #

    Are you using any security plugins?
    Does your host have mod_security set up?
    Does your link actually have those brackets [...] in it?

  3. Codemark
    Member
    Posted 2 years ago #

    1. I recently enabled Akismet. Could this be the cause?
    2. Yes
    3. No, the brackets [...] were just to make you understand that the link could be longer.

  4. MickeyRoush
    Member
    Posted 2 years ago #

    I'm only guessing that it could be related to a mod_security or Apache config setting. If you can't access either of those, you may have to contact your host.

    What happens when you disable Akismet? What about your other plugins? I'm not sure why Akismet would be causing any problems like that.

    That's very strange because your .htaccess has nothing relating to a 403, that's why I'm guessing it's a mod_security or config issue. But you never know.

  5. Codemark
    Member
    Posted 2 years ago #

    Tried disabling Akismet, nothing changed. I always used other plugins.. no problems.

    This happens only with hotfile. Really can't understand.

    Where can I access the mod_security option? From the control panel of the hosting?

    Thanks in advance

  6. MickeyRoush
    Member
    Posted 2 years ago #

    You'd have to contact your host. You may not even be able to edit it. They may have to edit it for you.

Topic Closed

This topic has been closed to new replies.

About this Topic