WordPress.org

Ready to get started?Download WordPress

Forums

Statify
[resolved] WordPress 3.5b3 - missing argument 2 for wpdb::prepare() (9 posts)

  1. Thomas
    Member
    Posted 1 year ago #

    Warning: Missing argument 2 for wpdb::prepare(), called in D:\webroot\wordpress\wp-content\plugins\statify\statify.php on line 813 and defined in D:\webroot\wordpress\wp-includes\wp-db.php on line 990
    
    Warning: Missing argument 2 for wpdb::prepare(), called in D:\webroot\wordpress\wp-content\plugins\statify\statify.php on line 823 and defined in D:\webroot\wordpress\wp-includes\wp-db.php on line 990

    Diese Meldung wird beim ersten Aufruf der Dashboard-Seite angezeigt. Nach einem Reload- ist die Meldung verschwunden. Geht man dann wieder auf eine andere Seite und dann wieder zurück, beginnt das Spiel von vorn.

    http://wordpress.org/extend/plugins/statify/

  2. Sergej Müller
    Member
    Plugin Author

    Posted 1 year ago #

    Kann ich nicht reproduzieren, habe hier 3.5 rc1. Aber ich habe eh schon eine neuere Version am Testen, kommt die Tage raus.

  3. Sergej Müller
    Member
    Plugin Author

    Posted 1 year ago #

    Ich habe vor wenigen Minuten eine Version aufgespielt, da habe ich den Aufruf angepasst.

    Schönes WE,
    Sergej

  4. Thomas
    Member
    Posted 1 year ago #

    ##### EDIT: #####
    Sorry, hab grad den RC2 aufgespielt, jetzt gehts ohne Probleme!
    #################

    Habe jetzt die neueste Version installiert.

    Bis auf die Zeile und die Datei hat sich nichts geändert?

    Warning: Missing argument 2 for wpdb::prepare(), called in D:\webroot\wordpress\wp-content\plugins\statify\inc\statify_dashboard.class.php on line 381 and defined in D:\webroot\wordpress\wp-includes\wp-db.php on line 990
    
    Warning: Missing argument 2 for wpdb::prepare(), called in D:\webroot\wordpress\wp-content\plugins\statify\inc\statify_dashboard.class.php on line 391 and defined in D:\webroot\wordpress\wp-includes\wp-db.php on line 990

    Naja, weiß auch nicht. Vielleicht hab auch auch nur mal wieder meinen Opfer-Server verkonfiguriert ;)

    Danke für deine Mühe :)
    Gruß
    Thomas

  5. Kevin Kyburz (@swissky)
    Member
    Posted 1 year ago #

    Hi

    Hab gerade die fertige Version installiert und bekomme den Fehler nun wieder:(

    Hattest ihr einen Lösungsweg?

    Gruss Kevin

  6. Sergej Müller
    Member
    Plugin Author

    Posted 1 year ago #

    Habe eben probiert. Kein Fehler. Schreib mir sonst ne Mail.

  7. Kevin Kyburz (@swissky)
    Member
    Posted 1 year ago #

    Ok hab gerade das Update nochmal raufgespielt und der Fehler ist nun weg.

    Danke

    Gruss Kevin

  8. Julian
    Member
    Posted 1 year ago #

    Wie hast du das gemacht, Kevin?

  9. Sergej Müller
    Member
    Plugin Author

    Posted 1 year ago #

    Genau, ich hatte ja vor 2 Wochen einen Fix zur Verfügung gestellt, siehe meinen Kommentar oben. Dafür sind RC von WordPress auch da, um die Umstellungen am WP-Core rechtzeitig zu bemerken und zu beseitigen.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic