WordPress.org

Ready to get started?Download WordPress

Forums

Path
[resolved] WordPress 3.5 And WPDB Prepare And Sharebar Plugin (4 posts)

  1. Kami2
    Member
    Posted 1 year ago #

    Hello,

    The theme works perfectly on wordpress 3.5. However, when i installed the Sharebar plugin it showed the following warning :

    Warning: Missing argument 2 for wpdb::prepare(), called in /home/pg23546/public_html/wp-content/plugins/sharebar/sharebar-admin.php on line 321 and defined in /home/pg23546/public_html/wp-includes/wp-db.php on line 990 -

    Looking on web i found that this error happens with wordpress 3.5. On some sites from theme developers i suppose(here and here) they found the solution for errors related. Some say that theme should be updated no? It is a good idea updating wordpress to 3.5.1 version? Still not updated my theme to 0.2 version.

    thank you,

    Kami

  2. Sami Keijonen
    WordPress-asiantuntija
    Theme Author

    Posted 1 year ago #

    Yes you should always use latest versions for WP, Themes and Plugins. That's pretty much the only way we can provide support.

    But I'm not familiar with that Plugin. Is there the same notice if you use default theme?

  3. Kami2
    Member
    Posted 1 year ago #

    The error is cause some update introduced by wordpress 3.5, some security issue. Other hand, as far as i can see, the plugin developer need to update to fix this problem. I'm looking for a solution.

    Thank you for your support,

    Kami

  4. Kami2
    Member
    Posted 1 year ago #

    Resolved
    I found the solution.
    If someone have this problem on wordpress 3.5 or above may take a look here and here (Important: for sharebar-admin.php if on back-end shows warning message).

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic