WordPress.org

Ready to get started?Download WordPress

Forums

WordPress 3.4.2 editor toolbar disappeared (20 posts)

  1. morex
    Member
    Posted 1 year ago #

    Hi, everyone!

    I need some help with my blog. Editor toolbar disappeared. I'm using 3.4.2 and I am very happy with it on my other projects, but on http://laenciclopediagalactica.info the editor just dissolved and I have no idea how to fix it.

    I have tried the following, to no effect:

    -Reset the plugin folder
    -Replaced the includes and admin folders
    -Deactivated every single plugin
    -Reinstalled WordPress from the update option

    And nothing.

    Please help! Any pointers will be appreciated.

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    Have you tried:

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by PhpMyAdmin.

  3. morex
    Member
    Posted 1 year ago #

    Thank you, esmi.

    I tried both sugestions, to no avail.

    Any help will be appreciated :)

  4. Rogier Noort
    Member
    Posted 1 year ago #

    Sorry Morex.., no solution from me. Sort off the same boat though.

    Did you try it in a different browser?
    For me only IE works, the rest doesn't.

    Also, 'they' implemented HTTPS, that's wen the trouble started.

  5. morex
    Member
    Posted 1 year ago #

    Hey Rogier

    Yes, I've tried all possible browsers, still nothing. I am tempted to re install WP from zero. Do you think that could work?

  6. esmi
    Forum Moderator
    Posted 1 year ago #

    Have you tried another machine? Preferably on a completely different network and using a different ISP.

  7. Rogier Noort
    Member
    Posted 1 year ago #

    OK, still working on it, came across this:

    1) Download (or just use) Google Chrome.
    2) Open the page you're having trouble with in Google Chrome.
    3) Open the Developer Tools.
    4) Click on the Console tab.

    At least, now I now what is wrong, for me:
    Failed to load: https://blogacibg.irisnet.be/wp-includes/js/tinymce/langs/en.js

    Now for the 'Why' and the 'How To'...

    Oh, I tried on a different machine, that's why I figured out IE worked. On my iPhone (I know!) it didn't work either.

  8. Rogier Noort
    Member
    Posted 1 year ago #

    Unbelievable.., I do not understand this.., at all... But:

    ../en.js doesn't exist.., ../wp-langs-en.js does.

    I changed the name and presto, editor is working again.
    In all browsers...

    Don't get it.., don't care.., it works.
    Good luck Morex!

  9. morex
    Member
    Posted 1 year ago #

    I used Chrome's Dev Tools and I get this errors:

    GET http://laenciclopediagalactica.info/wp-includes/js/tinymce/wp-tinymce.php?c=1&ver=349-21274 404 (Not Found) post-new.php:1127

    Uncaught ReferenceError: tinyMCE is not defined post-new.php:1129
    (anonymous function) post-new.php:1129

    Uncaught ReferenceError: tinyMCE is not defined post-new.php:1171
    (anonymous function) post-new.php:1171

    I downloaded a fresh WP and uploaded tinyMCE, but I got the same error.

    Also, I tried the en.js trick and still no joy.

  10. morex
    Member
    Posted 1 year ago #

    I used Chrome's Dev Tools and I get this errors:

    GET http://laenciclopediagalactica.info/wp-includes/js/tinymce/wp-tinymce.php?c=1&ver=349-21274 404 (Not Found) post-new.php:1127

    Uncaught ReferenceError: tinyMCE is not defined post-new.php:1129
    (anonymous function) post-new.php:1129

    Uncaught ReferenceError: tinyMCE is not defined post-new.php:1171
    (anonymous function) post-new.php:1171

    I downloaded a fresh WP and uploaded tinyMCE, but I got the same error.

    Also, I tried the en.js trick and still no joy.

  11. Rogier Noort
    Member
    Posted 1 year ago #

    Such very specific errors...

    I can only suggest.., oh wait, you already did that...

    Sorry man, that's all java.., it's beyond me...

  12. shadow315
    Member
    Posted 1 year ago #

    I too have the same errors: tinyMCE is not defined post-new.php.

    I've tried almost everything. It is affecting about 12 of my sites. I've been working on this for 3 days now. I have no idea what to try next.. :(

  13. esmi
    Forum Moderator
    Posted 1 year ago #

    As per the Forum Welcome, please post your own topic. Your problem - despite any similarity in symptoms - is likely to be completely different.

  14. jehovejr
    Member
    Posted 1 year ago #

    WE have also experienced after upgrade to 3.4.2 that the our custom users page that uses tinymce editor from wordpress does not display it's toolbars.

    After some review with our website I found out that the error causing this was the import url at wp-includes\js\tinymce\themes\advanced\skins\wp_theme\ui.css

    which is @import url("../../../../../../css/editor-buttons.css?ver=20111114");

    it lacks 1 "../" and the also you need to use editor.css instead of editor-buttons.css

    the import line should now look like this
    @import url("../../../../../../../css/editor.css?ver=20111114");

    after updating the file the editor's toolbar was fix.

    HTH

    Regards,
    Joeven

  15. shadow315
    Member
    Posted 1 year ago #

    @Joeven Thanks, I apparently have a different issue as mine is still broken..

    The " tinyMCE is not defined post-new.php " errors have to mean something...

  16. vinaysagar4u
    Member
    Posted 1 year ago #

    I have this issue with a plugin(WIKIPOP).
    It works fine when the plugin is disabled but toolbar is stripped off except toggle screen tool when WIKIPOP is enabled.

  17. esmi
    Forum Moderator
    Posted 1 year ago #

    As per the Forum Welcome, please post your own topic - preferably in the plugin's dedicated forum. Your problem is completely different.

  18. vinaysagar4u
    Member
    Posted 1 year ago #

    Add the following line of code at the bottom of the file, right before the require_once line.
    define('CONCATENATE_SCRIPTS', false );

    Have you people tried this? Does,'t work in my case as mine is plugin issue but may work for you.

  19. simydan
    Member
    Posted 1 year ago #

    I am new to wordpress and ever since I installed wordpress 3.4.2 I have been having this visual formatting problem.
    I have tried all suggestions on this page and to no avail.
    I am really confuse. please, I need help.

  20. Sony Boy
    Member
    Posted 1 year ago #

    Hi All,
    I'm facing the same problem, 'vanishing editor tool bar in - 2011 Theme', what a pain.
    Sorry I can't help, just wanted to say I also tried deactivating plugins in Word Press and resetting the plugins folder by PhpMyAdmin to no avail.
    I would like to fix this problem so future volunteer administrators for the site I'm working on (spanishcare.net) can manage it independently. A solution would be much appreciated.

Topic Closed

This topic has been closed to new replies.

About this Topic