WordPress.org

Ready to get started?Download WordPress

Forums

WordPress 3.4.2 broken in IE9 (9 posts)

  1. regisit
    Member
    Posted 1 year ago #

    Admin for sites upgraded to WordPress v3.4.2 no longer works properly in IE9. On accessing the dashboard there is a warning that the browser is out of date (what!?!) and dragging widgets intermittently fails to work.

    What gives? IE9 is the latest version for W7. Ok, so W8 with IE10 has *just* come out, but surely a browser released barely a few weeks ago on a tiny proportion of active machines cannot suddenly make IE9 unsupported!?

    Anyone for WordPress care to comment? Amazingly the web seems very quiet on this.

    P.S. No "IE is rubbish, use another" replies please!

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    In what way does the admin area no longer work in IE9? Browser message aside?

  3. regisit
    Member
    Posted 1 year ago #

    ...and dragging widgets intermittently fails to work.

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading all files & folders - except the wp-content folder - from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.

  5. regisit
    Member
    Posted 1 year ago #

    The same sites work fine in other browsers, e.g. Chrome, so it's not an issue with the sites. I can visit the widget area on one occasion and attempts to drag a widget fail, with it instead selecting the text, on another occasion it works fine. On one site I can drag the first few widgets, but not the rest.

    I haven't seen this happen before and it only *appears* to be happening on sites upgraded to 3.4.2, which is when WP seem to have decided IE9 is no longer current.

  6. Andrew
    Forum Moderator
    Posted 1 year ago #

    Does the problem persist when you switch to a default theme, like Twenty Ten?

  7. esmi
    Forum Moderator
    Posted 1 year ago #

    Did you try ANY of the suggestions I posted above?

  8. Billox
    Member
    Posted 1 year ago #

    I have the same problem and got the same warning that explorer was out of date. I still can't move any widgets and the right hand column is blank. The actual website view seems ok. I have disabled and enabled all widgets and changed a few themes with no avail. I have a few wordpress sites and this only happened to one "with the ie error on login. The same site does the same thing in all browsers. It is a WP error. Would the upcomming update fix this. I don't want to re install everything.Here is the site in question http://www.roofshingles.com.au
    Kind regards,

    Richard.

  9. Andrew
    Forum Moderator
    Posted 1 year ago #

    Did you try all suggested solutions in this thread?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags