WordPress.org

Ready to get started?Download WordPress

Forums

wordpress 3.1.3 Insert Image/media popup window not working (3 posts)

  1. nix255
    Member
    Posted 3 years ago #

    I have a problem with a wordpress install. I'm running wordpress 3.1.3 and when I try to add an image to a page or post, the pop up window appears and I can choose a file to upload but then nothing happens. The slug doesn't move along the screen to show the file is uploading, and you cannot click on the show button. However, the image does show up in the media library, and in the folder with thumbnails when looking via ftp. If I try to add an image the same way that is already in the media library, I can see a list of filenames with no thumbnails and the 'show' link does not work.

    The server has php 5.2.14 installed. I have deleted all plugins which hasn't helped. I have reinstalled the wp-admin and wp-includes folders which hasn't helped. I have done a complete fresh reinstall of wordpress version 3.1 and have tried to insert an image to a page before updating to 3.1.3 and even that doesn't work. I have installed the hotfix plugin to the clean install and that hasn't helped either. I have tried using other browsers to no avail. I am out of ideas now so if anyone can offer any other advice for me to try that would be great.

    Do you think it could be a hosting problem as the same wordpress installs on another server are working fine.

    Thanks for your help.

  2. Tim Moore
    Moderator
    Posted 3 years ago #

    It may be that some PHP extensions are missing. I believe the PHP GD library is needed to properly use the Media Library. If that isn't installed, it may cause issues, though I'm not sure if it would cause this specific issue or not.

    Have you also removed all of your plugins, from both wp-content/plugins and wp-content/mu-plugins (if it exists)?

  3. nix255
    Member
    Posted 3 years ago #

    Hi Tim, thanks for your quick response.

    I've checked the phpinfo and GD is enabled version 2.0.34.

    I had removed all plugins from wp-content/plugins and there was no mu-plugins folder. This didn't solve the problem.

Topic Closed

This topic has been closed to new replies.

About this Topic