WordPress.org

Ready to get started?Download WordPress

Forums

WordPress 3.1.1. but still HTTP error with flash-upload (37 posts)

  1. rangitoto
    Member
    Posted 3 years ago #

    Hi all!

    I just updated to 3.1.1 and I know there are already some posts but there is also no real solution (I think).

    When trying to use the Flash-uploader I still get the HTTP error.

    How can I fix this problem. I already tried a lot "fixes"...

    Thanks for ideas! :-)

    rangitoto

  2. esmi
    Forum Moderator
    Posted 3 years ago #

  3. rangitoto
    Member
    Posted 3 years ago #

    Hi esmi

    Thanks for trying to help but maybe I expressed wrong.

    I can upload with the normal Browser-uploader - this works perfect!

    But when I try to switch to the Flash-Uploader I get the HTTP error in red!

    The "solution-link" you provided is only fixing the issue "no upload at all".

    Many posts in the internet have the same problem but it seems that this is a serious wordpress problem.

    Does somebody knows a working flash-fix? (In my opinion i has nothing to do with Mac or PC)

    regards
    rangitoto

  4. mattysheff
    Member
    Posted 3 years ago #

    I have the same problem as this and been looking for a answer but no luck so far.

  5. rangitoto
    Member
    Posted 3 years ago #

    Now the 3.2 update is nearly waiting and I hope for a solution! :-)

  6. Puristaako
    Member
    Posted 3 years ago #

    Hi, I have the same problem and I solved it temporary via Flexupload multithread uploader plugin.
    But still waiting a real solution.

  7. rangitoto
    Member
    Posted 3 years ago #

    Thanks, but Flexupload wasn't able to solve that problem.....

  8. rangitoto
    Member
    Posted 3 years ago #

    Update: Installed WP 3.2 but sill http error...

  9. mccay_a
    Member
    Posted 3 years ago #

    I have the same problem, but it is with all files. It worked then i did something and it stopped working

    I am working on it and will psot with my fix when i find it, but heres a few brain dumps so that others may have ideas

    1) It could be a plugin ( there was a post online stating that a plugin applied a security mod to .htaccess that screwed flash player security rights)
    2) .htacces file that works on my old site have module loads for the upload.php file, but this doesnat appear to work on my latest wordpress

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

    Regards mccay_A

  10. safi2266
    Member
    Posted 3 years ago #

    Dear All
    Now I use WordPress 3.2.1 with flash player 10.3.181.35 for chrome and 10.3.181.34 for other browsers and I try all suggested fixes here but with no luck, I am still have the issue mentioned by rangitoto.

    moreover when I add AddType x-mapp-php5 .php to my .htaccess file and try to upload image via flash uploader I got this

    post_type ) wp_die( __( 'Unknown post type.' ) ); $post_type_object = get_post_type_object( 'attachment' ); if ( ! current_user_can( $post_type_object->cap->edit_post, $id ) ) wp_die( __( 'You are not allowed to edit this item.' ) ); if ( 2 == $_REQUEST['fetch'] ) { add_filter('attachment_fields_to_edit', 'media_single_attachment_fields_to_edit', 10, 2); echo get_media_item($id, array( 'send' => false, 'delete' => true )); } else { add_filter('attachment_fields_to_edit', 'media_post_single_attachment_fields_to_edit', 10, 2); echo get_media_item($id); } exit; } check_admin_referer('media-form'); $id = media_handle_upload('async-upload', $_REQUEST['post_id']); if ( is_wp_error($id) ) { echo '
    ' . __('Dismiss') . '' . sprintf(__('ā€œ%sā€ has failed to upload due to an error'), esc_html($_FILES['async-upload']['name']) ) . '
    ' . esc_html($id->get_error_message()) . '
    '; exit; } if ( $_REQUEST['short'] ) { // short form response - attachment ID only echo $id; } else { // long form response - big chunk o html $type = $_REQUEST['type']; echo apply_filters("async_upload_{$type}", $id); } ?>

    in textarea instead of image

    I still waiting true solution for this issue

    God bless you and Best regards

  11. safi2266
    Member
    Posted 3 years ago #

    Hi Again
    After I posted the issue that I faced above, I've continue digging out for a solution, I am trying using three different OS's : winXP, win7 and ubuntu with google chrome the browser that I love, On the ubuntu the flash uploader works fine without any error, but on winXP and win7 it's encountered an error HTTP Error after uploading one image, moreover when I used IE on both OS's the uploader works as charm
    Finally I realized that the above issue causes by the fash plugins not in flash activeX, I am not sure if this is a bug in flash plugins and should be reported in adobe.com site because that I was used the uploader in the past with chrome without any error
    I hope this post help someone in somehow

    BR,
    SaFi2266

  12. ceotron
    Member
    Posted 3 years ago #

    Hi,

    nice Job - thanks for testing!
    have you reported it to adobe?

    Greetings,

  13. safi2266
    Member
    Posted 3 years ago #

    Hi,

    nice Job - thanks for testing!
    have you reported it to adobe?

    Greetings,

    Hi,
    No, not yet

    BR,

  14. mihaiteo
    Member
    Posted 2 years ago #

    Hello there

    I am using WP 3.2.1, fresh copy without any plugins or themes installed and i still get the same error. It seems that is a server configuration problem because when i try to upload an image to website that is hosted to another provider it works. One provider is using CentOS with Cpanel another is using Plesk (works on plesk).

    I hope someone from WP could resolve this bug. I want to mention that this error is only appearing to certain images, but i wasn't able to determine an pattern.

    I tried all (and belive me i spent 3 days on this one) solution provided here and on other blogs, but still no success. Can anyone tell me a fix?

    Regards gents.

  15. safi2266
    Member
    Posted 2 years ago #

    Hello

    I am using WP 3.2.1, fresh copy without any plugins or themes installed and i still get the same error

    What's your browser ?? your OS ?? you don't mentioned any info about that

    BR,
    SaFi

  16. esmi
    Forum Moderator
    Posted 2 years ago #

  17. rangitoto
    Member
    Posted 2 years ago #

    Hi esmi

    Thanks again but this solution doesn't work for me at all (as mentioned above).

    I tried different OS and Browser. I deinstalled and reinstalled plugins (adobe).

    I checked the htacess...

    But still no flash upload....

    Regards
    Rangi

  18. mihaiteo
    Member
    Posted 2 years ago #

    @safi2266 My bad. I'm sorry :)

    I'm ussing win 7 Ultimate SP1 the latest flash player (this morning i got it from adobe.com) and the problem appears on all the browsers(FF, chrome, IE8 and 9, Safari) with both upload solution (flash and html).

    The solution @esmi mentioned didn't work in my case, the problem still persists.

    Any ideas?
    thx

  19. squishy79
    Member
    Posted 2 years ago #

    Same issue here... I am running WP 3.2.1 on a VPS [Virtual Private Server] from AlienVPS. In this case I cannot blame my host as I setup the server myself (doh!). I have tried seemingly every "fix" out there and so far none have worked. Posting to let everyone know that I have had great luck on this site and will be posting any findings.

  20. mccay_a
    Member
    Posted 2 years ago #

    I had solved thsi issue, let me remember and see if i can help

    MICK

  21. mccay_a
    Member
    Posted 2 years ago #

    Squishy, you look like you are trying to advertise a site rather than get help for an issue.

    Do you actually need help

  22. squishy79
    Member
    Posted 2 years ago #

    Why do people get so pissy when it comes to forum posts? Yes, I need help...wouldn't be here otherwise.

  23. mccay_a
    Member
    Posted 2 years ago #

    Sorry Squishy. I am a tech guy and a visitor to many forums, and my job role requires me to pick up on sneaky posts that advertise when others dont even realise that they are being led.

    In that case, I will actually look through my config and try to find out what I changed to get this working ( I keep record in most part for all fixes I apply to my site )

    Regards, MICK

  24. mccay_a
    Member
    Posted 2 years ago #

    As a test do the following. It may not solve the issue but the result will help me diagnose more

    Access your website through what ever mechanism you can. find teh .htaccess file and take a backup of it ( This is critical )

    then edit your file and replace everything with the solution 1 lines. if that dont work, try replacing all with solution 2 lines

    Regards, MICK

    Solution 1

    RewriteEngine On
    RewriteBase /

    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    RewriteRule ^(.+)$ $1/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*.php)$ $2 [L]
    RewriteRule . index.php [L]

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

    AddHandler phpini-cgi .php .htm
    Action phpini-cgi /cgi-bin/php5-custom-ini.cgi

    Solution 2

    AddHandler phpini-cgi .php .htm
    Action phpini-cgi /cgi-bin/php5-custom-ini.cgi

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]

  25. squishy79
    Member
    Posted 2 years ago #

    Both solutions made my site inaccessible. Below is my .htaccess file.
    ========================================
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # Exclude the file upload and WP CRON scripts from authentication
    <FilesMatch "(async-upload\.php|wp-cron\.php|xmlrpc\.php)$">
    Satisfy Any
    Order allow,deny
    Allow from all
    Deny from none
    </FilesMatch>

    # END WordPress
    ========================================

  26. germars
    Member
    Posted 2 years ago #

    Anyone found a solution for this? I read in one of the messages above that someone using a Plesk server had no issues, but using Centos is getting the error messages.

    I've only just started hosting sites on a Linux server, so have had to learn the hard way about uploading a htaccess file, and changing the permissions. Could there be another step I'm missing to do with Centos or a Linux server? And that is why I'm getting the
    ERROR HTTP ERROR : IMG_0248.jpg : 500
    message?

    Thanks!

  27. lappyhappy
    Member
    Posted 2 years ago #

    I'm on a fresh install of 3.2.1 on a fresh hosting account and am having the same problem. I was supposed to be spending this holiday weekend editing and adding content to my site, but instead I've been working on this image upload issue for 3 days now. I have tried everything online in dozens of "solutions" and none of them has worked. The last thing I tried was to go into SETTINGS -> MEDIA -> Maximum embed size

    Set the "maximum embed size" to "0"

    This has allowed me to actually post some photos for the first time. The image uploads are still not fully functioning, but it has allowed me to post 2 out of the 3 photos I selected for upload (the last one didn't seem to crunch.)

    My htaccess is currently set to:

    <IfModule*mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>
    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

    If anyone can help, please chime in.

  28. lappyhappy
    Member
    Posted 2 years ago #

    OK I just got this working. I called my host and he stayed on the phone with me while I tried uploading some photos. He said this produced some issues w/ mod-security which he addressed as they occurred and just to call him back if I get the same error.

  29. squishy79
    Member
    Posted 2 years ago #

    lappyhappy, any idea what they did to modify the mod-security?

  30. lappyhappy
    Member
    Posted 2 years ago #

    I think he said he increased the upload size but I didn't understand if that was what fixed it. He just said he looked for errors as I was trying the upload and then fixed them as they popped up.

Topic Closed

This topic has been closed to new replies.

About this Topic