WordPress.org

Ready to get started?Download WordPress

Forums

WordPress 3.0 Plugin Activation Error (5 posts)

  1. iamkickstart
    Member
    Posted 4 years ago #

    Hi,

    I have problem with activating my own written plugin. My plugin have code like this:

    plugins/Testing/test.php
    <?php
    /*
    Plugin Name: Testing
    Version: 0.1
    Plugin URI: http://www.testing.com
    Description: Testing
    Author: Testing
    Author URI: http://www.testing.com
    */
    ?>
    halo

    When I try to activate this plugin, wordpress give this error:

    "The plugin generated 4 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin."

    When I try to logout from wordpress, it gives another long list of warning that prevent me from logging out.

    Any idea how to fix this? Not sure is my settings problem or wordpress issue, so far it it working for wordpress 2.9.

    Thanks

  2. Mike Challis
    Member
    Posted 4 years ago #

    Make sure there is no characters or whitespace before the <?php or after the ?>

  3. Robert Chapin
    Member
    Posted 4 years ago #

    "halo" = 4 characters. WordPress considers this to be a corrupt plugin.

  4. mpilon
    Member
    Posted 3 years ago #

    Mike Challis-

    Thanks for posting your comment. It saved me considerable time and trouble, as I definitely would not have come up with that on my own. Just one line of whitespace was destroying my efforts.

    Thanks again,

    matt pilon

  5. deblopper.sumanta
    Member
    Posted 3 years ago #

    User : Mike Challis
    User : miqrogroove
    You both gives exactly correct ans. Mike Challis's ans helps me a lot.
    Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic