WordPress.org

Ready to get started?Download WordPress

Forums

[closed] WordPress 3.0 Multisite using sub-directories not creating (37 posts)

  1. tbe1981
    Member
    Posted 4 years ago #

    Good Evening All,

    I'm using dreamhost and have installed wordpress using their advanced option of the one click installers. It is in sub-directory WP.

    I have setup multisite and have the superadmin menu and the option to create sites using sub-directories.

    However when I create a site i enter:
    'TBLog' into the site address field

    and then an appropriate site title and email address (tried with existing and non-existing user email)

    It then goes through and creates according to the console but it gives the site url as: http://mysite.commysite_com_1tblog

    which is not a valid url.

    I cannot see where it has actually tried to create the site at all and I cannot make the site work.

    I'm not sure what exactly i've missed but am sure it is probably something small.

    Thanks in advance.

  2. "I'm using dreamhost "

    If you are on their bottom-line shared hosting package they may not support it.

    Also, the blogs are virtual, and not created in folders on the server. they work via mod_rewrite and the htaccess file.

    but. Some shared hosts are preventing it from working if they don't want to support it.

  3. tbe1981
    Member
    Posted 4 years ago #

    g'day thanks for your reply.

    what i have found on dreamhost is that their policy does not specifically prevent multisite using sub-directories. they just don't let you have wildcard dns without purchasing a private server.
    http://discussion.dreamhost.com/thread-126948.html?highlight=multisite

    My understanding is that I do not require wildcard dns to use multisite via sub-directories.

    To me everything appears correct except when i actually try to create the site it does not make the path correctly.
    For starters it misses the \ after the mysite.com

    Would this be something to do with the mod_rewrite and htaccess file?

    Could it be permissions related?

    just trying to establish what i should be looking at to find the cause of my problem.

    Thanks.

  4. I've been dealing with the same issue in other threads, and the thing most people have in common is Dreamhost.

    no, you don't need the wildcard subdomains to use subfolders. that doesn't preclude DH doing something to disable even subfolders being run properly. The wildcards is a good technical reason for them to not allow it on the shared level.

    Yes, the blogs are created using mod_rewrite and reading the htaccess file. Everyone I've checked so far has the right settings.

  5. tbe1981
    Member
    Posted 4 years ago #

    I have just decided to install wordpress twice because I only wanted two sites.

    Thanks for your help.

  6. troberts
    Member
    Posted 4 years ago #

    I am unable to create blogs within WordPress 3.0.1. Here's what I've done so far: I did a complete removal of previous installation of WordPressMU (including the database). I did a clean install of WordPress 3.0.1., I "created a network" as instructed via the online documentation. with updating the .htaccess file and the wp-config.php file. When I add a new "site" everything appears normal until I try to go to that site and I get the 404 error page not found. I had no problem with creating new sites with WordPressMU, no changes have been made to the server. Any ideas or suggestions on how to get my new sites to show up online?

    Thanks for the help.

  7. Subfolders or subdirectories?

  8. troberts
    Member
    Posted 4 years ago #

    subdirectories not subdomains

  9. Crap. I'm hoping this is not a bug, but if they worked in wpmu and not now, evidence is starting to pile up. :-/

    Check these things:
    - pretty permalinks work
    - mod_rewrite is enabled
    - AllowOverride FileInfo Options is in the vhost entry for that domain (it forces mod_rewrite to pay attention to the htaccess file)

  10. benek71
    Member
    Posted 4 years ago #

    Hello, I've got exactly the same problem as Troberts. Andrea, I would like to follow your advice, but I don't understand your sugesstions - I am a new user of WP.
    So, how to check if permalinks work and mod_rewrite is enabled?

    Thanks in advance

  11. benek71
    Member
    Posted 4 years ago #

    Probably the problem is in .htaccess file. I didn't update the file as sugessted (because I didn't find it), so I created .htaccess.txt with all the staff sugessted in online documentation and put it into server via my ftp client. Everything seems to be OK, but my sites don't show up online.

    What shall I do?

  12. troberts
    Member
    Posted 4 years ago #

    mod_rewrite is enabled, AllowOverride FileInfo options in vhost is set to ALL. I am not sure about pretty permalinks, as I've not really used them before. However, I went into the Permlinks module and made a change, I received a pop up message that the change was successful.

  13. so I created .htaccess.txt

    It has to be .htaccess with the dot in front, just exactly like you see it. Take the one you created with the .txt at the end and rename it.

  14. benek71
    Member
    Posted 4 years ago #

    I did it, but I have only text on my blog, without theme. I am doing sthg wrong, but I don't know what's that. Any sugesstion?

  15. @benek71 - tell your webhost you made htaccess changes and they are not happening.

  16. troberts
    Member
    Posted 4 years ago #

    Any additional ideas/thoughts on my problem with my sites not showing up online?

  17. @troberts i tried this myself and it works for me on my server. other people are reporting a bug. If you want to go diving, see this post:
    http://wordpress.org/support/topic/image-links-broken-un-wordpress-30-subdomain?replies=12#post-1646429

  18. troberts
    Member
    Posted 4 years ago #

    Thanks. I will check it out.

  19. benek71
    Member
    Posted 4 years ago #

    I asked my webhost to chceck if AllowOverride FileInfo options in vhost is set to ALL, but he answered I can activate this option on my own in .htaccess, and if I don't know how to do that I shall browse Internet !!
    As far as I understand I shall put this code into my .htacces
    <Directory />
    AllowOverride All
    </Directory>

    Am I right? If yes, in which line shall I put this code

    Thanks for your answer

  20. put it at the top.

  21. artur
    Member
    Posted 4 years ago #

    if i order Dreamhost PS, will MultiSite need more manual configurations ( like the samples above ) to work with subdomains?
    or are these hacks for installs not hosted using PS hosting?

    and will this plugin :
    http://wordpress.org/extend/plugins/wordpress-mu-domain-mapping/
    allow me to manage the subdomains in a more user friendly way?

    also can u recommend a BETTER host? that can handle 1000 WP MulitSite re-mapped subdomains?

    thanks!
    artur

  22. You'll have to talk to the reps at Dreamhost.

    Tho honestly,. with a site the size you're planning, you should be looking at a *least* a VPS with 512 meg of ram. Just to start.

  23. artur
    Member
    Posted 4 years ago #

    ok. i just setup WP 3 on their PS service..

    and everything went smooth.. until i started to make a new SubDomain.
    * the main domain works great.

    but when i click on the new subdomain site i get a repeated url:
    http://mysite2.convertmyflash.comconvertmyflash_com/
    and it should be:
    http://mysite2.convertmyflash.com/

    my wp-config ( after the serial key code ):

    //define('WP_ALLOW_MULTISITE', true);
    
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', true );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'convertmyflash.com' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );
    
    /* Stop editing */
    
    $server = DB_HOST;
    $loginsql = DB_USER;
    $passsql = DB_PASSWORD;
    $base = DB_NAME;
    
    define('ABSPATH', dirname(__FILE__).'/');
    
    // Get everything else
    require_once(ABSPATH.'wp-settings.php');
    ?>

    i also tried commenting out :
    'define( 'DOMAIN_CURRENT_SITE', 'convertmyflash.com' );'

    and no luck!

    please advise thanks!

  24. artur
    Member
    Posted 4 years ago #

    also when i manually go to the url : http://mysite2.convertmyflash.com/
    i dont see any Styles/template setup.

    and when i setup a new subdomain.. the new user gets this url to login:
    http://mysite2.convertmyflash.comconvertmyflash_com

  25. artur
    Member
    Posted 4 years ago #

    FIXED!

    basically it was Dreamhost's fault.
    all i needed to do is comment out this line in the wp-config.php

    //$base = DB_NAME;

    * i hope that doesnt affect any other WP features?
    will it?

  26. That was put in there by Dreamhost's OneClick installer.

    So.... no.

  27. Ninaj
    Member
    Posted 3 years ago #

    Hi,
    I am having the same problem. I am on GoDaddy. Trying to use subdirectories. The WP install was over a month old but I changed the true to false in the config file.

    Here's the config:
    'define('WP_ALLOW_MULTISITE', true);
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', false );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'mysite.org' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );
    '

    Here's the .htaccess:

    '# BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    </IfModule>
    # END WordPress

    '

    All the admin panels get set up and emails get sent but I get a 404 error.
    I added the
    '<Directory />
    AllowOverride All
    </Directory>
    '
    to the top of the .htaccess and then got a misconfiguration error so I had to remove it.

    Is there any further help on this issue?

    Thanks.

  28. elanbailey
    Member
    Posted 3 years ago #

    Hmmm. I'm having a related problem. I am with dreamhost and when I complete the network set up I get the confirmation that a network has been set up. However I don't have a superadmin menu.

    I tried adding this to my .htaccess file:
    ''<Directory />
    AllowOverride All
    </Directory>'

    And it causes an internal server error.

    I see that the DH one-click install added the following lines to my wp-config file:

    '$server = DB_HOST;
    $loginsql = DB_USER;
    $passsql = DB_PASSWORD;
    $base = DB_NAME;'

    I commented these out.

    So when I click on Tools > Network the system gives me a warning that a network has already been detected on my site. But I don't have any super admin menu access to my network.

    I did leave this line in the wp-config file:
    'define('WP_ALLOW_MULTISITE', true);'

    elan

  29. @Ninaj - go back to the admin menu for networks and get the NEW htaccess code for the different format you switched to.

    I tried adding this to my .htaccess file:
    ''<Directory />
    AllowOverride All
    </Directory>'

    And it causes an internal server error.

    That has absolutely nothing to do with multisite.

    So when I click on Tools > Network the system gives me a warning that a network has already been detected on my site. But I don't have any super admin menu access to my network.

    Look in the database for these tables:

    wp_blogs
    wp_blog_versions
    wp_registration_log
    wp_signups
    wp_site
    wp_sitemeta

    If they ARE there, that's why it's detecting an exisiting network.

  30. Ninaj
    Member
    Posted 3 years ago #

    Hi Andrea,

    I completed uninstalled and did a fresh install copied all the correct codes to .htaccess and wp-config. It worked - yesterday. Each blog was set up using the default twenty ten, even though the main blog was using a studiopress theme.

    Today - gone. I have the admin panels but I get a page not found error on the blog pages.

    Additionally I have my permalinks set to /%postname%/. I know see on the main site there is blog/ before the permalink field. Also on the sub-directory sites the permalinks become this: /%year%/%monthnum%/%day%/%postname%/

    Not sure if that helps at all...

    Any thoughts as to why it was there yesterday and not today? Something rewriting something else?

    Thanks,
    Nina

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.