WordPress.org

Ready to get started?Download WordPress

Forums

WordPress 2.9: your attempt to edit this post has failed (70 posts)

  1. DannyWRP
    Member
    Posted 4 years ago #

    As per the recommendations here, I did deactivate the twitter tools plugin, and now everything works fine. I did trying just activating twitter tools on it's own, without the extra Bit.ly URLs plugin, and it did not work.

    I'll just leave the twitter stuff out until I see a proper fix for it.

  2. Michael Clark
    Member
    Posted 4 years ago #

    I've had this problem on blogs that do have Twitter Tools installed, and on blogs that do not have Twitter Tools installed. I only use Twitter Tools to read and import my tweets, I don't automagically publish my blog posts to a twitter account.

    PHP 5.16. WordPress 2.90. Apache 2.2.3. MySQL 5.0.77

  3. WPChina
    Member
    Posted 4 years ago #

    I'm glad I found this thread. Yes, I just disabled Twitter Tools and now everything works fine on both blogs that had this issue.

  4. jpmidnight
    Member
    Posted 4 years ago #

    Having seen people voted for Twitter tools plugin works, then I wonder a true problem lies beyond Twitter tools...

    My environment is

    Server version: Apache/2.2.14 (Unix)
    Server built:   Dec  5 2009 20:07:31
    Server's Module Magic Number: 20051115:23
    Server loaded:  APR 1.3.9, APR-Util 1.3.9
    Compiled using: APR 1.3.9, APR-Util 1.3.9
    Architecture:   64-bit
    Server MPM:     Worker
      threaded:     yes (fixed thread count)
        forked:     yes (variable process count)

    mysql Ver 14.12 Distrib 5.0.84, for pc-linux-gnu (x86_64) using readline 6.0

    PHP 5.2.12-pl0-gentoo (cli) (built: Jan  2 2010 08:47:35)
    Copyright (c) 1997-2009 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2009 Zend Technologies

    WordPress is 2.9.1 and Twitter tools is 2.0.

  5. indierockmedia
    Member
    Posted 4 years ago #

    The problem I am having with my WP 2.9 and twitter tools is simply that my tweets dont show up as posts. The widget appears to be working, I have no issues with failed posts or anything else. I set my tweets to display as posts and nothing. Tried everything for 6 hours now..

  6. indierockmedia
    Member
    Posted 4 years ago #

    p.s. I am using 5 with Dreamhost, jQuery, and twitter tools has worked flawlessly with other sites I have made using pre WP 2.9

  7. indierockmedia
    Member
    Posted 4 years ago #

    OK, update: on a separate client project, using just the default theme, the plugin worked fine. The site I am having a problem with is using a theme I purchased. That narrows it down some to a theme problem, maybe in the functions file.

  8. tomreese
    Member
    Posted 4 years ago #

    I also upgraded to WP 2.9 and began receiving the dreaded "your attempt to edit this post has failed" error.

    Disabled Twitter Tools, everything works fine again.

    There must be some commonality between the plugins causing this problem (it's clearly not just Twitter Tools, since people who don't have TT activated are also experiencing this issue). I'm going to look into it further later today when I have a bit more time.

  9. Alex King
    Member
    Posted 4 years ago #

    We believe there may be an environmental issue that is causing this problem. If you are having trouble saving posts in WP 2.9.x, it would be helpful to install the WordPress HelpCenter plugin and send in your System Profile so that we can try to identify common versions, etc. that could be contributing to this.

    http://wordpress.org/extend/plugins/wphelpcenter/

  10. Alex King
    Member
    Posted 4 years ago #

    Have created a new release based on hunches - available for testing:

    http://alexking.org/blog/2010/01/08/twitter-tools-and-wordpress-2-9-testing-needed

  11. jpmidnight
    Member
    Posted 4 years ago #

    It works in my test environment.

  12. rainer23
    Member
    Posted 4 years ago #

    People are asking how to send your posts to twitter without twitter-tools, just get the firefox twitter/facebook plugin.

  13. Gary_Petersen
    Member
    Posted 4 years ago #

    Alex, I uploaded the updated plugin and it allowed me to successfully create and save a test post following the steps I outlined earlier in this thread. I was also able to post to Twitter using the plugin, though I did have only it activated. One thing you'll want to update in the final release, the version number of the plugins (as shown on the plugins page in WordPress) did not change when I loaded the test versions.

  14. graemecod
    Member
    Posted 4 years ago #

    I run a number of different WP blogs, using different themes and formats. Since latest update of 2.9.1., I have not been able to create any posts when I have any Twitter related plug in active. I have had to deactivate all of them in order to be able to create any post.

    I have installed WPhelpcenter on one of my domains (www.graemecodrington.com) and sent you my System Profile.

    I hope you get this sorted soon as I need the link between WP and Twitter on most of my sites.

  15. PFMRinteract
    Member
    Posted 4 years ago #

    I am experiencing the same problem, but NOT using Twitter Tools and the problem also persists even when I deactivate all of my plugins at once.

    I have just noticed this problem since upgrading to 2.9. My database has always been MySQL 5 so MySQL 4 isn't the problem.

    I don't get the error message if I save a draft with no title. Then I can add the title and save as draft and it works. Also, when I do get the error message it still saves the post and I can see the new post show up when I go to the 'edit posts' menu.

    Is anyone else having a similar problem unrelated to Twitter plugin? Any ideas?

  16. RexFromArs
    Member
    Posted 4 years ago #

    I can report the new version of Twitter Tools apparently fixes the problem. I do not get the "your attempt to edit this post has failed" error, but it seems like it takes a long time for new posts to "go through".

    This is on a small, personal blog (>1500 posts).

  17. PFMRinteract
    Member
    Posted 4 years ago #

    I solved my issue but needed to disable the auto-save function. The error is definitely related to auto-save. Although this is a nice feature in theory I think I can live without it.

    If anyone else has had no luck resolving the error by disabling plugins and doesn't mind disabling the auto-save here is what to do:

    1. open the file post-new.php found in the wp-admin folder
    2. find the line that says wp_enqueue_script('autosave'); and type // in front of it to turn it into a comment rather than a command (this way you can reenable the feature later if you decide to)
    3. save the file and replace the old one on your ftp client

  18. rainer23
    Member
    Posted 4 years ago #

    Could be that "autosave" requires server config that has "safe mode off"?
    Is there any mentioning that 2.9.1 prefers servers which have "safe mode off"?

  19. sogrady
    Member
    Posted 4 years ago #

    @PFMRinteract: yes, i'm experiencing this problem with no Twitter Tools installed.

    WP version is 2.9.1
    PHP version is 5.1.2
    Apache version is 2.0.55

  20. damianrees
    Member
    Posted 4 years ago #

    Hi I am also experiencing this issue without Twitter Tools installed. Any solutions to this yet? Seems like a bit of a shoddy update from WordPress to me :(

  21. mrbelm
    Member
    Posted 4 years ago #

    I had the same problem running WP 2.9.1 with the WP to Twitter plugin, the blank page after publishing a post. Deactivating the plugin eliminated the problem.

    IT seems to me the problem is with WP's interaction with Twitter posting, since it's reproducible with two different Twiter plugins.

  22. damianrees
    Member
    Posted 4 years ago #

    Anyone got a solution for people who DO NOT have the twitter tools plugin?

  23. Coffee4cr
    Member
    Posted 4 years ago #

    Thanks, updating my php version worked!

  24. BurningDog
    Member
    Posted 4 years ago #

    Upgrading to php 5 worked for me too. I'm not using Twitter Tools, but am using Tweet Blender, Tweet This and Twitter Publisher - enabling any 2 of these caused a "Your attempt to edit this post has failed" on a new post. Updating to php 5 meant I could post things again.

  25. d0k
    Member
    Posted 4 years ago #

    just to add another example about this silly bug.
    I've a mu, with different sites on it. I've done same configuration on two of them, one works the second one provides the error on posting.
    I've tried removing plugins and enabling them one by one (I've no twitter plugin installed). At the end I've re-enabled all the plugin and the posting works again.

  26. drokkon
    Member
    Posted 4 years ago #

    This probably won't contribute much, but I also am having this problem WITHOUT ever having ever heard of Twitter Tools, and I AM running PHP5. I have a dozen other plugins, though, but I'm too scared to deactivate them all.

    I really have to set up a test environment one of these days...

  27. somaputra
    Member
    Posted 4 years ago #

    hi , all
    i've same problem during upgrade to wp-2.9.2 , I deactivated allplugins, and upgrade successfully. thank's to all of you. see you.

    regards,
    http://www.all-publisher.com

  28. Rian Rietveld
    Member
    Posted 4 years ago #

    I use WPMU 2.9.1 and buddypress 1.2 and got the error
    The method in this post worked for me
    http://www.ghacks.net/2009/02/02/wordpress-your-attempt-to-edit-this-post-has-failed/

    So true @drokkon I really have to set up a test environment one of these days...

  29. drokkon
    Member
    Posted 4 years ago #

    Just a quick update: searched all the files within my wordpress install for "JSON," and found that Topsy Retweet was also referencing this library that was a suspected culprit. Disabled Topsy, but the problem is still there!

  30. neekone
    Member
    Posted 4 years ago #

    It was the twitter tool that did this to me using MySQL 4 on another Blog MySQL 5 and the same twitter tool no problems... time to update datebase

Topic Closed

This topic has been closed to new replies.

About this Topic