WordPress.org

Ready to get started?Download WordPress

Forums

WordPress 2.8.5: disabling comments (7 posts)

  1. boboboi
    Member
    Posted 4 years ago #

    I am having trouble disabling comments in my entire site. Reading most of the forum topics, people are instructed to uncheck "Allow people to post comments in articles". However, in v2.8.5 this option has been replaced with "Allow people to post comments on NEW articles". So when I uncheck this option, it has no effect on all of my previous posts and pages. I am 99% sure I have overlooked something and would appreciate your help!

  2. @mercime
    Volunteer Moderator
    Posted 4 years ago #

    If you want to disable comments entirely, you can delete the "call" to comments.php see this for reference about which tag to delete in both Posts and Pages http://codex.wordpress.org/Function_Reference/comments_template
    OR
    If you don't want to touch your theme install a plugin http://wordpress.org/extend/plugins/close-old-posts/

  3. boboboi
    Member
    Posted 4 years ago #

    Thanks for the suggestions!
    Unfortunately that wasn't exactly what I was looking for, which is in no way your fault as my initial post was unclear.
    I guess I should also say what it is I want to exactly achieve.

    My site has been up for more than a year, many posts and pages have been added on to the site. I have recently added a new page and I would like only that page to have commenting enabled. On the older versions of wordpress you could just uncheck "allow people to post comments in articles" and just individually enable commenting on the posts/pages that I want as I add them to the site. With 2.8.5 it appears that I cannot do that, and I doubt the only solution is to manually disable comments on all of my previous pages and posts.

    Reading your post again mercime your solution may work for me, just that my php knowledge is quite basic and I will need some guidance as to what the instructions mean and such.

  4. @mercime
    Volunteer Moderator
    Posted 4 years ago #

    Ok, now it's clearer to me. WP 2.8.5 does allow override of disabled comments in individual Posts or Pages, so your situation is odd. The first thing you should do is upgrade your install to WP 2.8.6 ASAP for security. It could also resolve your problem about enabling comments only for specific Posts or Pages.

    If upgrading doesn't resolve enabling comments in individual Post/Page, then you might have some theme or plugin conflict. The easier thing to do is change theme back to default theme and check in Post or Page write panels whether you can enable/disable comments/trackbacks. Then change back to custom theme. If that doesn't work, disable all plugins and enable one by one and checking the enabling comments in between each plugin activation to find the culprit.

  5. boboboi
    Member
    Posted 4 years ago #

    Thanks for sticking around to help me out!
    The thing is I need the exact opposite of what you're describing, I am able to individually enable comments on posts/pages. The thing I am unable to do is globally (I believe that's the term) disable commenting on the site. I have recently decided to enable it on one page, but the only option I have on 2.8.5 is to enable it for all pages/posts and then individually disable it on the new posts/pages that I will be creating.

    I realize my situation is very odd, hence the confusion even I get when reading what I just wrote, this is why I believe I am overlooking a very simple solution.

  6. alism
    Member
    Posted 4 years ago #

    If you want to disable it for all existing posts, have a look at MichaelH's final response in this thread:
    http://wordpress.org/support/topic/310934?replies=6

    Then just re-enable the post/page you do want comments for.

  7. boboboi
    Member
    Posted 4 years ago #

    Thanks! Running those 2 lines in PHPmyAdmin has disabled comments for all posts!

    However, now when I re-enable comments for specific posts/pages, the comment box does not show anymore. I am aware I need to include the code: <?php comments_template(); ?> in my theme's page.php file and I have included that. Any ideas why this is the case?

Topic Closed

This topic has been closed to new replies.

About this Topic