WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WordPress 2.8: No toolbars & can't read post text (31 posts)

  1. VictoriaE
    Member
    Posted 5 years ago #

    Just updated automatically to WordPress 2.8.

    When writing a blog post, I have no toolbars (i.e. can't add URL links, adjust text ... etc.) & I can't even see the text when I type it in the box - it is all white!

    Any ideas on how to fix this?

  2. mduszyk
    Member
    Posted 5 years ago #

    the same on my blog - just upgraded to 2.8 and Tiney MCEAdvanced does not work, text area is white......

    Any fix soon?

    Mark

  3. malexandria
    Member
    Posted 5 years ago #

    Same thing happened to me use Dean's FCK Editor Plugin instead. That works fine.

  4. hrbartender
    Member
    Posted 5 years ago #

    I have the TinyMCE on the HTML editor only - not the visual. Can switch between the two and what I type is showing up. Same in both IE8 and Firefox.

  5. The Secret Cash Builder
    Member
    Posted 5 years ago #

    Same here, ugh!!!

    I'm so sorry I upgraded right now, I hope this plugin works!

  6. The Secret Cash Builder
    Member
    Posted 5 years ago #

    Well FCK did not work for me, how do I go back to 2.7.1?

  7. jsoroko
    Member
    Posted 5 years ago #

    Editing tools worked in RC 1 - disappeared in 2.8 final. Perhaps more testing was in order. JS

  8. addics
    Member
    Posted 5 years ago #

    same problem here... thi is fked up

  9. addics
    Member
    Posted 5 years ago #

    I have the same problem, i've upgreaded to 2.8 and the toolbar from visual editor is gone, i tried in ie8, in firefox 3.0.10, in chrome and its still gone.

    When I try to re-install wordpress i keep getting this error:

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 1572864 bytes) in /home/fanfotba/public_html/wp-includes/http.php on line 999

    Dont know what to do! Need help! T

  10. WilliamTM
    Member
    Posted 5 years ago #

    I've got the same problem...Visual mode doesn't show any trace of TinyMCE at all, and the HTML mode still has it's toolbar. However, switching between the tool makes it screw around with the text, and it's adding/removing p and br tags everywhere. :(

  11. mduszyk
    Member
    Posted 5 years ago #

    I deactivated TinyMCE,
    installed FCKEditor and all is working again!

  12. jackamus
    Member
    Posted 5 years ago #

    I am also having all the same issues as above. Kind of nerve racking. I disabled the plug in, so I know it's not that. Hopefully a quick fix comes around, I'll also try using FCKEditor that somneone else mentioned as a brief fix.

  13. VictoriaE
    Member
    Posted 5 years ago #

    Any updates on this issue? I'm glad to know I'm not the only one having it - was worried my automatic install plugin messed up (it was my first time using it).

  14. mamaloves
    Member
    Posted 5 years ago #

    I have tried all the quick fixes and nothing works. KCFEditor made things worse. How do I go back to wp 2.7.1. I can't post and need to make some updates for readers.

  15. figaro
    Member
    Posted 5 years ago #

    How do I go back to wp 2.7.1. I can't post and need to make some updates for readers.

    Do you have a backup of your db before you upgraded?

  16. mamaloves
    Member
    Posted 5 years ago #

    Yes..

  17. mamaloves
    Member
    Posted 5 years ago #

    My dashboard doesn't look right either. I have nothing showing in the right hand column anymore. Is this all related?

  18. mamaloves
    Member
    Posted 5 years ago #

    I found what is causing the problem for me. The culprit seems to be nextgen-gallery plugin. When I deactivated this one plugin everything seems to reappear. I love this plugin but for now I won't use it. Hope a fix becomes available soon.

  19. VictoriaE
    Member
    Posted 5 years ago #

    I don't use that plugin, so it must be a bigger problem than just a plugin issue ... I do hope this gets solved soon ... :(

  20. figaro
    Member
    Posted 5 years ago #

    @VictoriaE: Have you disabled all plugins and reviewed the list of things to check at the link below...

    http://wordpress.org/support/topic/279132?replies=1

  21. VictoriaE
    Member
    Posted 5 years ago #

    I did disable all plug-ins to test if that was the issue - nope. I'll try the other suggestions listed in the linked thread and let you know if it works. :)

  22. VictoriaE
    Member
    Posted 5 years ago #

    The automatic re-install (FAQ step #6 @ http://wordpress.org/support/topic/279132?replies=1) worked!

  23. amoswright
    Member
    Posted 5 years ago #

    the automatic re-install worked for me, thanks for the link. the step that made the difference was simply re-uploading new, fresh copies of wp-admin and wp-includes.

  24. jackamus
    Member
    Posted 5 years ago #

    I've done all this now, and still no go. I can not see or edit (because I can't see it) posts from the admin panel yet. Hopefully a fix is forth coming. I have tried on several browsers a couple of PC's.....

  25. Mossack Anme
    Member
    Posted 5 years ago #

    Re-installing WP 2.8 works well on my sites...
    On my blog that hosted on IIX server (Indonesian National Backbone), re-upload or overwriting wp-admin and wp-includes folder resolved the problem.

    Thx!

  26. jackamus
    Member
    Posted 5 years ago #

    I can report I was able to get the editing to look and work correctly in IE8 standalone and within the AOL 9.5 client. I am not able to get the editor to show text correctly in FF 3.0.11. I have installed and updated client of TinyMCE Advanced 3.2.4, that seems to allow me to edit via IE8, just not FF, yet. I posted this, in case it helps anyone.

  27. onewalrus
    Member
    Posted 5 years ago #

    THIS WORKS:

    1. Remove the site from Gears list. (ignore if no Gears)
    2. Disable the Gears.
    3. Clear browser cache.
    4. Reinstall WP 2.8 or reupload through tools/upgrade (overwrite) wp-admin and wp-includes folder.
    5. Clear browser cache (if you choose reinstall way).
    6. Enabling Gears.
    7. Login to wp-admin and re-enabled Turbo-Gears.
    8. Enjoy.

  28. jackamus
    Member
    Posted 5 years ago #

    Thank you onewalrus. I did that and now I have my edit screens back.

  29. drjimanderson
    Member
    Posted 5 years ago #

    Bingo - that solved the problem for me. So nobody's talked about what's causing this problem, but it sure looks like old cached information is not compatible with new WordPress 2.8 code.

    I'm not 100% sure why reloading portions of the WordPress 2.8 code into your blog's subdirectories is required, but the clearing of your browser's cache (including cookies!) is definitely required. I did both steps and now I can see my TinyMCE editing tools.

    One small "gotch" that might sneak up on you - I signed out of my blog before reloading the code and clearing my cache. Then when I tried to log in, WordPress acted like my admin account didn't exist. The solution was to clear my cache again and RELOAD the WordPress sign-in page. Whew!

    Good luck to everyone who is still struggling with this one...

    - Dr. Jim Anderson
    http://www.TheAccidentalSuccessfulCIO.com

  30. x0fx3
    Member
    Posted 5 years ago #

    delete your wp-admin and wp-includes folder and reinstall a fresh copy that worked for me :) but still having problems with dashboard but thats a conflict with my plugins

Topic Closed

This topic has been closed to new replies.

About this Topic