WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] wordpress 2.7.1 instalation problem (10 posts)

  1. virtualmjr
    Member
    Posted 5 years ago #

    Hi,
    I`m trying to install wordpress 2.7.1 on my linux dedicated server and after modifing the wp-config.php folowing the documentation the install.php pange shows up empty.
    I have created a database, is there something more i should do?

    Also, something very strange.Even if my display_errors is on in my php.ini i don't get any errors in the browsers like i do in other site that i have. No errors in my httpd errors_log also.

    Also i want to say that i`ve tryied to install wordpress on my windows pc with LAMP installed and it worked without a problem/

    The site where i want to install wordpress is http://blog.taracalculatoarelor.ro/
    I hope someone has had this problem before.

    Thanks
    Antohe Sorin

  2. WebDev WaxLotus LLC
    Member
    Posted 5 years ago #

    If you make a simple index.html can you view that? (does your webserver work!)

  3. virtualmjr
    Member
    Posted 5 years ago #

    Hi.
    Yes it does work. I have made an index.html, you can view it: http://blog.taracalculatoarelor.ro/index.html
    Also i have hundreds of sites on that server so i don't think it`s a problem with my web server.

    Thanks for your reply.

  4. WebDev WaxLotus LLC
    Member
    Posted 5 years ago #

    Hmm, well, that's a good sign that the server's good. The WP install is pretty straight forward. Create the db, use the db login info to install WP/edit wp-config.php and you're good to go.

    Delete the index.html to get the server to pull the index.php (there's also a .htaccess directive you can add to specify the order of various index doc's)

    <IfModule mod_dir.c>
    DirectoryIndex index.php
    </IfModule>

  5. WebDev WaxLotus LLC
    Member
    Posted 5 years ago #

    It's pushing install.php at me! Make it stop, haha!

    Odd. You have other sites up and running so PHP must be installed correctly... mime types must be ok ...

    .htaccess nonsense? What's in that file (for this site)?

  6. virtualmjr
    Member
    Posted 5 years ago #

    Hi.
    I don't have any .htaccess for this site.
    Do i need one?

  7. WebDev WaxLotus LLC
    Member
    Posted 5 years ago #

    Why don't you try it and see if it fixes your issue?

    Options +FollowSymLinks
    RewriteEngine On
    RewriteBase /
    
    <Files .htaccess>
    order deny,allow
    deny from all
    </Files>
    
    <IfModule mod_dir.c>
    DirectoryIndex index.php index.html
    </IfModule>
    
    # add a trailing slash to /wp-admin
    RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    RewriteRule ^(.+)$ /$1/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    
    # Allow flash uploader to work
    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>
  8. virtualmjr
    Member
    Posted 5 years ago #

    Hi.
    Thanks for your reply but still nothing.
    I just get the blank pages with no errors.

  9. WebDev WaxLotus LLC
    Member
    Posted 5 years ago #

    Hmm,

    If all the WP files are in place with the proper permissions etc then I would look at your server and your server configuration.

    http://codex.wordpress.org/Hosting_WordPress

    http://codex.wordpress.org/User:Hakre/Technical_Installation

    Blank pages may stem from js conflicts or insufficient RAM etc...

  10. virtualmjr
    Member
    Posted 5 years ago #

    Hi.
    Thanks for your answer. You made my day :)
    I had to set zend.zel_compatibility_mode to Off in php.ini and now it works :)

    Thanks
    VM

Topic Closed

This topic has been closed to new replies.

About this Topic