WordPress.org

Ready to get started?Download WordPress

Forums

WordPress 2.7 issue > AUTOPLAY on audio files wont disable properly (16 posts)

  1. mcordina
    Member
    Posted 5 years ago #

    Hello All!

    I have just recently installed WP 2.7 on a blog that I am managing. I am having an issue with the autoplay feature when embedding an audio file. Using Quicktime as the player, and clicking on the ADvanced tab, I turn off the "autoplay" feature, and then when I go to test, it still plays automatically? I go back, turn it off again and same problem. I tried IE and Firefox on both XP and Vista PC's. I also tried with Windows media and I have the same prob.

    Is anyone else having this issue? I cant have all the sound files autoplay as there are multiple embedded audio files on one page and I have never had this issue before.

    PLEASE HELP!!!

  2. cipote
    Member
    Posted 5 years ago #

    I'm also having this issue with videos.
    For me, the autoplay settings get changed whenever I edit the post.

  3. monpelaud
    Member
    Posted 5 years ago #

    I'm having the same issue too!
    In advanced menu I can't disable Auto start, Show menu and Invoke URLS options.
    I don't know how to fixe this issue.

  4. mcordina
    Member
    Posted 5 years ago #

    Is it safe to say this is a bug? I will try reporting this issue with WP, I am new to this part so if anyone knows how to do it please go ahead and do the same! What an inconvenience this is. Thank you for your replies.

  5. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    WordPress doesn't know anything about "autoplay" or any other video content, so it can't alter anything in that way.

    You'll need to be more specific about how you include the video.

  6. monpelaud
    Member
    Posted 5 years ago #

    When I insert a video in a post the HTML code generate is:
    '<object classid="clsid:6bf52a52-394a-11d3-b153-00c04f79faa6" width="100" height="100" codebase="http://activex.microsoft.com/activex/controls/mplayer/en/nsmp2inf.cab#Version=5,1,52,701"><param name="url" value="http://pelvoux.localdomain/wordpress/wp-content/uploads/2008/12/mvi_0156.avi" /><embed type="application/x-mplayer2" width="100" height="100" src="http://pelvoux.localdomain/wordpress/wp-content/uploads/2008/12/mvi_0156.avi" autostart="false"></embed></object>'

    When I save the post the HTML code saved is:
    '<object classid="clsid:6bf52a52-394a-11d3-b153-00c04f79faa6" width="100" height="100" codebase="http://activex.microsoft.com/activex/controls/mplayer/en/nsmp2inf.cab#Version=5,1,52,701"><param name="url" value="http://pelvoux.localdomain/wordpress/wp-content/uploads/2008/12/mvi_0156.avi" /><param name="url" value="http://pelvoux.localdomain/wordpress/wp-content/uploads/2008/12/mvi_0156.avi" /><embed type="application/x-mplayer2" width="100" height="100" src="http://pelvoux.localdomain/wordpress/wp-content/uploads/2008/12/mvi_0156.avi" url="http://pelvoux.localdomain/wordpress/wp-content/uploads/2008/12/mvi_0156.avi"></embed></object>'

  7. p800aul
    Member
    Posted 5 years ago #

    The tool is not adding all of the code needed

    <object classid="clsid:6bf52a52-394a-11d3-b153-00c04f79faa6" width="100" height="100" codebase="http://activex.microsoft.com/activex/controls/mplayer/en/nsmp2inf.cab#Version=5,1,52,701"><param name="url" value="http://pelvoux.localdomain/wordpress/wp-content/uploads/2008/12/mvi_0156.avi" />

    should read

    <object classid="clsid:6bf52a52-394a-11d3-b153-00c04f79faa6" width="100" height="100" codebase="http://activex.microsoft.com/activex/controls/mplayer/en/nsmp2inf.cab#Version=5,1,52,701"><param name="url" value="http://pelvoux.localdomain/wordpress/wp-content/uploads/2008/12/mvi_0156.avi" /><param name="autoplay" value="false">

    I just added the code and it worked for me, a pain but i guess it will be fixed

  8. jjowens
    Member
    Posted 5 years ago #

    Hello folks, I'm having this same issue. I'm using WP version 2.7. What I found is that WP does not save the option parameter <param name="autostart" value="true/false" /> to the post.

    In my case I'm inserting a Windows Media Player video and these are the seteps to reproduce the issue:

    1. While in edit post mode, select the button "Insert/Edit embedded midia" from toolbar.

    2. Select type "Windows Media", enter the video URL and dimensions. Then go to "Advanced" tab and UNCHECK the "auto start" box.

    3. Click on "Update" to save.

    4. Back to the post, click "Update post" button.

    5. Highlight the embedded midia box and click on "Insert/Edit embedded midia" button in toolbar.

    6. Go to "Advanced" tab and notice the "Auto start" box is CHECKED.

    The issue can also be verified by reviewing the respective HTML where regardless the status of the "auto start" property, the <param name="autostart" value="true/false" /> is never included.

    A quick workaround I found is to manually insert the option parameter

    <param name="autostart" value="false" />

    in HTML edit mode. The suggested workaround in the previous post did NOT work for me (using parameter name "autoplay" set to "false").

    I hope this is reported as a bug to WP support. I don't know how to do it.

    --jjowens

  9. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    jjowens: None of what you're talking about exists in WordPress. WordPress doesn't have any "Windows Media" text, it doesn't know anything about dimensions of media files, it can't enter object tags into the post, there is no "autostart" checkbox, etc, etc.

    You must be using a plugin or something to add all of this, because it is not a part of WordPress.

  10. matthewb76
    Member
    Posted 5 years ago #

    Otto42, I am having the same issue, and as a new user of wordpress have not downloaded any plugins. Follow jjowens instructions and you will see in the post page there is an "insert/edit embedded media". I won't repeat what the other posters have said, but in the advanced options when windows media is chosen, when you uncheck autoplay it will not save.

  11. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    OH! I see what you're talking about. That's in TinyMCE, not in WordPress. I've never used that functionality before, because WordPress has it's own media uploader, which that TinyMCE stuff is not a part of.

    I'd look at the TinyMCE website, and take it up with them. If they have a fix for the problem, we can incorporate it into WP, but TinyMCE is such a big and separate project that it's unlikely WP will fix anything in it directly, since it needs to maintain parity with the released code.

  12. jjowens
    Member
    Posted 5 years ago #

  13. Neziniux
    Member
    Posted 5 years ago #

    I have the same problem with WP 2.7 :(

  14. dougjam
    Member
    Posted 5 years ago #

    I was going a little (more) nuts trying to figure out why the autostart kept resetting itself. I have multiple players on my blogpage and they all started playing at once!
    After finding this post, I used the advice (see above) from:
    p800aul
    I inserted:
    <param name="autoplay" value="false">
    and it works.
    Thanks.

  15. NickCorcodilos
    Member
    Posted 5 years ago #

    dougjam,

    I tried what you did. Added <param name="autoplay" value="false">, saved, tested. WMP still starts playing automatically. When I go back and check the HTML, the code I added is gone! Tried again and again, but that code keeps disappearing.

    How'd you manage to make it "stick"?? Thanks!

    (This is very frustrating. As for TinyMCE, I didn't install TinyMCE in my WP 2.71. Where'd the player come from??)

  16. Sandee Cohen
    Member
    Posted 5 years ago #

    I have had the same issue with an embedded mp3 QT sound.

    I uncheck Autoplay, but when I preview the page, the sound starts playing.

    And then when I check the Advanced status of the link, Autoplay is checked again.

    The only way I have gotten the sound not to Autoplay is to NOT preview the page. Just publish immediately after setting the sound.

    That seems to work.

    But any corrections on the page mean I have to reimport the embedded media.

Topic Closed

This topic has been closed to new replies.

About this Topic