WordPress.org

Ready to get started?Download WordPress

Forums

WordPress 2.5 loading EXTREMELY slow (12 posts)

  1. tuomob
    Member
    Posted 6 years ago #

    I upgraded to WP 2.5 and as soon as I got the software running on the server, I noticed that the pages are loading extremely slow. It takes about 30 seconds or more to load even the front page. I checked the chmod settings. I checked the plugins. I checked the server load in general. I checked other pages under the same domain. No problems. Everything is fine expect that my blog is the slowest in the world right now.

    The server is running PHP 5 and MySQL 5. The address of my blog is: http://www.bjorksten.fi/blogi

    Any tips?

  2. Andrew Ozz
    WordPress Dev
    Posted 6 years ago #

    Seems fine to me... The above link loaded in 2-3 sec.

  3. tuomob
    Member
    Posted 6 years ago #

    Hmmm... At the end of the source code it says "!-- 30 queries. 28.381 seconds. -->". Does the result depend on the speed of my current internet access?

  4. solonavi
    Member
    Posted 6 years ago #

    I'm facing this main page slow response issue also. Previously was on 2.3.3 and no such issue. Now, 50% of the time, it will take > 30sec to load the main page.

    My blog is @ http://www.shinnpark.com/ running on MYSQL Version : 4.0.27-standard and PHP Version : 4.4.8.

    Any advice?

  5. altoyes
    Member
    Posted 6 years ago #

    hi folks

    me also ... Previously was on 2.3.3 and no such issue.

    Since updating the version to latest version ....
    very very slow in the admin pages and sometimes, i get a message asking me if i want to continue the script ... can anyone tell me what that is all about? and why it takes so incredibly long to save a file or to do anything in admin?

    Thankyou for your time
    http://worldpeacepoll.com/fabradio/

  6. DianeV
    Member
    Posted 6 years ago #

    The bjorksten.fi blog loaded for me in 2-3 seconds.

    The shinnpark blog took quite a while, but I think that's because the home page is almost 4MB, which is a huge download. Try optimizing your images -- for instance, the Oishii image is 325K; resaving it (in Photoshop) at 60% quality brings it down to 93K, which is not nothing but quite a difference.

    worldpeacepoll was not so bad, but the home page is about 1MB. Try cutting that down as you can.

  7. altoyes
    Member
    Posted 6 years ago #

    hi dianeV
    thankyou for your reply

    the front page loads fine, though i will cut it down in size.
    it is the admin which is really very very slow.

    dianeV, do you know what is happening when i try saving anything in admin, a message OFTEN comes up, "do you want to continue running the script?"

    what is that?

  8. DianeV
    Member
    Posted 6 years ago #

    You're welcome, and I misunderstood.

    No, I don't know what the admin warning might be, unless you're using Internet Explorer and your settings cause it to warn you when scripts are running on a page. Beyond that, I don't know.

  9. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    I've setup several installations for people on some somewhat dodgy hosting services, and I've noticed that WordPress does not handle overloaded shared servers particularly well. I've usually been able to get acceptable performance out of these systems by installing WP-Super-Cache. By eliminating the load caused by viewers of the site, this tends to increase the CPU time available for the administrative side of things. Depends on the server configuration of course, but it works particularly well on shared hosts that do lots of CPU throttling.

    It's worth a try.

  10. meetjustin
    Member
    Posted 5 years ago #

    I keep seeing messages saying people's blogs are slow once they upgrade, but no one ever posts how they resolved the issue. Anyone?

  11. bencasbon
    Member
    Posted 5 years ago #

    I figured it out. My wordpress install was on a server that wasn't allowed to make web requests to the rest of the internet. Because of that, the scripts that were loading the widgets on the main page were timing out and taking forever without notifying me. In firefox, since the ajax calls on the dashboard widgets are asynchronous, it doesn't give me any slows at all. So, go into index.php in the wp-admin folder and comment out the dashboard_primary:, dashboard_secondary: etc...

    Works like a charm afterwards.

  12. christinck
    Member
    Posted 5 years ago #

    my intranet-server with WP has no internet-connection.
    every page (blog or admin) ist loading with a 30sec delay.

    tried to install a new version of WP.
    event the setup has this delay starting at 2nd screen.

    any hints ?

Topic Closed

This topic has been closed to new replies.

About this Topic