WordPress.org

Ready to get started?Download WordPress

Forums

WordPress 2.5 Inserting Images Issue (22 posts)

  1. crianp
    Member
    Posted 6 years ago #

    Hi everyone, I love the new wordpress version with the exception of the fact that it is much harder for me to insert images now. The new "add medi" option does not want to work for me.

    1. When I go to upload an image, that works fine but I can't seem to be able to insert said image into a post without switching to the code part of wordpress and inserting the IMG tags and having to type out the really long link to the image manually? I really miss the old way of inserting images into posts, is that buried in 2.5 somewhere? I was using 2.33 originally before this

  2. woodyz
    Member
    Posted 6 years ago #

    I am also having problems inserting images into my posts.

    There is a lot of odd behavior using the Add Media functionality. I am able to upload images, but inserting an image is not working well. I have tried IE7, IE6, and Firefox in a windows environment.

    Inserting an image can end in any one of several undesireble results. I have not found a way to make it work the same way every time.

    What I am doing temporarily is to copy the html from previous posts and changing the various values for the current image.

  3. wizardgold
    Member
    Posted 6 years ago #

    having trouble with inserting images too. I am getting a blank window popup with

    Are you sure you want to do this?

    Please try again.

    When I click on Please try again I get the write post inside that popup window.

    when I click on the button with the little tree to add an image I just get a smaller empty window with nothing in it.

    I like the look of 2.5 but I doo need to be able to insert images

  4. pmars
    Member
    Posted 6 years ago #

    Images seem to upload, but 2.5 says it cannot create the necessary folders for image storage, although test posts (without images) display the correct folder hierarchy in a browser bar. (wp/wp-content/2008/04) I think that the database is converting the info to display in a browser, but not actually creating those folders, which compounds trouble shooting, for me anyway! When I look with FTP, there are NO Folders!

    That that is... is
    That that is not... is not
    Is not that it? It is!

    Thanks and good luck to all!

  5. buntstift
    Member
    Posted 6 years ago #

    my problem appears this way:

    after choosing an image from my desktop to upload i get redirected to the login screen which looks a bit weird:
    http://i106.photobucket.com/albums/m268/defaulty/uploadproblem1.jpg

    after filling in name and passwort an error appears inside the flash window:
    http://i106.photobucket.com/albums/m268/defaulty/uploadproblem2.jpg
    "the requested url was not found on the server"

    and the images did not appear in the upload-folder (wp-content/uploads/2008/04). there isn't a solution for me yet except of uploading the pictures via ftp to the server.

    i tried all of the possible solutions in the sticky post, except of the no-flash-plugin. i am going to try this now.

  6. jkslouth
    Member
    Posted 6 years ago #

    If I try to upload an image from my computer using the Add Media function, I just get an HTTP Error and the message "There was an error uploading your file please try later"

  7. photolord
    Member
    Posted 6 years ago #

    I am having issues too in 2.5 with it giving me the login screen after crunching and then when you log in, it says that the post is not on the server. It is a problem for safari, opera, and firefox. The only one that works a little is IE& with the IE-fix on the sticky. But at the most I can still only upload 10 images or so before I get the infamous http error. I've been trying and I still can't get a grip on what is causing it. I'll just keep trying. I've lost a couple days at least trying to figure it out.

  8. buntstift
    Member
    Posted 6 years ago #

    weird stuff.
    but i did try the no-flash-plugin from the sticky post now (did you?) and i can perfectly live with it now. it still looks better than in older versions of wordpress. i think i'll stick with the no-flash-option.
    actually: all in all i am pretty pleased that the upgrade to 2.5 worked pretty well, far better than i expected.

  9. photolord
    Member
    Posted 6 years ago #

    buntstift:

    When I enable the no-flash plugin it only lets me upload one at a time. I wanted to upload 50 or 100 at a time for the gallery function without getting the http error. Are you able to upload more than one photo at a time when you have the no-flash plugin enabled?

  10. pmars
    Member
    Posted 6 years ago #

    I have started this reply over 3 times now.... never mind!

  11. buntstift
    Member
    Posted 6 years ago #

    @ photolord: no, i can't. i am not dealing with galleries. sorry i misunderstood you.

  12. solus
    Member
    Posted 6 years ago #

    As crianp said "I love the new wordpress version with the exception of the fact that it is much harder for me to insert images now. The new "add medi" option does not want to work for me." I feel the same thing. it's not working I can upload but from there to the post no way.
    I'm seriously thinking of going back to an older version of WP where the inserting of image was much more simple and worked.
    But at present: I have reupload wp even in a different place but nothing helps and get no error message it just don't work, so for the moment I manualy upload my images and insert them manualy with html code.
    Is there solution to this nightmare or do hope for a version of wp to solve this problem?

  13. dustmagic
    Member
    Posted 6 years ago #

    This worked for me with 2.5 -

    Check if you have the 'uploads' folder in
    wp-content, create it manually if not.
    Set permissions on the folder to 777.

    Add this to your htaccess file -

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

    Your done! ;)

    hth

  14. virtualimpax
    Member
    Posted 6 years ago #

    DUSTMAGIC.... YOU ARE MY HERO!!!!

    THANK YOU!!!!

  15. geofones
    Member
    Posted 6 years ago #

    I did all the things that dustmagic recommended, the uploaded image is clearly in the uploads folder but I still cannot see how to put the image into the post! It is in the Gallery but how do i get it from the gallery into the post! please

  16. JesseG5
    Member
    Posted 6 years ago #

    How do you add to your htaccess file?

  17. Josh Leuze
    Member
    Posted 6 years ago #

    For me, the media uploader is uploading my images to the wp-admin directory. Is anyone else experiencing this?

  18. JesseG5
    Member
    Posted 6 years ago #

    My images are being uploaded where they are supposed to be and the images still wont show up in posts on homepage.

  19. Josh Leuze
    Member
    Posted 6 years ago #

    Ahh, I can't the the only one!

    As far as the .htaccess file, you can edit that in your favorite text editor. But you may have to create one if you hadn't added one to that directory before for some reason.

  20. iluminada
    Member
    Posted 6 years ago #

    I was having this same issue, getting an http error on image upload when using the media manager. I had my whole blog password protected via a .htaccess pwd instead of using WordPress' "password protect blog" setting. Disabled the .htpassword for my blog and all is well.

  21. pattayaghost
    Member
    Posted 6 years ago #

    I've had this problem since 2.5.1 and hoped upgrading to 2.6 would solve it.

    It didn't.

    I followed the upgrade directions to the letter, so I was not overwriting any files. Allt he fiels are new. Flash is updated.

    The probelem happens on both FF and IE7 on any computer I use, so it's not my browser. Furhter, on another 2.6 blog I contribute to it works fine, so it's not even my own comptuer with the problem.

    The error console box says the error is character 1 of line 4 of media-upload.php and the error is PERMISSION DENIED.

    However, I have not been able to find any post that talks about permissions. It's undoubtedly 1&1 and their crappy Linux hosting server (business package) but please someone tell me what permission needs to be set where.

  22. craiger
    Member
    Posted 6 years ago #

    pattayaghost,

    You are not alone: http://wordpress.org/support/topic/197027

Topic Closed

This topic has been closed to new replies.

About this Topic