WordPress.org

Ready to get started?Download WordPress

Forums

wordpress 2.5: gallery not showing at all (8 posts)

  1. UncleZeiv
    Member
    Posted 6 years ago #

    I can upload images but the [gallery] shortcode doesn't affect the final post.

    This problem has been driving me crazy, but I finally tracked the problem down. The SQL query is failing, because of bad formatting:

    ORDER BY \"menu_order ASC, ID ASC\" DESC

    Now this is probably a problem with my server since I seem to be the only one experiencing it. I'm writing here just in case someone else has the same problem and is having trouble figuring out what's going on.

  2. lsjblomberg
    Member
    Posted 6 years ago #

    I have the same problem. I use Next-Gen Gallery.
    The Problem is that the Gallary(thumbnail-prewiev) don't show up at all.

    I also use the "[gallary=ID]"-command.

    So you are not allone with this failure :-P

  3. lsjblomberg
    Member
    Posted 6 years ago #

    Updating ng-Gallery to version 0.92 solved my problem!

  4. UncleZeiv
    Member
    Posted 6 years ago #

    I refer to the default gallery code in WordPress 2.5 (lsjblomberg this doesn't seem to be the same problem).

    A more specific bug describes the problem:

  5. thrallz
    Member
    Posted 6 years ago #

    I tried to copy my blog to another distro and it works just fine. It seems only Debian has this problem AFAIK.

  6. thrallz
    Member
    Posted 6 years ago #

    oh right i have a same prob. btw :D

  7. UncleZeiv
    Member
    Posted 6 years ago #

    For future reference:

  8. macanics
    Member
    Posted 6 years ago #

    I found that the orderby parameter of gallery in 2.5 was broken. An incorrect SQL statement was being produced that meant that any orderby was ignored. This is now fixed in 2.5.1 and introduces a new value: 'orderby=RAND()' for random ordering.
    See this trac entry for more.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags