WordPress.org

Ready to get started?Download WordPress

Forums

WordPress 2.2.1, Postie plugin - *HOW TO* (10 posts)

  1. jedimacfan
    Member
    Posted 7 years ago #

    I am running WordPress 2.2.1 and would like to allow anyone who sends email to a specific address to automatically post to a site I have created.

    I have installed and setup the Postie plugin. However, the documentation references the WP-CRON plugin which is now obsolete. I have successfully gotten Postie to work, but ONLY if I manually run it by logging in and allowing the email posts to go through. I need help getting this to automatically check for mail, preferably every minute.

    I have access to cron on my server, and set up a cron job but it doesn't seem to work. Is there someting I have to do to the (now included) WP-CRON.PHP file to make this work? And since I know very little about PHP and cron, can anyone post exactly what I need to add if that is the case?

    FWIW, the blog is in a subfolder (www.domain.com/anotherfolder).

    Other than posting automatically, Postie seems to be working just fine.

  2. jedimacfan
    Member
    Posted 7 years ago #

    Setting up a cron job with help from my hosting company to check "http://oldfishandlemonade.com/iphone/wp-content/plugins/postie/get_mail.php" every 5 minutes does not work.

    Does this plugin not work with WordPress 2.2? All the documentation references WordPress 2.0 and 2.1 and the WP-CRON plugin which (apparently) does not work with 2.2.1. What the heck is WP-CRON? Is it built into WP 2.2.1? How do I set it up? Has ANYONE on the entire planet ever gotten Postie to work with WP 2.2?

  3. jolato
    Member
    Posted 7 years ago #

    I also can't get postie (WP2.2.1/Postie 1.1.1) to work, although the postie config doesn't give any errors. But when I run wp-mail manualy I get "login failed". Of course could be the pw but that seems to work fine when I log in manually to the webmail. Any idea ? Very new to this.
    Thanks in advance,
    Jo

  4. jedimacfan
    Member
    Posted 7 years ago #

    I ended up getting it to work, but only by having a friend in Australia (who is better at cron jobs than I am) login and set it up. Now it works very well.

    What email are you using? (Gmail? Your own?) It sounds like you have not enabled POP email access for your email, which prevents Postie from logging in. This may or may not be an option, depending on who you use for email.

    The good news is that you can always setup a new account at a free email place so that it will work :) Post back and I will try and help you more if I can.

  5. jolato2
    Member
    Posted 7 years ago #

    Thanks a lot.. I created a new mail account with the provider of my blog and one with yahoo. The latter gives a protocol mismatch when I run config postie. The first one “there is no new mail”. When I run wp-mail it gives the login failed message. The webmail of the provider is Squirre mail.

    Manual Settings (provider - Squirre mail):
    Mail Server Username: tnwblog+patrizianorellibachelet.com
    Incoming Mail Server: mail.patrizianorellibachelet.com
    Outgoing Mail Server: mail.patrizianorellibachelet.com (server requires authentication)
    Supported Incoming Mail Protocols: POP3, POP3S (SSL/TLS), IMAP, IMAPS (SSL/TLS)
    Supported Outgoing Mail Protocols: SMTP, SMTPS (SSL/TLS)

  6. jedimacfan
    Member
    Posted 7 years ago #

    Are you using Postie or WP's built in email program? Because wp-mail.php has nothing to do with Postie. I do not use wp-mail.php with my blog.

  7. jolato
    Member
    Posted 7 years ago #

    Yes, I was not clear. I used postie to begin with. It always returned the same boring message "you have no new mail", even after the above set-up etc. So out of curiosity I manually launched wp-mail and also got the same message. Then I learned from someone that this last message was actually a misnomer and I adapted the code of wp-mail.php to have a more meaningfull error message. After that I got the "login failed" message, so I presume that this is also the reason why postie doens't see any new mail ?

    Hope that helps,
    Jo

  8. jedimacfan
    Member
    Posted 7 years ago #

    I'm not sure what is incorrect with your Postie setup. Don't bother filling out wp-mail.php because it's not used by Postie. Login to your Dashboard and Click the Options tab, then Confugre Postie. Make sure that you setup your email address and password here, and that your email account supports POP. Once that's done, send and email to the address you setup with Postie and try manually running Postie from within the config. See if that works first. If it does, then you just need to setup a cron job on your server to check for mail every few minutes or so.

  9. jolato2
    Member
    Posted 7 years ago #

    Yes, I have tried all that. One thing I am not sure of is whether my maul account supports POP or POP3: how to check that ? I have the following account for ex. : tnwblog@yahoo.com

  10. jolato
    Member
    Posted 7 years ago #

    I have run postie config and it said this:

    Unable to connect. The server said - POP3 connect: Error [110] [Connection timed out]
    Try putting in your full email address as a userid and try again.

  11. jolato
    Member
    Posted 7 years ago #

    .. which I did but same result. I suspect that my yahoo accountis POP and not POP3

Topic Closed

This topic has been closed to new replies.

About this Topic